summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2023-08-24 17:50:11 +1000
committerLuis Aranguren2023-08-24 17:50:11 +1000
commitf2bdb38af53e0b7f90406a35798360232cc61b3a (patch)
treef707dc4f4cde9ac655a1f4d9c091ecc8c569a0f3
parente2061d5d2122350c52b50700ba7d3b3c58cbd549 (diff)
downloadaur-zap-desktop-git.tar.gz
0.7.7.beta.r0.g086533a, reworked makedepends & depends, python2->python3
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0618e08af5f2..af1816d47c3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zap-desktop-git
pkgdesc = Lightning wallet focused on user experience and ease of use
- pkgver = 0.7.7.beta
+ pkgver = 0.7.7.beta.r0.g086533a
pkgrel = 1
url = https://github.com/LN-Zap/zap-desktop
arch = x86_64
@@ -8,13 +8,14 @@ pkgbase = zap-desktop-git
makedepends = npm
makedepends = yarn
makedepends = git
- makedepends = python2
- makedepends = lib32-glibc
+ makedepends = python
+ makedepends = glibc
makedepends = gcc-libs
- makedepends = lib32-gcc-libs
depends = gtk3
depends = nss
depends = libxss
+ depends = alsa-lib
+ depends = gnome-keyring
provides = zap-desktop
conflicts = zap-desktop-bin
conflicts = zap-desktop-appimage
diff --git a/PKGBUILD b/PKGBUILD
index bc7de5e0e918..31b547f2e53b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
-# Maintainer: David Parrish <daveparrish@tutanota.com>
+# Maintainer: Luis Aranguren <pizzaman@hotmail.com>
+# Contributor: David Parrish <daveparrish@tutanota.com>
pkgname=zap-desktop-git
-pkgver=0.7.7.beta
+pkgver=0.7.7.beta.r0.g086533a
pkgrel=1
pkgdesc="Lightning wallet focused on user experience and ease of use"
arch=('x86_64')
url="https://github.com/LN-Zap/zap-desktop"
license=('MIT')
-depends=('gtk3' 'nss' 'libxss')
-makedepends=('npm' 'yarn' 'git' 'python2' 'lib32-glibc' 'gcc-libs' 'lib32-gcc-libs')
+depends=('gtk3' 'nss' 'libxss' 'alsa-lib' 'gnome-keyring')
+makedepends=('npm' 'yarn' 'git' 'python' 'glibc' 'gcc-libs')
source=("$pkgname::git+https://github.com/LN-Zap/zap-desktop.git"
"zap-desktop.desktop")
sha256sums=('SKIP'
@@ -18,7 +19,7 @@ provides=("zap-desktop")
pkgver() {
cd "$pkgname" || exit
- git describe --tags | sed 's/^v//;s/-/./g'
+ git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {