summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKokaKiwi2022-09-19 14:28:01 +0200
committerKokaKiwi2022-09-19 14:28:01 +0200
commit0ebfec7bcb12b555e9b9abd2036871c6e82f8c78 (patch)
treeda511cced8152412146eaac4e37281e4891dd9d0
parent5f41b2d1ec71047ce45d6e55b3ef1e0a30257326 (diff)
downloadaur-0ebfec7bcb12b555e9b9abd2036871c6e82f8c78.tar.gz
Fix build
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-default-build-with-disable-cpp-tests.patch44
-rw-r--r--PKGBUILD10
3 files changed, 2 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e6955e51bf4..15cbd6865ea2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zeek
pkgdesc = A network analysis framework
pkgver = 5.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://zeek.org
arch = x86_64
license = BSD
@@ -20,12 +20,10 @@ pkgbase = zeek
depends = python
source = https://download.zeek.org/zeek-5.0.1.tar.gz
source = https://download.zeek.org/zeek-5.0.1.tar.gz.asc
- source = 0001-Fix-default-build-with-disable-cpp-tests.patch
source = zeek.tmpfiles.conf
validpgpkeys = 962FD2187ED5A1DD82FC478A33F15EAEF8CB8019
sha256sums = 3cd43ae446200e7e59a89a9bf8190d964f3198e517f5d4be9cc1daba67ba0b81
sha256sums = SKIP
- sha256sums = 3f5f0820480ecb2b160d948cfd3957ac26d4c48ecab95410eebbbfb6ac5380b4
sha256sums = af5b7e14caae88122d0e6dd29539ae77ed3388c70a12ea0ed73c9a3f6de16d91
pkgname = zeek
diff --git a/0001-Fix-default-build-with-disable-cpp-tests.patch b/0001-Fix-default-build-with-disable-cpp-tests.patch
deleted file mode 100644
index ef0f13576dd2..000000000000
--- a/0001-Fix-default-build-with-disable-cpp-tests.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From c40f8cc37b1c3a1b06dff681cfccb5ab97c51dba Mon Sep 17 00:00:00 2001
-From: Benjamin Bannier <benjamin.bannier@corelight.com>
-Date: Sat, 9 Jul 2022 11:07:46 +0200
-Subject: [PATCH] Fix default build with `--disable-cpp-tests`.
-
-For a build configured with `--disable-cpp-tests` we globally set
-`-DDOCTEST_CONFIG_DISABLE`. Spicy does not expect this define to be used
-and its unit tests fail to build with it.
-
-This patch adds a Zeek-side workaround for that. We now do not build the
-Spicy unit test targets as part of `ALL` anymore.
-
-Closes #2238.
----
- auxil/spicy/CMakeLists.txt | 16 ++++++++++++++++
- 1 file changed, 16 insertions(+)
-
-diff --git a/auxil/spicy/CMakeLists.txt b/auxil/spicy/CMakeLists.txt
-index 050ee9753..bae7ed6be 100644
---- a/auxil/spicy/CMakeLists.txt
-+++ b/auxil/spicy/CMakeLists.txt
-@@ -36,3 +36,19 @@ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-vla")
- set(HILTI_DEV_PRECOMPILE_HEADERS OFF)
-
- add_subdirectory(spicy)
-+
-+# Disable Spicy unit test targets.
-+#
-+# Spicy builds its unit tests as part of `ALL`. They are usually not only
-+# uninteresting for us but might cause problems. Since any configuration
-+# we do for our unit tests happens through global C++ compiler flags, they
-+# would get inherited directly by Spicy which can cause issues, e.g., we set
-+# `-DDOCTEST_CONFIG_DISABLE` if `ENABLE_ZEEK_UNIT_TESTS` is false, but Spicy
-+# unit test do not anticipate this define being set.
-+set_target_properties(
-+ hilti-rt-tests
-+ hilti-rt-configuration-tests
-+ spicy-rt-tests
-+ hilti-toolchain-tests
-+ spicy-toolchain-tests
-+ PROPERTIES EXCLUDE_FROM_ALL TRUE)
---
-2.37.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 71ec23fc50cf..96d4f609c54d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=zeek
pkgver=5.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="A network analysis framework"
arch=('x86_64')
url="https://zeek.org"
@@ -11,22 +11,14 @@ license=('BSD')
depends=(zlib libpcap bash libmaxminddb python)
makedepends=(cmake swig bison flex openssl geoip gperftools shadow)
source=("https://download.zeek.org/zeek-$pkgver.tar.gz"{,.asc}
- 0001-Fix-default-build-with-disable-cpp-tests.patch
zeek.tmpfiles.conf)
sha256sums=('3cd43ae446200e7e59a89a9bf8190d964f3198e517f5d4be9cc1daba67ba0b81'
'SKIP'
- '3f5f0820480ecb2b160d948cfd3957ac26d4c48ecab95410eebbbfb6ac5380b4'
'af5b7e14caae88122d0e6dd29539ae77ed3388c70a12ea0ed73c9a3f6de16d91')
validpgpkeys=(
962FD2187ED5A1DD82FC478A33F15EAEF8CB8019 # The Zeek Team <info@zeek.org>
)
-prepare() {
- cd "zeek-$pkgver"
-
- patch -Np1 -i "$srcdir/0001-Fix-default-build-with-disable-cpp-tests.patch"
-}
-
build() {
cmake -B build -S "zeek-$pkgver" \
-D CMAKE_INSTALL_PREFIX=/usr \