summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan Hardman2017-12-29 13:26:01 -0700
committerAlan Hardman2017-12-29 13:26:01 -0700
commitb6a9dc6f10192d1cbae5e3ebea677d9c095b7718 (patch)
tree865895601bcbae38a05f9deff79a23e9e5fa484a
downloadaur-zephyr-gtk-theme-git.tar.gz
Adding Zephyr GTK theme basic install
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c60525bc3998
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = zephyr-gtk-theme-git
+ pkgdesc = A dark pastel GTK theme built for Xfce, based on Breeze Dark
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://alanaktion.github.io/zephyr-gtk/
+ arch = any
+ license = LGPL
+ makedepends = gtk2
+ makedepends = gtk3
+ optdepends = gtk2: GTK+2 theme
+ optdepends = gtk3: GTK+3 theme
+ provides = zephyr-gtk-theme
+ conflicts = zephyr-gtk-theme
+ source = git+https://github.com/Alanaktion/zephyr-gtk.git
+ sha256sums = SKIP
+
+pkgname = zephyr-gtk-theme-git
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a36360c668d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alan Hardman <alan@phpizza.com>
+
+pkgname=zephyr-gtk-theme-git
+pkgver=1.0
+pkgrel=1
+pkgdesc='A dark pastel GTK theme built for Xfce, based on Breeze Dark'
+arch=('any')
+url='https://alanaktion.github.io/zephyr-gtk/'
+license=('LGPL')
+depends=()
+makedepends=('gtk2'
+ 'gtk3'
+ )
+optdepends=('gtk2: GTK+2 theme'
+ 'gtk3: GTK+3 theme'
+ )
+provides=('zephyr-gtk-theme')
+conflicts=('zephyr-gtk-theme')
+source=('git+https://github.com/Alanaktion/zephyr-gtk.git')
+sha256sums=('SKIP')
+
+package() {
+ install -dm755 $pkgdir/usr/share/themes
+ cp -R zephyr-gtk $pkgdir/usr/share/themes/Zephyr
+ rm -rf $pkgdir/usr/share/themes/Zephyr/.git
+}
+