summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-09-17 13:40:00 +0800
committerChocobo12020-09-17 14:05:38 +0800
commitd72d75c95cc092820b4fad2bc75aa8f577edb0e2 (patch)
tree38794a68da7dbc761a35333f05c8e0d99c0a4ed3
parentc7691b194416135ca0a3a78d6f8366041bee19a6 (diff)
downloadaur-d72d75c95cc092820b4fad2bc75aa8f577edb0e2.tar.gz
upgpkg: zeromq-git 4.3.3.r6.g86bf83bc-1
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD70
2 files changed, 42 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c0802d855bd..ff56bc33f204 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,25 @@
-# Generated by mksrcinfo v8
-# Tue Dec 19 23:04:19 UTC 2017
pkgbase = zeromq-git
- pkgdesc = ZeroMQ core engine in C++
- pkgver = 20160724
+ pkgdesc = Fast messaging system built on sockets. C and C++ bindings. aka 0MQ, ZMQ
+ pkgver = 4.3.3.r6.g86bf83bc
pkgrel = 1
- url = https://github.com/zeromq/libzmq
+ url = https://zeromq.org/
arch = i686
arch = x86_64
- license = LGPL3
- makedepends = autoconf
- makedepends = automake
- makedepends = gcc
+ license = GPL
+ license = LGPL
makedepends = git
- makedepends = libtool
- makedepends = make
- makedepends = pkg-config
- depends = gcc-libs
+ makedepends = asciidoc
+ makedepends = pkgconf
+ makedepends = xmlto
+ depends = glibc
depends = libpgm
+ depends = libsodium
+ depends = util-linux
provides = zeromq
conflicts = zeromq
options = staticlibs
- source = zeromq::git+https://github.com/zeromq/libzmq
- source = https://raw.githubusercontent.com/zeromq/cppzmq/master/zmq.hpp
+ source = git+https://github.com/zeromq/libzmq.git
+ source = git+https://github.com/zeromq/cppzmq.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 11aa0bf40b49..353c3570257c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,68 +1,56 @@
-# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+# Previous maintainer: Andy Weidenbaum <archbaum@gmail.com>
# Contributor: Daniel YC Lin <dlin.tw at gmail.com>
# Contributor: boypt <pentie at gmail.com>
# Contributor: Kyle Keen <keenerd@gmail.com>
pkgname=zeromq-git
-pkgver=20160724
+pkgver=4.3.3.r6.g86bf83bc
pkgrel=1
-pkgdesc="ZeroMQ core engine in C++"
+pkgdesc="Fast messaging system built on sockets. C and C++ bindings. aka 0MQ, ZMQ"
arch=('i686' 'x86_64')
-depends=('gcc-libs' 'libpgm')
-makedepends=('autoconf' 'automake' 'gcc' 'git' 'libtool' 'make' 'pkg-config')
-url="https://github.com/zeromq/libzmq"
-license=('LGPL3')
+url="https://zeromq.org/"
+license=('GPL' 'LGPL')
+depends=('glibc' 'libpgm' 'libsodium' 'util-linux')
+makedepends=('git' 'asciidoc' 'pkgconf' 'xmlto')
+provides=('zeromq')
+conflicts=('zeromq')
options=('staticlibs')
-source=(${pkgname%-git}::git+https://github.com/zeromq/libzmq
- https://raw.githubusercontent.com/zeromq/cppzmq/master/zmq.hpp)
+source=("git+https://github.com/zeromq/libzmq.git"
+ "git+https://github.com/zeromq/cppzmq.git")
sha256sums=('SKIP'
'SKIP')
-provides=('zeromq')
-conflicts=('zeromq')
+
pkgver() {
- cd ${pkgname%-git}
- git log -1 --format="%cd" --date=short --no-show-signature | sed "s|-||g"
+ cd "libzmq"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd ${pkgname%-git}
+ cd "libzmq"
- msg2 'Building...'
./autogen.sh
./configure \
- --prefix=/usr \
- --sbindir=/usr/bin \
- --libexecdir=/usr/lib/zeromq \
- --sysconfdir=/etc \
- --sharedstatedir=/usr/share/zeromq \
- --localstatedir=/var/lib/zeromq \
- --disable-perf \
+ --prefix="/usr" \
+ --disable-Werror \
--enable-static \
- --with-gnu-ld \
- --with-pgm \
- --without-docs
+ --with-libsodium \
+ --with-pgm
make
}
-package() {
- cd ${pkgname%-git}
+check() {
+ cd "libzmq"
- msg2 'Installing license...'
- install -Dm 644 COPYING* -t "$pkgdir/usr/share/licenses/zeromq"
+ #make check
+}
- msg2 'Installing...'
+package() {
+ cd "$srcdir/libzmq"
make DESTDIR="$pkgdir" install
- msg2 'Installing zmq.hpp...'
- install -Dm 644 "$srcdir/zmq.hpp" -t "$pkgdir/usr/include"
-
- msg2 'Renaming binaries...'
- for _bin in $(find "$pkgdir/usr/bin" -type f -printf '%f\n'); do
- mv "$pkgdir/usr/bin/$_bin" "$pkgdir/usr/bin/zmq_$_bin"
- done
-
- msg2 'Cleaning up pkgdir...'
- find "$pkgdir" -type d -name .git -exec rm -r '{}' +
- find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
+ cd "$srcdir/cppzmq"
+ install -Dm644 {zmq.hpp,zmq_addon.hpp} -t "$pkgdir/usr/include"
}