summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDiab Neiroukh2021-03-17 23:59:52 +0000
committerDiab Neiroukh2021-03-18 00:14:52 +0000
commit1e275314a3c26640febf4b3da6850bb5e25b28f5 (patch)
treeac7170637f3701df91885b4b24773966c39d37eb
downloadaur-1e275314a3c26640febf4b3da6850bb5e25b28f5.tar.gz
Initial Commit
Signed-off-by: Diab Neiroukh <lazerl0rd@thezest.dev>
-rw-r--r--.SRCINFO46
-rw-r--r--.gitignore5
-rw-r--r--LICENSE26
-rw-r--r--PKGBUILD130
-rw-r--r--logrotate11
-rw-r--r--service15
6 files changed, 233 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a30106e264f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+pkgbase = zestginx
+ pkgdesc = A modern, performant, and secure NGINX distribution packed with features.
+ pkgver = 1.19.8
+ pkgrel = 1
+ url = https://github.com/ZestProjects/zestginx
+ arch = any
+ license = custom
+ makedepends = cmake
+ makedepends = git
+ makedepends = rust>=1.39
+ depends = geoip
+ depends = libatomic_ops
+ depends = liburing
+ depends = libxcrypt
+ depends = mailcap
+ depends = mimalloc
+ depends = pcre
+ depends = zstd
+ backup = etc/logrotate.d/nginx
+ backup = etc/nginx/fastcgi.conf
+ backup = etc/nginx/fastcgi_params
+ backup = etc/nginx/koi-utf
+ backup = etc/nginx/koi-win
+ backup = etc/nginx/nginx.conf
+ backup = etc/nginx/scgi_params
+ backup = etc/nginx/uwsgi_params
+ backup = etc/nginx/win-utf
+ source = git+https://github.com/ZestProjects/zestginx.git
+ source = https://nginx.org/LICENSE
+ source = logrotate
+ source = service
+ b2sums = SKIP
+ b2sums = fbd993990b43a4476d0963287bdc5f55f73fa5ce828f11977cf1abeedd478729a95861d930e27c6a1b0e78b16397164395afc4473fd34e050cadd32b94336beb
+ b2sums = 6a8f31fe0c0a91487ae6ff209b0e43f0619ecc4a9eeaaede8c478ce041ac9b0fd94125fab064c9451800e3f5a6002ee80e92541032e3dfc426552bf4fa12dc00
+ b2sums = 7ed09ce30b7fff528b4c11f95d3ca66cdf8f570a200851525a45235f35ea4719d495134670b0cad03049448e51bd574fd0719508ed232fa526687f5297b7c3be
+
+pkgname = zestginx
+ provides = nginx
+ conflicts = nginx
+ replaces = nginx-zest-git
+
+pkgname = zestginx-src
+ pkgdesc = The source code of Zestginx, which is useful for building dynamic modules.
+ depends =
+ replaces = nginx-zest-src-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2dfd68123c19
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+zestginx/
+
+*.pkg.*
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..0ec178cc94e8
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,26 @@
+/*
+ * Copyright (C) 2002-2020 Igor Sysoev
+ * Copyright (C) 2011-2020 Nginx, Inc.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ */
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..383498215f9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,130 @@
+# Maintainer: Diab Neiroukh <lazerl0rd at thezest dot dev>
+
+pkgbase="zestginx"
+pkgver="1.19.8"
+pkgrel=1
+arch=("any")
+pkgname=("zestginx" "zestginx-src")
+pkgdesc="A modern, performant, and secure NGINX distribution packed with features."
+url="https://github.com/ZestProjects/zestginx"
+license=("custom")
+depends=(
+ "geoip"
+ "libatomic_ops"
+ "liburing"
+ "libxcrypt"
+ "mailcap"
+ "mimalloc"
+ "pcre"
+ "zstd"
+)
+makedepends=(
+ "cmake"
+ "git"
+ "rust>=1.39"
+)
+source=(
+ "git+$url.git"
+ "https://nginx.org/LICENSE"
+ "logrotate"
+ "service"
+)
+b2sums=(
+ "SKIP"
+ "fbd993990b43a4476d0963287bdc5f55f73fa5ce828f11977cf1abeedd478729a95861d930e27c6a1b0e78b16397164395afc4473fd34e050cadd32b94336beb"
+ "6a8f31fe0c0a91487ae6ff209b0e43f0619ecc4a9eeaaede8c478ce041ac9b0fd94125fab064c9451800e3f5a6002ee80e92541032e3dfc426552bf4fa12dc00"
+ "7ed09ce30b7fff528b4c11f95d3ca66cdf8f570a200851525a45235f35ea4719d495134670b0cad03049448e51bd574fd0719508ed232fa526687f5297b7c3be"
+)
+backup=(
+ "etc/logrotate.d/nginx"
+ "etc/nginx/fastcgi.conf"
+ "etc/nginx/fastcgi_params"
+ "etc/nginx/koi-utf"
+ "etc/nginx/koi-win"
+ "etc/nginx/nginx.conf"
+ "etc/nginx/scgi_params"
+ "etc/nginx/uwsgi_params"
+ "etc/nginx/win-utf"
+)
+
+prepare()
+{
+ cp -r "$pkgbase"{,"-src"}
+ rm -rf "$pkgbase-src/.git"
+ cd "$pkgbase"
+ git submodule update --init
+}
+
+build()
+{
+ export CFLAGS="${CFLAGS//-flto/}"
+ export CFLAGS="${CFLAGS//-flto=thinlto/}"
+ export CXXFLAGS="${CXXFLAGS//-flto/}"
+ export CXXFLAGS="${CXXFLAGS//-flto=thinlto/}"
+ export LDFLAGS="$LDFLAGS -lmimalloc"
+
+ cd "$pkgbase"
+ ./configure \
+ --prefix="/etc/nginx" \
+ --conf-path="/etc/nginx/nginx.conf" \
+ --sbin-path="/usr/bin/nginx" \
+ --pid-path="/var/run/nginx.pid" \
+ --lock-path="/var/run/lock/nginx.lock" \
+ --user="http" \
+ --group="http" \
+ --http-log-path="/var/log/nginx/access.log" \
+ --error-log-path="stderr" \
+ --http-client-body-temp-path="/var/lib/nginx/client-body" \
+ --http-proxy-temp-path="/var/lib/nginx/proxy" \
+ --http-fastcgi-temp-path="/var/lib/nginx/fastcgi" \
+ --http-scgi-temp-path="/var/lib/nginx/scgi" \
+ --http-uwsgi-temp-path="/var/lib/nginx/uwsgi" \
+ --with-cc-opt="$CFLAGS $CPPFLAGS" \
+ --with-ld-opt="$LDFLAGS"
+ make
+}
+
+package_zestginx()
+{
+ provides=("nginx")
+ replaces=("nginx-zest-git")
+ conflicts=("nginx")
+
+ cd "$pkgbase"
+ make DESTDIR="$pkgdir" install
+
+ sed -e "s|\<user\s\+\w\+;|user html;|g" \
+ -e "44s|html|/usr/share/nginx/html|" \
+ -e "54s|html|/usr/share/nginx/html|" \
+ -i "$pkgdir/etc/nginx/nginx.conf"
+
+ rm "$pkgdir/etc/nginx/"*".default"
+ rm "$pkgdir/etc/nginx/mime.types"
+ install -d "$pkgdir/var/lib/nginx"
+ install -dm700 "$pkgdir/var/lib/nginx/proxy"
+ chmod 755 "$pkgdir/var/log/nginx"
+ chown "root":"root" "$pkgdir/var/log/nginx"
+ install -d "$pkgdir/usr/share/nginx"
+ mv "$pkgdir/etc/nginx/html" "$pkgdir/usr/share/nginx/"
+ install -Dm644 "../logrotate" "$pkgdir/etc/logrotate.d/nginx"
+ install -Dm644 "../service" "$pkgdir/usr/lib/systemd/system/nginx.service"
+ install -Dm644 "../LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ rmdir "$pkgdir/var/run"
+ install -d "$pkgdir/usr/share/man/man8"
+ gzip -9c "docs/man/nginx.8" > "$pkgdir/usr/share/man/man8/nginx.8.gz"
+
+ for i in "indent" "ftdetect" "syntax"; do
+ install -Dm644 "contrib/vim/$i/nginx.vim" \
+ "$pkgdir/usr/share/vim/vimfiles/$i/nginx.vim"
+ done
+}
+
+package_zestginx-src()
+{
+ pkgdesc="The source code of Zestginx, which is useful for building dynamic modules."
+ replaces=("nginx-zest-src-git")
+ depends=()
+
+ install -d "$pkgdir/usr/src"
+ cp -r "$pkgbase-src" "$pkgdir/usr/src/$pkgname"
+}
diff --git a/logrotate b/logrotate
new file mode 100644
index 000000000000..b7719f0ce97c
--- /dev/null
+++ b/logrotate
@@ -0,0 +1,11 @@
+/var/log/nginx/*log
+{
+ missingok
+ notifempty
+ create 640 http log
+ sharedscripts
+ compress
+ postrotate
+ test ! -r /var/run/nginx.pid || kill -USR1 `cat /var/run/nginx.pid`
+ endscript
+}
diff --git a/service b/service
new file mode 100644
index 000000000000..258a8e09ba7c
--- /dev/null
+++ b/service
@@ -0,0 +1,15 @@
+[Unit]
+Description = Zestginx Web Server
+After = network.target network-online.target nss-lookup.target
+
+[Service]
+ExecReload = /usr/bin/nginx -s reload
+ExecStart = /usr/bin/nginx -g "pid /var/run/nginx.pid; error_log stderr;"
+KillMode = mixed
+PIDFile = /var/run/nginx.pid
+PrivateDevices = yes
+SyslogLevel = err
+Type = forking
+
+[Install]
+WantedBy = multi-user.target