summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDiab Neiroukh2021-03-18 22:31:07 +0000
committerDiab Neiroukh2021-03-18 22:31:07 +0000
commitf058b6cdf17b24b5fba87a2c723154b265c8a30a (patch)
tree369178cd0d51b9a895483283976be03dc950e950
parentb993a352c4f23bc3d6b267aa5842ae3d94e1029c (diff)
downloadaur-f058b6cdf17b24b5fba87a2c723154b265c8a30a.tar.gz
PKGBUILD: Avoid explictly setting flags to improve toolchain support.
Signed-off-by: Diab Neiroukh <lazerl0rd@thezest.dev>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 3 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab7f3e0d734f..eb2e6b8b58d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zestginx
pkgdesc = A modern, performant, and secure NGINX distribution packed with features.
pkgver = 1.19.8
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ZestProjects/zestginx
arch = any
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index 1cc7618eefc1..57dc2497398a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase="zestginx"
pkgver="1.19.8"
-pkgrel=2
+pkgrel=3
arch=("any")
pkgname=("zestginx" "zestginx-src")
pkgdesc="A modern, performant, and secure NGINX distribution packed with features."
@@ -57,12 +57,6 @@ prepare()
build()
{
- export CFLAGS="${CFLAGS//-flto/}"
- export CFLAGS="${CFLAGS//-flto=thinlto/}"
- export CXXFLAGS="${CXXFLAGS//-flto/}"
- export CXXFLAGS="${CXXFLAGS//-flto=thinlto/}"
- export LDFLAGS="$LDFLAGS -lmimalloc"
-
cd "$pkgbase"
./configure \
--prefix="/etc/nginx" \
@@ -79,8 +73,7 @@ build()
--http-fastcgi-temp-path="/var/lib/nginx/fastcgi" \
--http-scgi-temp-path="/var/lib/nginx/scgi" \
--http-uwsgi-temp-path="/var/lib/nginx/uwsgi" \
- --with-cc-opt="$CFLAGS $CPPFLAGS" \
- --with-ld-opt="$LDFLAGS"
+ --with-ld-opt="-lmimalloc"
make
}