summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc Tiehuis2019-04-20 20:19:34 +1200
committerMarc Tiehuis2019-04-20 20:19:34 +1200
commit74dfce9e012ea98c6589ddf0910560442dd2fccc (patch)
tree0289627ea0fb65fd9d579eaddeceed7a09ca59b6
parent4086d785ad4261aac6db533bc0be7dbda8bb1674 (diff)
downloadaur-74dfce9e012ea98c6589ddf0910560442dd2fccc.tar.gz
Update no_stage2_artifacts patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--no_stage2_artifacts.patch19
3 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68073ad1e97d..ea5e7bc2d4a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zig-git
pkgdesc = a programming language prioritizing robustness, optimality, and clarity
- pkgver = 0.3.0r3806.3f13a59c
+ pkgver = 0.4.0.r83.g1030cc97
pkgrel = 1
url = http://ziglang.org
arch = i686
@@ -17,7 +17,7 @@ pkgbase = zig-git
source = no_stage2_artifacts.patch
md5sums = SKIP
md5sums = 9a935ede50ab8f1a789349fc3b760c1c
- md5sums = cb0bbf9c19971a48eff41e8c764ac990
+ md5sums = 84fdaa44cae56d85ee4604a95fa2ccd7
pkgname = zig-git
diff --git a/PKGBUILD b/PKGBUILD
index 2a16f1846baa..6c0d597b4a5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Marc Tiehuis <marctiehuis at gmail.com>
pkgname=zig-git
-pkgver=0.3.0r3806.3f13a59c
+pkgver=0.4.0.r83.g1030cc97
pkgrel=1
pkgdesc="a programming language prioritizing robustness, optimality, and clarity"
arch=('i686' 'x86_64')
@@ -12,7 +12,7 @@ makedepends=('cmake' 'git')
provides=(zig)
conflicts=(zig)
source=("git://github.com/zig-lang/zig.git" 'force_dynamic_llvm.patch' 'no_stage2_artifacts.patch')
-md5sums=('SKIP' '9a935ede50ab8f1a789349fc3b760c1c' 'cb0bbf9c19971a48eff41e8c764ac990')
+md5sums=('SKIP' '9a935ede50ab8f1a789349fc3b760c1c' '84fdaa44cae56d85ee4604a95fa2ccd7')
prepare() {
cd "$srcdir/$provides"
@@ -22,7 +22,7 @@ prepare() {
pkgver() {
cd "$srcdir/$provides"
- printf "0.3.0r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
diff --git a/no_stage2_artifacts.patch b/no_stage2_artifacts.patch
index a89edcc58450..76c25be374a0 100644
--- a/no_stage2_artifacts.patch
+++ b/no_stage2_artifacts.patch
@@ -1,8 +1,11 @@
+ CMakeLists.txt | 2 --
+ 1 file changed, 2 deletions(-)
+
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index bda57634..52599838 100644
+index f70f79c1..13b3b676 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -254,7 +254,6 @@ else()
+@@ -257,7 +257,6 @@ else()
embedded_lld_wasm
embedded_lld_lib
)
@@ -10,11 +13,11 @@ index bda57634..52599838 100644
endif()
# No patches have been applied to SoftFloat-3e
-@@ -775,7 +774,6 @@ if(MSVC OR MINGW)
- target_link_libraries(zig LINK_PUBLIC version)
- endif()
- install(TARGETS zig DESTINATION bin)
+@@ -6640,7 +6639,6 @@ add_library(zig_cpp STATIC ${ZIG_CPP_SOURCES})
+ set_target_properties(zig_cpp PROPERTIES
+ COMPILE_FLAGS ${EXE_CFLAGS}
+ )
-install(TARGETS zig_cpp DESTINATION "${ZIG_CPP_LIB_DIR}")
- foreach(file ${ZIG_C_HEADER_FILES})
- get_filename_component(file_dir "${C_HEADERS_DEST}/${file}" DIRECTORY)
+ add_library(opt_c_util STATIC ${OPTIMIZED_C_SOURCES})
+ set_target_properties(opt_c_util PROPERTIES