summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibele2021-07-18 20:39:15 -0500
committerlibele2021-07-18 20:39:15 -0500
commitb3f5ede4065323a40540fdcc5fde05d31aef6d3b (patch)
tree9358423d350179119358115bab987c60b69f07dc
parenta1e1f9ce0ef438f8590ac9cb42fad90cdb2f5097 (diff)
downloadaur-zilf.tar.gz
re-write PKGBUILD, update source
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD47
2 files changed, 27 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ba176c77614..a9b3b3a4071b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,12 @@
pkgbase = zilf
- pkgdesc = Tools for working with the ZIL fiction language, including a compiler and assembler
+ pkgdesc = A set of tools for working with the ZIL interactive fiction language, including a compiler, assembler, disassembler, and game library.
pkgver = 0.9.0
- pkgrel = 0
- url = https://bitbucket.org/jmcgrew/zilf
+ pkgrel = 1
+ url = https://foss.heptapod.net/zilf/zilf
arch = x86_64
license = GPL
options = !strip
- source = https://bitbucket.org/jmcgrew/zilf/downloads/zilf-0.9.0-linux-x64.tar.gz
- source = https://bitbucket.org/jmcgrew/zilf/downloads
- sha512sums = afc1c54d4fa8d4910ce61c3619ccfc9cb8fd16bdb70cdc0c2ddbebbce4e3abe9064f46ae29e358060d9a80c827a9d73062c9ef89df371f61e151bf16777216e9
- sha512sums = SKIP
+ source = https://storage.googleapis.com/zilf-releases/0.9/zilf-0.9.0-linux-x64.tar.gz
+ md5sums = 6e9697774bfb20f1b3768e6dff98b720
pkgname = zilf
-
diff --git a/PKGBUILD b/PKGBUILD
index d951012b9df4..4b7543614812 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,30 @@
-# Maintainer: Alex Gentilucci <alexander.gentilucci@gmail.com>
+# maintainer: libele <libele@disroot.org>
+# contributor: Alex Gentilucci <alexander.gentilucci@gmail.com>
+
pkgname=zilf
pkgver=0.9.0
-pkgrel=0
-epoch=
-pkgdesc="Tools for working with the ZIL fiction language, including a compiler and assembler"
+_rlver=0.9
+pkgrel=1
+pkgdesc="A set of tools for working with the ZIL interactive fiction language, including a compiler, assembler, disassembler, and game library."
arch=('x86_64')
-url="https://bitbucket.org/jmcgrew/zilf"
+url="https://foss.heptapod.net/zilf/zilf"
license=('GPL')
options=('!strip')
-source=("https://bitbucket.org/jmcgrew/zilf/downloads/zilf-$pkgver-linux-x64.tar.gz"
- "https://bitbucket.org/jmcgrew/zilf/downloads")
-sha512sums=('afc1c54d4fa8d4910ce61c3619ccfc9cb8fd16bdb70cdc0c2ddbebbce4e3abe9064f46ae29e358060d9a80c827a9d73062c9ef89df371f61e151bf16777216e9'
- 'SKIP')
-
-prepare() {
- _commit=$(grep -oE "get\/([0-9a-fA-F]+)" downloads | cut -c 5-)
- curl -O "https://bitbucket.org/jmcgrew/zilf/get/$_commit.zip"
- unzip -q "$_commit.zip" -d "$srcdir"
-}
+source=("https://storage.googleapis.com/${pkgname}-releases/${_rlver}/${pkgname}-${pkgver}-linux-x64.tar.gz")
+md5sums=('6e9697774bfb20f1b3768e6dff98b720')
package() {
- _commit=$(grep -oE "get\/([0-9a-fA-F]+)" downloads | cut -c 5-)
- install -d -m 755 "$pkgdir/usr/lib/zilf"
- install -d -m 755 "$pkgdir/usr/lib/zilf/library"
- cp -dpr --no-preserve=ownership "$srcdir/$pkgname-$pkgver-linux-x64/bin/"* "$pkgdir/usr/lib/zilf"
- cp -dpr --no-preserve=ownership "$srcdir/jmcgrew-zilf-$_commit/zillib/"* "$pkgdir/usr/lib/zilf/library/"
- chmod ugo+x "$pkgdir/usr/lib/zilf/zilf"
- chmod ugo+x "$pkgdir/usr/lib/zilf/zapf"
- mkdir -p ${pkgdir}/usr/bin
- ln -sf "/usr/lib/zilf/zilf" "$pkgdir/usr/bin/zilf"
- ln -sf "/usr/lib/zilf/zapf" "$pkgdir/usr/bin/zapf"
+ cd "${srcdir}/${pkgname}-${pkgver}"-linux-x64
+
+ install -dm755 "${pkgdir}"/usr/bin
+ install -dm755 "${pkgdir}/usr/lib/${pkgname}"
+ install -dm755 "${pkgdir}/usr/share/${pkgname}"
+
+ install -Dm755 bin/* "${pkgdir}/usr/lib/${pkgname}"
+
+ mv zillib "${pkgdir}/usr/lib/${pkgname}/zillib"
+ mv sample "${pkgdir}/usr/share/${pkgname}/sample"
+
+ ln -sf /usr/lib/"${pkgname}"/zilf "${pkgdir}"/usr/bin/zilf
+ ln -sf /usr/lib/"${pkgname}"/zapf "${pkgdir}"/usr/bin/zapf
}