summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2016-02-03 17:11:34 +0100
committerChristopher Arndt2016-02-03 17:11:34 +0100
commit530e15ea99aea97a97ca57833ab835d07ad171eb (patch)
tree0c0d850a32a045ae78b3f49324e0c0e017ffcc48
downloadaur-zita-lrx.tar.gz
Ported package zita-lrx from AUR 3 archive
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD37
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2da8a0637ba6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Feb 3 16:11:05 UTC 2016
+pkgbase = zita-lrx
+ pkgdesc = A command line jack application providing 2, 3, or 4-band, 4th order crossover filters.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = http://kokkinizita.linuxaudio.org/linuxaudio/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = clthreads>=2.4.0
+ depends = jack
+ source = http://kokkinizita.linuxaudio.org/linuxaudio/downloads/zita-lrx-0.1.0.tar.bz2
+ md5sums = 84c1aa2b8550e0d6771d6c8b5281f986
+
+pkgname = zita-lrx
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ba46473007fb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+pkg/
+src/
+.AURINFO
+zita-lrx/
+zita-lrx-*.tar.xz
+zita-lrx-*.src.tar.gz
+zita-lrx-*.tar.gz
+zita-lrx-*.tar.bz2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14f48d6d70bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Contributor: SpepS <dreamspepser at yahoo dot it>
+
+pkgname=zita-lrx
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A command line jack application providing 2, 3, or 4-band, 4th order crossover filters."
+arch=(i686 x86_64)
+url="http://kokkinizita.linuxaudio.org/linuxaudio/"
+license=('GPL3')
+depends=('clthreads>=2.4.0' 'jack')
+source=("${url}downloads/$pkgname-$pkgver.tar.bz2")
+md5sums=('84c1aa2b8550e0d6771d6c8b5281f986')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/source"
+
+ make PREFIX=/usr
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/source"
+
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
+
+ # doc
+ install -d "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm644 ../README* \
+ "$pkgdir/usr/share/doc/$pkgname"
+
+ # examples
+ install -d "$pkgdir/usr/share/$pkgname/examples"
+ install -Dm644 ../examples/* \
+ "$pkgdir/usr/share/$pkgname/examples"
+}
+
+# vim:set ts=2 sw=2 et: