summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalazs Ferenc Mezei2018-10-05 02:36:19 +0100
committerBalazs Ferenc Mezei2018-10-05 02:36:19 +0100
commit0210b6afe765dca16ab7635fcb050768f6a07195 (patch)
tree231db24df124b4243c88acbce9c137930d21a6e6
parentd138e2bc0d497576cb14c589387e81a6cf9f8e2d (diff)
downloadaur-0210b6afe765dca16ab7635fcb050768f6a07195.tar.gz
Update to 1.3.018
-rw-r--r--.SRCINFO9
-rw-r--r--LICENSE52
-rw-r--r--PKGBUILD21
3 files changed, 70 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f747bcf4449d..f3ef1c6530f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = zmninja
pkgdesc = High performance, cross platform ionic app for Home/Commerical Security Surveillance using ZoneMinder or other NVRs
- pkgver = 1.3.016
+ pkgver = 1.3.018
pkgrel = 1
url = https://github.com/pliablepixels/zmNinja
arch = x86_64
license = custom:cc-by-nc-sa-4.0
license = custom
depends = gconf
- source = zmninja-1.3.016.zip::https://github.com/pliablepixels/zmNinja/releases/download/v1.3.016/zmNinja-linux64bit.zip
+ options = !strip
+ source = zmninja.AppImage::https://github.com/pliablepixels/zmNinja/releases/download/v1.3.018/zmninjapro-1.3.18-x86_64.AppImage
source = zmninja.desktop
source = cc-by-nc-sa-4.0.txt
+ source = LICENSE
source = zmninja.png
- sha256sums = a8b67fa19cee777a979479df53e5d472db95c5d21c9cd94b65775fc69baf691f
+ sha256sums = a77a45b28a8208b7ae5bb33bf8114c3521837e144c088a06de5f14b2b8502b42
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c7dbdbf59b40
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,52 @@
+License for apps on Play store/App store
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+The apps in Apple App store and Google Play store can be used for any purpose (personal, commercial etc). After all, you've paid for it.
+
+
+For Desktop Clients Binaries:
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+The Desktop clients binaries free to download and use ONLY for users
+who are using the desktop client with the free and open source ZoneMinder
+software. If you are selling a service based on ZoneMinder and are either distributing the Desktop Client to your users or asking your users to use the desktop client by download it themselves, you are violating the non-commercial use. You will need to procure a license before you do so.
+
+
+Source Code License
+~~~~~~~~~~~~~~~~~~~
+The source code of zmNinja is dual licensed.
+
+a) The code is free for personal, non commercial use
+http://creativecommons.org/licenses/by-nc-sa/4.0/
+In summary: Share Alike, Adapt,Attribute, NonCommercial
+
+b) zmNinja source code is also open for commercial licensing and white-labeling.
+Please contact pliablepixels@gmail.com
+
+
+
+Third Party credits
+===================
+Ninja icon;
+https://openclipart.org/detail/172393/ninja-logo
+License: https://openclipart.org/share
+
+Wizard Icon:
+https://openclipart.org/detail/4795/wizard-in-blue-hat
+License: https://openclipart.org/share
+
+Blop sound for notifications:
+http://soundbible.com/2067-Blop.html
+
+Version 1.1.0 and above of zmNinja uses Packery.
+http://packery.metafizzy.co
+
+A commercial single developer license has been purchased for the same.
+Note that this license allows me (pliablepixels) to use Packery for commercial
+apps that I develop (such as zmNinja). Given that I publish my source under
+CC BY-NC-SA 4.0, you can compile the code for your personal use (non commercial purposes)
+and continue to use Packery. This is compliant to Packery's license too, where they
+prohibit other developers to build for profit using the license I purchased.
+
+If however you purchase the source code from me, you will
+still have to purchase an additional license for Packery from David via http://packery.metafizzy.co/#commercial-license
+It's very cheap ($25 for unlimited products by one developer).
+
diff --git a/PKGBUILD b/PKGBUILD
index 2e5a45afa566..d798408f5f46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
# Maintainer: Balazs Mezei <mezei92@gmail.com>
pkgname=zmninja
-pkgver=1.3.016
+pkgver=1.3.018
+_customver=1.3.18
pkgrel=1
pkgdesc="High performance, cross platform ionic app for Home/Commerical Security Surveillance using ZoneMinder or other NVRs"
arch=(x86_64)
+options=(!strip)
url="https://github.com/pliablepixels/zmNinja"
license=('custom:cc-by-nc-sa-4.0' 'custom')
depends=('gconf')
-source=("${pkgname}-${pkgver}.zip::https://github.com/pliablepixels/zmNinja/releases/download/v$pkgver/zmNinja-linux64bit.zip" "zmninja.desktop" "cc-by-nc-sa-4.0.txt" "zmninja.png")
-sha256sums=("a8b67fa19cee777a979479df53e5d472db95c5d21c9cd94b65775fc69baf691f" "SKIP" "SKIP" "SKIP")
+source=("$pkgname.AppImage::https://github.com/pliablepixels/zmNinja/releases/download/v$pkgver/zmninjapro-$_customver-$arch.AppImage" "zmninja.desktop" "cc-by-nc-sa-4.0.txt" "LICENSE" "zmninja.png")
+sha256sums=("a77a45b28a8208b7ae5bb33bf8114c3521837e144c088a06de5f14b2b8502b42" "SKIP" "SKIP" "SKIP" "SKIP")
build() {
:
@@ -17,13 +19,14 @@ build() {
package() {
cd $pkgdir
- install -d usr/share/$pkgname
- cp -R $srcdir/zmNinja-linux64bit/* usr/share/$pkgname
- install -d usr/bin
- ln -s /usr/share/$pkgname/zmNinja usr/bin/$pkgname
+ install -d usr/lib/
+ install -d usr/bin/
+ ln -s /usr/lib/$pkgname/$pkgname.AppImage usr/bin/$pkgname
- install -D -m644 $srcdir/zmninja.desktop usr/share/applications/$pkgname.desktop
- install -D -m644 usr/share/$pkgname/ZMNINJA-LICENSE-DESKTOP-CLIENT.txt usr/share/licenses/$pkgname/LICENSE
+ install -D -m755 $srcdir/$pkgname.AppImage usr/lib/$pkgname/$pkgname.AppImage
+ install -D -m644 $srcdir/$pkgname.desktop usr/share/applications/$pkgname.desktop
+ install -D -m644 $srcdir/LICENSE usr/share/licenses/$pkgname/LICENSE
install -D -m644 $srcdir/cc-by-nc-sa-4.0.txt usr/share/licenses/$pkgname/cc-by-nc-sa-4.0.txt
install -D -m644 $srcdir/zmninja.png usr/share/pixmaps/$pkgname.png
+ sync
}