summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRadu Potop2022-03-31 23:01:58 +0100
committerRadu Potop2022-03-31 23:15:22 +0100
commitf4718f07101cb2e922a2f6a79560bde49a34e956 (patch)
treecc4bd9703f1c1c12b31dfa4a1b73c11f8d38b113
parent19178331de473812716a08761ac00739a310e808 (diff)
downloadaur-f4718f07101cb2e922a2f6a79560bde49a34e956.tar.gz
Added conflicts section, run shellcheck
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72197d1c8034..ec2f64182785 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zoho-cliq
pkgdesc = Zoho Cliq communication software
pkgver = 1.5.3
- pkgrel = 1
+ pkgrel = 2
url = https://www.zoho.com/cliq/desktop/linux.html
arch = x86_64
license = Proprietary
@@ -18,6 +18,7 @@ pkgbase = zoho-cliq
sha256sums = 6f7704bce3bf38ef8a8acd1177afb470a810e42ca8f67b5d17c7920c3c162132
pkgname = zoho-cliq
+ conflicts = zoho-cliq-upstream-electron
pkgname = zoho-cliq-upstream-electron
pkgdesc = Zoho Cliq running on upstream Electron (experimental)
diff --git a/PKGBUILD b/PKGBUILD
index 277e1d915782..434f24dccac0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=(zoho-cliq zoho-cliq-upstream-electron)
pkgver=1.5.3
-pkgrel=1
+pkgrel=2
pkgdesc='Zoho Cliq communication software'
arch=('x86_64')
url="https://www.zoho.com/cliq/desktop/linux.html"
@@ -16,9 +16,10 @@ source=(
)
package_zoho-cliq() {
+ conflicts=('zoho-cliq-upstream-electron')
install -d "${pkgdir}/opt"
install -d "${pkgdir}/usr/share"
- cd ${srcdir}/
+ cd "${srcdir}"
tar xf data.tar.xz
cp -r opt/Cliq "${pkgdir}/opt/Cliq"
cp -r usr/share/* "${pkgdir}/usr/share/"
@@ -45,7 +46,7 @@ package_zoho-cliq-upstream-electron() {
tar xf data.tar.xz
- for file in ${install_files[@]}; do
+ for file in "${install_files[@]}"; do
install -Dm 644 "${srcdir}${file}" "${pkgdir}${file}"
done