summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Golatofski2020-02-02 17:20:30 +0100
committerFelix Golatofski2020-02-02 17:20:30 +0100
commitc4c68b96ca6c84108615e01050a83645eeda2f42 (patch)
tree936c4779f03cd2873b5a4ecd0071bbb60cd157c9
parent666400125bf7b430fedb44fedd8cbb9078cb97cd (diff)
downloadaur-zorba.tar.gz
Updated to 4.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
-rw-r--r--item_handle.patch14
-rw-r--r--parser_bison_3_0_compatibility.patch50
4 files changed, 12 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80874ea61e6e..eb923ddc18cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zorba
pkgdesc = NoSQL(XQuery/JSONiq) Query Processor written in C++.
- pkgver = 3.0
- pkgrel = 2
+ pkgver = 4.0
+ pkgrel = 1
url = http://www.zorba.io/
arch = i686
arch = x86_64
@@ -23,16 +23,12 @@ pkgbase = zorba
optdepends = python2: python 2 bindings
optdepends = java-runtime: java bindings
optdepends = ruby: ruby bindings
- source = http://launchpad.net/zorba/trunk/3.0/+download/zorba-3.0.tar.gz
- source = item_handle.patch
+ source = https://github.com/zorba-processor/zorba/archive/4.0.tar.gz
source = bindings_dirs.patch
source = swig_xqj.patch
- source = parser_bison_3_0_compatibility.patch
- md5sums = 652e67103597e36126586ed1432e23bd
- md5sums = 1ec5d529746472147af9c325b0f49a62
- md5sums = 465cb60352b3a564da363b3e1cc80dcf
- md5sums = 93227da5598469f57eb1ff44e225c8d6
- md5sums = a578bf5966ab6dca4bdecfda5dff13c7
+ sha512sums = 8173de6058c72b2a804a91f8f888c27f3d2af2e288512ce4908cc3582858ad9f708ce434e1069ef9e4c8fe5a61b076829b3f8aed266d45548a3f1eda387f1100
+ sha512sums = 0a25606f608d42bfb47415a5908413581d2bc94b37527cde74b12c5b70c949a61904784ee4ddd0df65f24cb61c9f8bb2a08d6d847789511bc4a41ee0b53fb260
+ sha512sums = 8f3fb456daf70fdafbf2cabcabd3632f9d30371aec7ae3da58fc8dd2e5ddba66f5905fb461ef511afa93c6d47cf569ea9d3df632229c512f64a4c2d93708d66e
pkgname = zorba
diff --git a/PKGBUILD b/PKGBUILD
index 8c284334ed0e..faee8f3aa49d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Nikolay Amiantov <nikoamia@gmail.com> (added bindings packaging)
# Contributor: Ivan Kanakarakis <ivan.kanak@gmail.com> (fixed bison failures)
pkgname=zorba
-pkgver=3.0
-pkgrel=2
+pkgver=4.0
+pkgrel=1
pkgdesc="NoSQL(XQuery/JSONiq) Query Processor written in C++."
url="http://www.zorba.io/"
arch=('i686' 'x86_64')
@@ -29,24 +29,18 @@ makedepends=('cmake>=2.8.0'
'java-environment'
'ruby'
)
-source=(http://launchpad.net/${pkgname}/trunk/3.0/+download/${pkgname}-${pkgver}.tar.gz
- item_handle.patch
+source=(https://github.com/zorba-processor/zorba/archive/${pkgver}.tar.gz
bindings_dirs.patch
swig_xqj.patch
- parser_bison_3_0_compatibility.patch
)
-md5sums=('652e67103597e36126586ed1432e23bd'
- '1ec5d529746472147af9c325b0f49a62'
- '465cb60352b3a564da363b3e1cc80dcf'
- '93227da5598469f57eb1ff44e225c8d6'
- 'a578bf5966ab6dca4bdecfda5dff13c7')
+sha512sums=('8173de6058c72b2a804a91f8f888c27f3d2af2e288512ce4908cc3582858ad9f708ce434e1069ef9e4c8fe5a61b076829b3f8aed266d45548a3f1eda387f1100'
+ '0a25606f608d42bfb47415a5908413581d2bc94b37527cde74b12c5b70c949a61904784ee4ddd0df65f24cb61c9f8bb2a08d6d847789511bc4a41ee0b53fb260'
+ '8f3fb456daf70fdafbf2cabcabd3632f9d30371aec7ae3da58fc8dd2e5ddba66f5905fb461ef511afa93c6d47cf569ea9d3df632229c512f64a4c2d93708d66e')
prepare() {
cd "$srcdir/${pkgname}-${pkgver}"
- patch -p1 -i ../item_handle.patch
patch -p1 -i ../bindings_dirs.patch
patch -p1 -i ../swig_xqj.patch
- patch -p1 -i ../parser_bison_3_0_compatibility.patch
}
build() {
diff --git a/item_handle.patch b/item_handle.patch
deleted file mode 100644
index b591de3b19a5..000000000000
--- a/item_handle.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ru a/src/store/api/item_handle.h b/src/store/api/item_handle.h
---- a/src/store/api/item_handle.h 2013-11-06 08:20:44.000000000 +0100
-+++ b/src/store/api/item_handle.h 2013-11-09 12:13:38.964469110 +0100
-@@ -16,6 +16,10 @@
- #ifndef ZORBA_STORE_ITEM_HANDLE_H
- #define ZORBA_STORE_ITEM_HANDLE_H
-
-+#include <string>
-+#include <sstream>
-+
-+
- namespace zorba
- {
-
diff --git a/parser_bison_3_0_compatibility.patch b/parser_bison_3_0_compatibility.patch
deleted file mode 100644
index 38e40c44b03b..000000000000
--- a/parser_bison_3_0_compatibility.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-diff -ru a/src/compiler/parser/parser.y b/src/compiler/parser/parser.y
---- a/src/compiler/parser/parser.y 2013-11-06 08:20:44.000000000 +0100
-+++ b/src/compiler/parser/parser.y 2013-11-09 12:29:24.621711602 +0100
-@@ -31,8 +31,7 @@
- %skeleton "lalr1.cc" /* -*- C++ -*- */
- %require "2.4"
- %defines
--%name-prefix="zorba"
--%pure-parser
-+%name-prefix "zorba"
- %error-verbose
-
-
-@@ -45,9 +44,9 @@
-
-
- #ifdef XQUERY_PARSER
--%define "parser_class_name" "xquery_parser"
-+%define "parser_class_name" { xquery_parser }
- #else
--%define "parser_class_name" "jsoniq_parser"
-+%define "parser_class_name" { jsoniq_parser }
- #endif
-
-
-@@ -4635,21 +4634,21 @@
- $$ = NumericLiteral::new_literal(
- LOC(@$), ParseConstants::num_decimal, *$1
- );
-- delete yylval.decval;
-+ delete yylhs.value.decval;
- }
- | INTEGER_LITERAL
- {
- $$ = NumericLiteral::new_literal(
- LOC(@$), ParseConstants::num_integer, *$1
- );
-- delete yylval.ival;
-+ delete yylhs.value.ival;
- }
- | DOUBLE_LITERAL
- {
- $$ = NumericLiteral::new_literal(
- LOC(@$), ParseConstants::num_double, *$1
- );
-- delete yylval.dval;
-+ delete yylhs.value.dval;
- }
- ;
-