summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlec Mev2020-05-05 20:28:30 +0100
committerAlec Mev2020-05-05 20:28:30 +0100
commit7308cd7b97e392afd6270a36fad4eaec06c07a84 (patch)
treea42190e135ec4ee2e0a1dacc9f2e4ad74f7299bf
downloadaur-zsh-theme-minimal-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD28
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..550906362a7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = zsh-theme-minimal-git
+ pkgdesc = A minimal and extensible Zsh theme
+ pkgver = r64.2c89c47
+ pkgrel = 1
+ url = https://github.com/subnixr/minimal
+ arch = any
+ license = GPL3
+ depends = zsh
+ optdepends = git: Git branch status support
+ optdepends = mercurial: Mercurial branch status support
+ source = zsh-theme-minimal-git::git+https://github.com/subnixr/minimal.git
+ sha256sums = SKIP
+
+pkgname = zsh-theme-minimal-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8eaa8fb4646c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/*.tar
+/*/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f285a4bf63a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alec Mev <alec@mev.earth>
+
+_name=minimal
+pkgname="zsh-theme-${_name}-git"
+pkgver=r64.2c89c47
+pkgrel=1
+pkgdesc='A minimal and extensible Zsh theme'
+arch=('any')
+url=https://github.com/subnixr/minimal
+license=('GPL3')
+depends=('zsh')
+optdepends=(
+ 'git: Git branch status support'
+ 'mercurial: Mercurial branch status support'
+)
+source=("${pkgname}::git+https://github.com/subnixr/minimal.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "`git rev-list --count HEAD`" "`git rev-parse --short HEAD`"
+}
+
+package() {
+ cd "${pkgname}"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.md
+ install -Dm644 -t "${pkgdir}/usr/share/zsh/plugins/theme-${_name}" minimal.zsh
+}