summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman Perepelitsa2020-06-06 18:23:35 +0200
committerRoman Perepelitsa2020-06-06 18:23:35 +0200
commit2584ea7abc5bcba5344043fb9e963a49b2056f2a (patch)
tree691720d42e361b51726545e44813d0f6dfe01f71
parente4b4361db1a3495a054596777308d8dd7d8e6139 (diff)
downloadaur-2584ea7abc5bcba5344043fb9e963a49b2056f2a.tar.gz
fix package by adding all necessary files
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD73
-rw-r--r--zsh-theme-powerlevel10k.install13
4 files changed, 38 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b2503dab547..c280dda10e18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,19 @@
pkgbase = zsh-theme-powerlevel10k-git
- pkgdesc = Powerlevel10k is a theme for ZSH. It's a backward-compatible fork of Powerlevel9k with lower latency and better prompt responsiveness
- pkgver = r2255.a1c45a5
+ pkgdesc = Powerlevel10k is a theme for Zsh. It emphasizes speed, flexibility and out-of-the-box experience.
+ pkgver = r3618.50dec9f
pkgrel = 1
url = https://github.com/romkatv/powerlevel10k
install = zsh-theme-powerlevel10k.install
arch = any
license = MIT
- makedepends = git
depends = zsh
+ optdepends = ttf-meslo-nerd-font-powerlevel10k: terminal font recommended by powerlevel10k
optdepends = powerline-fonts: patched fonts for powerline
- optdepends = oh-my-zsh-git: oh-my-zsh integration
- optdepends = prezto-git: Prezto integration
- optdepends = antigen-git: Antigen integration
- optdepends = zpm: ZPM integration
- optdepends = zsh-zim-git: Zim integration
optdepends = awesome-terminal-fonts: icon package
- optdepends = acpi: battery monitoring
- optdepends = git: status of repository
- optdepends = mercurial: status of repository
- optdepends = systemd: virtualization detection
- optdepends = openssh: ssh detection
provides = zsh-theme-powerlevel10k
conflicts = zsh-theme-powerlevel10k
- conflicts = zsh-theme-powerlevel9k-git
source = powerlevel10k::git+https://github.com/romkatv/powerlevel10k.git
- sha256sums = SKIP
+ md5sums = SKIP
pkgname = zsh-theme-powerlevel10k-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0bc44f80bd57
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/powerlevel10k
+/src
+/zsh-theme-powerlevel10k-*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 3a07b0c81ce2..3ca797b55e82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,41 @@
-# Maintainer: Ron Asimi <ron dot asimi at gmail dot com>
+# Maintainer: Roman Perepelitsa <roman.perepelitsa@gmail.com>
-_pkgname=powerlevel10k
-pkgname=zsh-theme-${_pkgname}-git
-pkgver=r2255.a1c45a5
+pkgname=zsh-theme-powerlevel10k-git
+pkgver=r3618.50dec9f
pkgrel=1
-pkgdesc="Powerlevel10k is a theme for ZSH. It's a backward-compatible fork of Powerlevel9k with lower latency and better prompt responsiveness"
+pkgdesc='Powerlevel10k is a theme for Zsh. It emphasizes speed, flexibility and out-of-the-box experience.'
arch=('any')
-url='https://github.com/romkatv/powerlevel10k'
+url="https://github.com/romkatv/powerlevel10k"
license=('MIT')
depends=('zsh')
optdepends=(
+ 'ttf-meslo-nerd-font-powerlevel10k: terminal font recommended by powerlevel10k'
'powerline-fonts: patched fonts for powerline'
- 'oh-my-zsh-git: oh-my-zsh integration'
- 'prezto-git: Prezto integration'
- 'antigen-git: Antigen integration'
- 'zpm: ZPM integration'
- 'zsh-zim-git: Zim integration'
- 'awesome-terminal-fonts: icon package'
- 'acpi: battery monitoring'
- 'git: status of repository'
- 'mercurial: status of repository'
- 'systemd: virtualization detection'
- 'openssh: ssh detection')
-source=("${_pkgname}::git+https://github.com/romkatv/${_pkgname}.git")
-sha256sums=('SKIP')
-makedepends=('git')
-provides=("zsh-theme-${_pkgname}")
-conflicts=(
- "zsh-theme-${_pkgname}"
- "zsh-theme-powerlevel9k-git"
-)
-install="zsh-theme-${_pkgname}.install"
+ 'awesome-terminal-fonts: icon package')
+install=zsh-theme-powerlevel10k.install
+provides=("zsh-theme-powerlevel10k")
+conflicts=("zsh-theme-powerlevel10k")
+source=('powerlevel10k::git+https://github.com/romkatv/powerlevel10k.git')
+md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd "$srcdir/powerlevel10k"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-package()
-{
- cd "${srcdir}/${_pkgname}"
-
- # Install license
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- # Install Documentation
- install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
-
- # Install the theme
- install -D -m644 powerlevel10k.zsh-theme "${pkgdir}/usr/share/zsh-theme-${_pkgname}/${_pkgname}.zsh-theme"
+build() {
+ cd "$srcdir/powerlevel10k"
+ zsh -fc '
+ emulate zsh -o no_aliases
+ unset -m "GITSTATUS_*"
+ GITSTATUS_CACHE_DIR="$PWD"/gitstatus/usrbin ./gitstatus/install -f'
+ for file in *.zsh-theme internal/*.zsh gitstatus/*.zsh gitstatus/install; do
+ zsh -fc "emulate zsh -o no_aliases && zcompile -R -- $file.zwc $file"
+ done
+}
- # Install the utilities
- install -D -m755 prompt_powerlevel10k_setup "${pkgdir}/usr/share/zsh-theme-${_pkgname}/prompt_powerlevel10k_setup"
- install -d "${pkgdir}/usr/share/zsh-theme-${_pkgname}/config"
- cp -R config "$pkgdir"/usr/share/zsh-theme-${_pkgname}/
- install -d "${pkgdir}/usr/share/zsh-theme-${_pkgname}/gitstatus/bin"
- cp -R gitstatus "$pkgdir"/usr/share/zsh-theme-${_pkgname}/
- cp -R internal "$pkgdir"/usr/share/zsh-theme-${_pkgname}/
+package() {
+ cd "$srcdir"
+ find powerlevel10k -path powerlevel10k/.git -prune \
+ -o '(' -type f -exec install -D '{}' "$pkgdir/usr/share/zsh-theme-{}" ';' ')'
}
diff --git a/zsh-theme-powerlevel10k.install b/zsh-theme-powerlevel10k.install
index bb82622e308b..4b222a6f68b2 100644
--- a/zsh-theme-powerlevel10k.install
+++ b/zsh-theme-powerlevel10k.install
@@ -1,11 +1,4 @@
post_install() {
- echo
- echo "Usage:"
- echo "Configure your setup to use the theme. Instructions for different frameworks can be found at"
- echo "https://github.com/romkatv/powerlevel10k#installation-and-configuration"
- echo
- echo "Requirements"
- echo "Vim Powerline patched font. Many different ones on the AUR"
- echo "Make sure terminal is using 256-colors mode with export TERM=\"xterm-256color\"."
- echo
-}
+ printf ' \033[34m->\033[0m To activate \033[1mPowerlevel10k\033[0m, add the following line to \033[4m.zshrc\033[0m:\n'
+ printf ' \033[34m->\033[0m \033[32msource\033[0m \033[4m/usr/share/zsh-theme-powerlevel10k/powerlevel10k.zsh-theme\033[0m\n'
+}