summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRon Asimi2019-03-09 19:05:05 -0500
committerRon Asimi2019-03-09 19:05:05 -0500
commitcf7eeb40516f61b9674f8083b37ff47abaf08a15 (patch)
tree25b54522423d38fce893d3c3ebc8998a359218ac
downloadaur-cf7eeb40516f61b9674f8083b37ff47abaf08a15.tar.gz
initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD59
-rw-r--r--zsh-theme-powerlevel10k.install11
3 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a1dcf334f24
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = zsh-theme-powerlevel10k-git
+ pkgdesc = Powerlevel10k theme for zsh
+ pkgver = v0.6.6.r172.gc3717ba
+ pkgrel = 1
+ url = https://github.com/romkatv/powerlevel10k
+ install = zsh-theme-powerlevel10k.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = zsh
+ optdepends = powerline-fonts: patched fonts for powerline
+ optdepends = oh-my-zsh-git: oh-my-zsh integration
+ optdepends = prezto-git: Prezto integration
+ optdepends = antigen-git: Antigen integration
+ optdepends = zpm: ZPM integration
+ optdepends = zsh-zim-git: Zim integration
+ optdepends = awesome-terminal-fonts: icon package
+ optdepends = acpi: battery monitoring
+ optdepends = git: status of repository
+ optdepends = mercurial: status of repository
+ optdepends = systemd: virtualization detection
+ optdepends = openssh: ssh detection
+ provides = zsh-theme-powerlevel10k
+ conflicts = zsh-theme-powerlevel10k
+ conflicts = zsh-theme-powerlevel9k-git
+ source = powerlevel10k::git+https://github.com/romkatv/powerlevel10k.git
+ sha256sums = SKIP
+
+pkgname = zsh-theme-powerlevel10k-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2dde856ff7df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Ron Asimi <ron dot asimi at gmail dot com>
+
+_pkgname=powerlevel10k
+pkgname=zsh-theme-${_pkgname}-git
+pkgver=v0.6.6.r172.gc3717ba
+pkgrel=1
+pkgdesc='Powerlevel10k theme for zsh'
+arch=('any')
+url='https://github.com/romkatv/powerlevel10k'
+license=('MIT')
+depends=('zsh')
+optdepends=(
+ 'powerline-fonts: patched fonts for powerline'
+ 'oh-my-zsh-git: oh-my-zsh integration'
+ 'prezto-git: Prezto integration'
+ 'antigen-git: Antigen integration'
+ 'zpm: ZPM integration'
+ 'zsh-zim-git: Zim integration'
+ 'awesome-terminal-fonts: icon package'
+ 'acpi: battery monitoring'
+ 'git: status of repository'
+ 'mercurial: status of repository'
+ 'systemd: virtualization detection'
+ 'openssh: ssh detection')
+source=("${_pkgname}::git+https://github.com/romkatv/${_pkgname}.git")
+sha256sums=('SKIP')
+makedepends=('git')
+provides=("zsh-theme-${_pkgname}")
+conflicts=(
+ "zsh-theme-${_pkgname}"
+ "zsh-theme-powerlevel9k-git"
+)
+install="zsh-theme-${_pkgname}.install"
+
+pkgver()
+{
+ cd "${srcdir}/${_pkgname}"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package()
+{
+ cd "${srcdir}/${_pkgname}"
+
+ # Install license
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Install Documentation
+ install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+
+ # Install the theme
+ install -D -m644 powerlevel10k.zsh-theme "${pkgdir}/usr/share/zsh-theme-${_pkgname}/${_pkgname}.zsh-theme"
+
+ # Install the utilities
+ for FILE in functions/*.zsh; do
+ install -D -m644 "${FILE}" "${pkgdir}/usr/share/zsh-theme-${_pkgname}/functions/$(basename ${FILE})"
+ done
+}
diff --git a/zsh-theme-powerlevel10k.install b/zsh-theme-powerlevel10k.install
new file mode 100644
index 000000000000..bb82622e308b
--- /dev/null
+++ b/zsh-theme-powerlevel10k.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo
+ echo "Usage:"
+ echo "Configure your setup to use the theme. Instructions for different frameworks can be found at"
+ echo "https://github.com/romkatv/powerlevel10k#installation-and-configuration"
+ echo
+ echo "Requirements"
+ echo "Vim Powerline patched font. Many different ones on the AUR"
+ echo "Make sure terminal is using 256-colors mode with export TERM=\"xterm-256color\"."
+ echo
+}