summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2023-04-27 03:58:21 +0100
committerScore_Under2023-04-27 03:58:21 +0100
commit0150cebc64b4f111ebbf7e2c78f91468d00cdb1b (patch)
tree08b15ccb089ac1eb2dd35af2968b40f539d07e28
parent43774e42380b50a4eb2555a9ba702368bf0fb2ff (diff)
downloadaur-0150cebc64b4f111ebbf7e2c78f91468d00cdb1b.tar.gz
Update for v525a
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--paths-in-opt.patch6
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55a26ae906cc..1d704a0864a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 524
- pkgrel = 3
+ pkgver = 525.a
+ pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
arch = any
license = custom
@@ -27,7 +27,7 @@ pkgbase = hydrus
depends = python-typing_extensions
depends = python-service-identity
depends = pyside6
- depends = hydrus-docs>=524
+ depends = hydrus-docs>=525.a
optdepends = ffmpeg: show duration and other information on video thumbnails
optdepends = miniupnpc: automatic port forwarding
optdepends = desktop-file-utils: to add Hydrus to your desktop environment menus
@@ -41,13 +41,13 @@ pkgbase = hydrus
optdepends = python-pyopenssl: to generate certificates for accessing client API and server via HTTPS
optdepends = swftools: to display SWF thumbnails
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=43ae2c2593c8e900b40460191b8379229578f52c
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=2691a92c8afe39e05c5eb7df2f9d93bcdb1d5f35
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = f34b3cbe1ee548975f98b339200e79c95ab1482c8e96636e9a27db4ee8ade27a
+ sha256sums = b196485720ed874a22fe49a48ce92db423dda12824b2755071bbf47cfc891bc0
sha256sums = d2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5
sha256sums = 463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index 5c79db1facfd..209fcde14545 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@ options=(!strip) # Don't strip libs because there aren't any
pkgname=hydrus
_pkgname=hydrus
-pkgver=524
-pkgrel=3
+pkgver=525.a
+pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
license=(custom)
@@ -31,13 +31,13 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
# 'python-pyparsing: currently unused'
# 'speedcopy: may speed up file transfers'
'swftools: to display SWF thumbnails')
-source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=43ae2c2593c8e900b40460191b8379229578f52c"
+source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=2691a92c8afe39e05c5eb7df2f9d93bcdb1d5f35"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- 'f34b3cbe1ee548975f98b339200e79c95ab1482c8e96636e9a27db4ee8ade27a'
+ 'b196485720ed874a22fe49a48ce92db423dda12824b2755071bbf47cfc891bc0'
'd2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5'
'463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index 7a234ceeb672..273fe4c68ddc 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,8 +1,8 @@
diff --git a/hydrus/client/gui/ClientGUI.py b/hydrus/client/gui/ClientGUI.py
-index e5fc71eb..cf59348b 100644
+index 8ed3a258..a63c53ac 100644
--- a/hydrus/client/gui/ClientGUI.py
+++ b/hydrus/client/gui/ClientGUI.py
-@@ -6150,7 +6150,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes, CAC.ApplicationCo
+@@ -6153,7 +6153,7 @@ class FrameGUI( CAC.ApplicationCommandProcessorMixin, ClientGUITopLevelWindows.M
python_executable = python_executable.replace( 'pythonw', 'python' )
@@ -12,7 +12,7 @@ index e5fc71eb..cf59348b 100644
cmd = [ python_executable, server_script_path, db_param ]
diff --git a/hydrus/core/HydrusConstants.py b/hydrus/core/HydrusConstants.py
-index ad529c75..49ddaeea 100644
+index b38f7432..4d71fbd9 100644
--- a/hydrus/core/HydrusConstants.py
+++ b/hydrus/core/HydrusConstants.py
@@ -11,34 +11,9 @@ import yaml