summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Woudstra2024-02-17 09:30:20 +0100
committerEric Woudstra2024-02-17 09:30:20 +0100
commit02ae32435af483e2bdda7fb1cc406cb77e4291b6 (patch)
tree323af993fc9b224ad13504945829c68677a0415a
parente889ad5fe813022c7d82920976ed73b3ec2e1ddc (diff)
downloadaur-02ae32435af483e2bdda7fb1cc406cb77e4291b6.tar.gz
New repo, thanks to Shatur
-rw-r--r--PKGBUILD40
-rw-r--r--add-av_stream_get_first_dts-for-chromium.patch31
2 files changed, 5 insertions, 66 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2d92475d0d18..3000b113a7d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,8 +20,9 @@
pkgname=ffmpeg-v4l2-request-git
# pkgname=ffmpeg
_srcname=FFmpeg
-pkgver=6.0.r329749
-pkgrel=2
+_version='6.1.1'
+pkgver=6.1.1.r112629.71a1f3f
+pkgrel=1
epoch=2
pkgdesc='FFmpeg with v4l2-request and drmprime'
arch=('armv7h' 'aarch64')
@@ -115,46 +116,15 @@ conflicts=(
ffmpeg
)
source=(
- 'git+https://github.com/jernejsk/FFmpeg'
- add-av_stream_get_first_dts-for-chromium.patch
+ 'git+https://github.com/Kwiboo/FFmpeg#branch=v4l2-request-n'$_version
)
sha256sums=(
SKIP
- SKIP
)
- #_version='5.1.2'
-_version='6.0'
-_branch1='v4l2-request-n'$_version
-_branch2='v4l2-drmprime-n'$_version
-_branch3='vf-deinterlace-v4l2m2m-n'$_version
-
-prepare() {
- cd ${_srcname}
-
- git reset --hard
- git checkout $_branch1
- if [ ! -z $_branch2 ]; then
- git -c "user.name=Your Name" -c "user.email=you@example.com" \
- merge --no-edit origin/$_branch2
- fi
- if [ ! -z $_branch3 ]; then
- git -c "user.name=Your Name" -c "user.email=you@example.com" \
- merge --no-edit origin/$_branch3
- fi
-
- patch -Np1 -i ../add-av_stream_get_first_dts-for-chromium.patch # https://crbug.com/1251779
-}
-
pkgver() {
cd ${_srcname}
- (
- set -o pipefail
- _cnt1=$(git rev-list --count origin/$_branch1)
- [ ! -z $_branch2 ] && _cnt2=$(git rev-list --count origin/$_branch2) || _cnt2="0"
- [ ! -z $_branch3 ] && _cnt3=$(git rev-list --count origin/$_branch3) || _cnt3="0"
- printf '%s.r%s' "$_version" "$(( $_cnt1 + $_cnt2 + $_cnt3 ))"
- )
+ printf '%s.r%s.%s' "$_version" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
build() {
diff --git a/add-av_stream_get_first_dts-for-chromium.patch b/add-av_stream_get_first_dts-for-chromium.patch
deleted file mode 100644
index 20ea725dabf4..000000000000
--- a/add-av_stream_get_first_dts-for-chromium.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff '--color=auto' -rupN ffmpeg.orig/libavformat/avformat.h ffmpeg/libavformat/avformat.h
---- ffmpeg.orig/libavformat/avformat.h 2022-08-19 17:42:47.323422603 +0200
-+++ ffmpeg/libavformat/avformat.h 2022-08-19 17:42:51.347130436 +0200
-@@ -1128,6 +1128,10 @@ struct AVCodecParserContext *av_stream_g
- */
- int64_t av_stream_get_end_pts(const AVStream *st);
-
-+// Chromium: We use the internal field first_dts vvv
-+int64_t av_stream_get_first_dts(const AVStream *st);
-+// Chromium: We use the internal field first_dts ^^^
-+
- #define AV_PROGRAM_RUNNING 1
-
- /**
-diff '--color=auto' -rupN ffmpeg.orig/libavformat/mux_utils.c ffmpeg/libavformat/mux_utils.c
---- ffmpeg.orig/libavformat/mux_utils.c 2022-08-19 17:42:47.346758108 +0200
-+++ ffmpeg/libavformat/mux_utils.c 2022-08-19 17:47:28.549589002 +0200
-@@ -37,6 +37,13 @@ int64_t av_stream_get_end_pts(const AVSt
- return AV_NOPTS_VALUE;
- }
-
-+// Chromium: We use the internal field first_dts vvv
-+int64_t av_stream_get_first_dts(const AVStream *st)
-+{
-+ return cffstream(st)->first_dts;
-+}
-+// Chromium: We use the internal field first_dts ^^^
-+
- int avformat_query_codec(const AVOutputFormat *ofmt, enum AVCodecID codec_id,
- int std_compliance)
- {