summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames P. Harvey2018-10-11 19:36:32 -0400
committerJames P. Harvey2018-10-11 20:01:12 -0400
commit043d496db170eb02b3debe182d969e15c9baf062 (patch)
treeb2a43636a8efdb0f272cfdb9fc1aa11967faf24d
parent0afd48f2fb1c88ee32027da7245bbd430a884583 (diff)
downloadaur-043d496db170eb02b3debe182d969e15c9baf062.tar.gz
Upstream released 2.6.3. Fixed typos in install file.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
-rw-r--r--bash-git-prompt.install6
3 files changed, 17 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9bea36408b8..7ca205ed01d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun Apr 16 01:28:49 UTC 2017
pkgbase = bash-git-prompt
pkgdesc = Informative git prompt for bash and fish
- pkgver = 2.6.2
+ pkgver = 2.6.3
pkgrel = 1
url = https://github.com/magicmonty/bash-git-prompt
install = bash-git-prompt.install
@@ -11,11 +9,11 @@ pkgbase = bash-git-prompt
makedepends = git
depends = bash
optdepends = fish: git prompt in fish support
- source = git+https://github.com/magicmonty/bash-git-prompt
+ source = https://github.com/magicmonty/bash-git-prompt/archive/2.6.3.tar.gz
source = bash-git-prompt.install
source = Default_Arch.bgptheme
- md5sums = SKIP
- md5sums = 990d3a7ef8a21b83f0d1e90d9ef1a5b7
+ md5sums = d11c07ef9672e6cb166fc5af55ba4fae
+ md5sums = 9024256781844b2af5da4da4882e9160
md5sums = af064330b3a579ec6efd2e018e6829df
pkgname = bash-git-prompt
diff --git a/PKGBUILD b/PKGBUILD
index 6e2975bc7bad..94ba4b6b216a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
-# $Id$
-# Maintainer: James Harvey <jamespharvey20@gmail.com>
+# Maintainer: James Harvey <jamespharvey20 at gmail dot com>
# * No namcap warnings or errors
pkgname=bash-git-prompt
-pkgver=2.6.2
+pkgver=2.6.3
pkgrel=1
pkgdesc="Informative git prompt for bash and fish"
arch=('any')
@@ -12,21 +11,16 @@ depends=('bash')
optdepends=('fish: git prompt in fish support')
makedepends=('git')
license=('custom:BSD 2 Clause (NetBSD)')
-source=("git+https://github.com/magicmonty/${pkgname}"
+source=("https://github.com/magicmonty/${pkgname}/archive/${pkgver}.tar.gz"
'bash-git-prompt.install'
'Default_Arch.bgptheme')
-md5sums=('SKIP'
- '990d3a7ef8a21b83f0d1e90d9ef1a5b7'
+md5sums=('d11c07ef9672e6cb166fc5af55ba4fae'
+ '9024256781844b2af5da4da4882e9160'
'af064330b3a579ec6efd2e018e6829df')
install='bash-git-prompt.install'
-prepare() {
- cd ${srcdir}/${pkgname}
- git checkout tags/${pkgver}
-}
-
package() {
- cd ${srcdir}/${pkgname}
+ cd ${srcdir}/bash-git-prompt-${pkgver}
install -Dm644 LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
install -Dm644 README.md ${pkgdir}/usr/lib/bash-git-prompt/README.md
@@ -45,7 +39,11 @@ package() {
install -Dm644 Default_NoExitState.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Default_NoExitState.bgptheme
install -Dm644 Evermeet.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Evermeet.bgptheme
install -Dm644 Evermeet_Lowres.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Evermeet_Lowres.bgptheme
+ install -Dm644 Minimal.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Minimal.bgptheme
+ install -Dm644 Minimal_UserHost.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Minimal_UserHost.bgptheme
+ install -Dm644 Plague_Doctor.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Plague_Doctor.bgptheme
install -Dm644 Single_line.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Single_line.bgptheme
+ install -Dm644 Single_line_Minimalist.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Single_line_Minimalist.bgptheme
install -Dm644 Single_line_NoExitState.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Single_line_NoExitState.bgptheme
install -Dm644 Single_line_Solarized.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Single_line_Solarized.bgptheme
install -Dm644 Solarized.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Solarized.bgptheme
diff --git a/bash-git-prompt.install b/bash-git-prompt.install
index 33c1e85df7cc..cef5117be77d 100644
--- a/bash-git-prompt.install
+++ b/bash-git-prompt.install
@@ -4,7 +4,7 @@ post_install() {
NOTE: To use bash-git-prompt, you should add the following to your
/etc/bash.bashrc or ~/.bashrc:
- if [ -f %{/usr/lib/bash-git-prompt/gitprompt.sh ]; then
+ if [ -f /usr/lib/bash-git-prompt/gitprompt.sh ]; then
# To only show the git prompt in or under a repository directory
# GIT_PROMPT_ONLY_IN_REPO=1
# To use upstream's default theme
@@ -17,7 +17,7 @@ post_install() {
NOTE: To have the colors shown by 'git status' match the Default_Arch theme,
add the following to your ~/.gitconfig:
- [color "status"]
+ [color \"status\"]
branch = magenta
untracked = cyan
unmerged = yellow
@@ -37,7 +37,7 @@ post_remove() {
by doing one of the following:
* Restarting your shells (relogging in each of them)
- * Starting new shells (running "bash" in each of them)
+ * Starting new shells (running \"bash\" in each of them)
* Rebooting
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^