summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Holzner2018-02-15 19:32:10 +0100
committerLukas Holzner2018-02-15 19:32:10 +0100
commit04f631afce07aeb73041c87b524a393ec82cd6b8 (patch)
tree03fa23de53de497c1810d6a7cf3006c4ebaf6d09
parent4930975dd584ab330a90dae25b70f74b191e1002 (diff)
downloadaur-04f631afce07aeb73041c87b524a393ec82cd6b8.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
-rw-r--r--binfmts.service (renamed from binfmt-support.service)8
3 files changed, 22 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c779c423f93..62cd0af4759e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
-# Generated by mksrcinfo v8
-# 二 1月 9 02:09:17 UTC 2018
pkgbase = binfmt-support
pkgdesc = register interpreters for various binary formats
pkgver = 2.1.8
pkgrel = 2
url = http://packages.debian.org/en/sid/binfmt-support
- arch = i686
- arch = x86_64
+ arch = any
license = GPL
+ depends = glibc
+ depends = systemd
depends = libpipeline
- source = ftp://ftp.de.debian.org/debian/pool/main/b/binfmt-support/binfmt-support_2.1.8.orig.tar.gz
- source = binfmt-support.service
- sha256sums = ebad04db8444d2275d042b5074fa3e160bcf3e2c23ee9b660e75f5acd73618a2
- sha256sums = efba2300b9f0c8c5c14696d2b25836d91edaaad8d30c64ed7d3eab0163b2553e
+ source = http://ftp.de.debian.org/debian/pool/main/b/binfmt-support/binfmt-support_2.1.8.orig.tar.gz
+ source = binfmts.service
+ md5sums = b86d8a8d310e246f1e02b91366472681
+ md5sums = 0000a524a3d97583563a0d1d6f6b1ecb
pkgname = binfmt-support
diff --git a/PKGBUILD b/PKGBUILD
index 502b9d63212b..a064bd305986 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,23 @@ pkgname=binfmt-support
pkgver=2.1.8
pkgrel=2
pkgdesc="register interpreters for various binary formats"
-arch=(i686 x86_64)
+arch=(any)
url="http://packages.debian.org/en/sid/binfmt-support"
license=('GPL')
-depends=('libpipeline')
+depends=('glibc' 'systemd' 'libpipeline')
makedepends=()
-source=(ftp://ftp.de.debian.org/debian/pool/main/b/binfmt-support/binfmt-support_$pkgver.orig.tar.gz
- binfmt-support.service)
-sha256sums=('ebad04db8444d2275d042b5074fa3e160bcf3e2c23ee9b660e75f5acd73618a2'
- 'efba2300b9f0c8c5c14696d2b25836d91edaaad8d30c64ed7d3eab0163b2553e')
+source=(
+ http://ftp.de.debian.org/debian/pool/main/b/binfmt-support/binfmt-support_$pkgver.orig.tar.gz
+ binfmts.service
+ )
+md5sums=(
+ 'b86d8a8d310e246f1e02b91366472681'
+ '0000a524a3d97583563a0d1d6f6b1ecb'
+ )
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --libexecdir=/usr/lib --sbindir=/usr/bin --localstatedir=/var
+ ./configure --prefix=/usr --libexecdir=/usr/lib --sbindir=/usr/bin
make
}
@@ -22,5 +26,5 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
install -dm0755 $pkgdir/var/lib/binfmts
- install -Dm644 $srcdir/binfmt-support.service $pkgdir/usr/lib/systemd/system/binfmt-support.service
+ install -Dm755 ../binfmts.service $pkgdir/usr/lib/systemd/system/binfmts.service
}
diff --git a/binfmt-support.service b/binfmts.service
index b7035d853aec..7e6256908d5f 100644
--- a/binfmt-support.service
+++ b/binfmts.service
@@ -4,14 +4,12 @@ Documentation=man:update-binfmts(8)
[Service]
Type=oneshot
-ExecStart=/usr/bin/update-binfmts --enable
-ExecStop=/usr/bin/update-binfmts --disable
-KillMode=process
+ExecStart=/bin/bash -c "exec /usr/bin/update-binfmts --enable"
+KillMode=none
Restart=no
-RemainAfterExit=yes
[Install]
WantedBy=multi-user.target
-# This service file writes "enabled" to /proc/sys/fs/binfmt_misc/status,
+# This service file writes "enabled" to /proc/sys/fs/binfmt_misc/status,
# and registers all binfmt specifications in /var/lib/binfmts (default)