summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Falezza2022-11-08 11:41:08 +0000
committerFilippo Falezza2022-11-08 11:41:08 +0000
commit054ca4d76cd79e24bf1dcac482f5c0d61dc191a4 (patch)
treeb794400e6a9b5d09cf2ec598c43421fb56a9e9c0
parentb967695f913dc60960d12f6309b2172d7fbd53e1 (diff)
downloadaur-054ca4d76cd79e24bf1dcac482f5c0d61dc191a4.tar.gz
edited Compile flags to remove error on format security warning
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34c3668c99d2..a306d006e614 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cross-mipsel-linux-gnu-gcc
pkgdesc = The GNU Compiler Collection for the MIPS architecture
pkgver = 12.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.gnu.org/software/gcc/
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 4201ceb77453..fe0c4206b4c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname=cross-mipsel-linux-gnu-gcc
_pkgname=gcc
_target="mipsel-linux-gnu"
pkgver=12.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="The GNU Compiler Collection for the MIPS architecture"
url="https://www.gnu.org/software/gcc/"
arch=('x86_64')
@@ -33,7 +33,9 @@ prepare() {
build() {
cd ${srcdir}/${_pkgname}-${pkgver}
-
+ export CFLAGS="${CFLAGS// -Werror=format-security}"
+ export CXXFLAGS="$CFLAGS"
+
./configure \
"--prefix=${_sysroot}" \
"--bindir=/usr/bin" "--program-prefix=${_target}-" \