summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2023-03-30 08:53:39 +0100
committerScore_Under2023-03-30 08:53:39 +0100
commit0852b6318cb41ab8473f48a9886040717abff2b0 (patch)
tree3626788df8c36944fca9bec00b2335b9b54c6c82
parent5812e5f3df23876d394658a37b29de876f404126 (diff)
downloadaur-0852b6318cb41ab8473f48a9886040717abff2b0.tar.gz
Update for v522
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
-rw-r--r--paths-in-opt.patch14
3 files changed, 26 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47ecfbd9f687..cc3880497dcf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 521
- pkgrel = 2
+ pkgver = 522
+ pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
arch = any
@@ -38,13 +38,13 @@ pkgbase = hydrus
conflicts = hydrus-docs
conflicts = hydrus-sources
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=7bd42868c54de08286b54f3b159f9cc41e0df880
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=91e1c54d2423cb086830e6994a2a96200ae8b9f6
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = 061490f052086dadf453c208834f14b48f101eb1a95e29e8dee4960f8a72e74d
+ sha256sums = f34b3cbe1ee548975f98b339200e79c95ab1482c8e96636e9a27db4ee8ade27a
sha256sums = d2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5
sha256sums = 463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index 39d01171250b..82cd95a90b58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@ DOC_DIRS=(opt/hydrus/help)
pkgname=hydrus
_pkgname=hydrus
-pkgver=521
-pkgrel=2
+pkgver=522
+pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
license=(WTFPL)
@@ -24,13 +24,13 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
'python-cloudscraper: bypass cloudflare "checking your browser" challenges'
'python-pyqt6-charts: display bandwidth usage charts'
'python-pyopenssl: to generate certificates for accessing client API and server via HTTPS')
-source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=7bd42868c54de08286b54f3b159f9cc41e0df880"
+source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=91e1c54d2423cb086830e6994a2a96200ae8b9f6"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- '061490f052086dadf453c208834f14b48f101eb1a95e29e8dee4960f8a72e74d'
+ 'f34b3cbe1ee548975f98b339200e79c95ab1482c8e96636e9a27db4ee8ade27a'
'd2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5'
'463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
@@ -49,11 +49,7 @@ _tweak_package_add_docs() {
prepare() {
cd "${srcdir}/${_pkgname}"
- git apply < ../paths-in-opt.patch
-
- # Remove unit tests
- rm -f "hydrus/Test"*.py
- rm -rf "static/testing"
+ patch -Np1 < ../paths-in-opt.patch
}
build() {
@@ -78,6 +74,9 @@ package() {
cp -r help "${pkgdir}/opt/hydrus/"
fi
+ # Remove unit tests
+ rm -rf "${pkgdir}/opt/hydrus/hydrus/test" "${pkgdir}/opt/hydrus/static/testing"
+
# Create and populate /opt/hydrus/bin
install -d -m755 "${pkgdir}/opt/hydrus/bin"
ln -s /usr/bin/upnpc "${pkgdir}/opt/hydrus/bin/upnpc_linux"
@@ -97,4 +96,11 @@ package() {
install -m644 license.txt "${pkgdir}/usr/share/licenses/${_pkgname}/"
}
+# Tests (they don't pass!)
+# makedepends+=(python-httmock)
+# check() {
+# cd "${srcdir}/${_pkgname}"
+# python -m unittest discover -s hydrus/test -p 'Test*.py'
+# }
+
_tweak_package_add_docs
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index 82c7c5b5f399..7a234ceeb672 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,8 +1,8 @@
diff --git a/hydrus/client/gui/ClientGUI.py b/hydrus/client/gui/ClientGUI.py
-index 95b81fc6..73b02fbf 100644
+index e5fc71eb..cf59348b 100644
--- a/hydrus/client/gui/ClientGUI.py
+++ b/hydrus/client/gui/ClientGUI.py
-@@ -6184,7 +6184,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes, CAC.ApplicationCo
+@@ -6150,7 +6150,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes, CAC.ApplicationCo
python_executable = python_executable.replace( 'pythonw', 'python' )
@@ -12,10 +12,10 @@ index 95b81fc6..73b02fbf 100644
cmd = [ python_executable, server_script_path, db_param ]
diff --git a/hydrus/core/HydrusConstants.py b/hydrus/core/HydrusConstants.py
-index fab89f7f..21a89dea 100644
+index ad529c75..49ddaeea 100644
--- a/hydrus/core/HydrusConstants.py
+++ b/hydrus/core/HydrusConstants.py
-@@ -10,34 +10,9 @@ import yaml
+@@ -11,34 +11,9 @@ import yaml
RUNNING_CLIENT = False
RUNNING_SERVER = False
@@ -53,9 +53,9 @@ index fab89f7f..21a89dea 100644
muh_platform = sys.platform.lower()
-@@ -49,32 +24,16 @@ PLATFORM_HAIKU = muh_platform == 'haiku1'
- RUNNING_FROM_SOURCE = sys.argv[0].endswith( '.py' ) or sys.argv[0].endswith( '.pyw' )
- RUNNING_FROM_MACOS_APP = os.path.exists( os.path.join( BASE_DIR, 'running_from_app' ) )
+@@ -66,32 +41,16 @@ elif RUNNING_FROM_FROZEN_BUILD:
+ elif RUNNING_FROM_MACOS_APP:
+ NICE_RUNNING_AS_STRING = 'from App'
-BIN_DIR = os.path.join( BASE_DIR, 'bin' )
-HELP_DIR = os.path.join( BASE_DIR, 'help' )