summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreyXor2024-01-25 02:00:15 +0100
committerGreyXor2024-01-25 02:00:15 +0100
commit098d81737f1230c12c42409e572cdb887e7fa5fe (patch)
tree5561cc28d626bb693f4793275038f9e1d82e385c
parent36ace4f2f57349cb30f0ee7c64a0332487012c1c (diff)
downloadaur-098d81737f1230c12c42409e572cdb887e7fa5fe.tar.gz
refactor: namcap issues, optdeps and message
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 27 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 883631f3b53e..af230d357f3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
pkgbase = wlroots-git
- pkgdesc = Modular Wayland compositor library (git version)
- pkgver = 0.17.0.r6161.3a200aa2
+ pkgdesc = Modular Wayland compositor library (git development version)
+ pkgver = 0.18.0.r6841.cca2bfbe
pkgrel = 1
url = https://gitlab.freedesktop.org/wlroots/wlroots
arch = x86_64
- license = custom:MIT
+ license = MIT
makedepends = git
makedepends = meson
makedepends = vulkan-headers
makedepends = wayland-protocols
makedepends = xorgproto
- depends = glslang
+ depends = glibc
+ depends = libdrm
depends = libinput
depends = libliftoff
depends = libxcb
+ depends = libglvnd
depends = libxkbcommon
+ depends = systemd-libs
depends = opengl-driver
depends = pixman
depends = wayland
@@ -22,14 +25,15 @@ pkgbase = wlroots-git
depends = xcb-util-renderutil
depends = xcb-util-wm
depends = seatd
+ depends = glslang
depends = vulkan-icd-loader
- depends = xorg-xwayland
depends = libdisplay-info
+ optdepends = xorg-xwayland: enable X11 support
provides = libwlroots.so
- provides = wlroots=0.17.0
+ provides = wlroots=0.18.0
conflicts = wlroots
options = debug
source = wlroots-git::git+https://gitlab.freedesktop.org/wlroots/wlroots.git
- md5sums = SKIP
+ b2sums = SKIP
pkgname = wlroots-git
diff --git a/PKGBUILD b/PKGBUILD
index 78db8bc60e62..f6ab7156dc5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,23 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
+# Maintainer: GreyXor <greyxor@protonmail.com>
# Maintainer: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=wlroots-git
-pkgver=0.17.0.r6161.3a200aa2
+pkgver=0.18.0.r6841.cca2bfbe
pkgrel=1
-license=(custom:MIT)
-pkgdesc='Modular Wayland compositor library (git version)'
-url=https://gitlab.freedesktop.org/wlroots/wlroots
+pkgdesc='Modular Wayland compositor library (git development version)'
arch=(x86_64)
-provides=("libwlroots.so" "wlroots=${pkgver%%.r*}")
-conflicts=(wlroots)
+url=https://gitlab.freedesktop.org/wlroots/wlroots
+license=(MIT)
options=(debug)
depends=(
- glslang
+ glibc
+ libdrm
libinput
libliftoff
libxcb
+ libglvnd
libxkbcommon
+ systemd-libs
opengl-driver
pixman
wayland
@@ -23,8 +25,8 @@ depends=(
xcb-util-renderutil
xcb-util-wm
seatd
+ glslang
vulkan-icd-loader
- xorg-xwayland
libdisplay-info)
makedepends=(
git
@@ -32,9 +34,13 @@ makedepends=(
vulkan-headers
wayland-protocols
xorgproto)
+optdepends=(
+'xorg-xwayland: enable X11 support'
+)
+provides=("libwlroots.so" "${pkgname%-git}=${pkgver%%.r*}")
+conflicts=("${pkgname%-git}")
source=("${pkgname}::git+${url}.git")
-md5sums=('SKIP')
-
+b2sums=('SKIP')
_builddir="build"
_builddir_pkgver="build-pkgver"
@@ -69,8 +75,3 @@ package () {
meson install -C "${_builddir}" --destdir="${pkgdir}"
install -Dm644 "${pkgname}/"LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-post_upgrade() {
- echo "Make sure to upgrade wlroots-git and sway-git together."
- echo "Upgrading one but not the other is unsupported."
-}