summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Burgos2021-12-29 16:22:03 -0600
committerSam Burgos2021-12-29 16:22:03 -0600
commit0a6b536e0ff15daf27cadbaa191936302af3c9d8 (patch)
tree8574bcf07a9fab548e5e41cbf0067807cff044a6
parent743b046a87a6a9e4325a80ac79ffb05ea17f1d85 (diff)
downloadaur-0a6b536e0ff15daf27cadbaa191936302af3c9d8.tar.gz
removed additional filemanager plugins, these will be added on other packages
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD82
2 files changed, 18 insertions, 95 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 627b074572a8..bb40d24c447d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,45 +1,26 @@
pkgbase = gtkhash
pkgdesc = A GTK+ utility for computing message digests or checksums
pkgver = 1.4
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/tristanheaven/gtkhash
arch = x86_64
license = GPL
- makedepends = caja
makedepends = dconf
makedepends = gtk3
makedepends = intltool
- makedepends = libnautilus-extension
makedepends = librsvg
- makedepends = nemo
makedepends = nettle
- makedepends = thunar
makedepends = xdg-utils
depends = dconf
depends = gtk3
depends = libb2
depends = nettle
+ provides = gtkhash
+ conflicts = gtkhash-caja
+ conflicts = gtkhash-nautilus
+ conflicts = gtkhash-nemo
+ conflicts = gtkhash-thunar
source = https://github.com/tristanheaven/gtkhash/releases/download/v1.4/gtkhash-1.4.tar.xz
sha256sums = 20b57dbb8f6c6d7323f573c111a11640603a422c5f9da7b302a4981e4adc37c4
pkgname = gtkhash
-
-pkgname = gtkhash-caja
- pkgdesc = A GTK+ utility for computing message digests or checksums (Caja filemanager plugin)
- depends = gtkhash
- depends = caja
-
-pkgname = gtkhash-nautilus
- pkgdesc = A GTK+ utility for computing message digests or checksums (Nautilus filemanager plugin)
- depends = gtkhash
- depends = nautilus
-
-pkgname = gtkhash-nemo
- pkgdesc = A GTK+ utility for computing message digests or checksums (Nemo filemanager plugin)
- depends = gtkhash
- depends = nemo
-
-pkgname = gtkhash-thunar
- pkgdesc = A GTK+ utility for computing message digests or checksums (Thunar filemanager plugin)
- depends = gtkhash
- depends = thunar
diff --git a/PKGBUILD b/PKGBUILD
index ba12d3ce0f79..bd8dcb3bfbfe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,9 @@
# Contributor: Frédérik Paradis <fredy_14@live.fr>
# Contributor: GI_Jack <GI_Jack@hushmail.com>
-pkgbase=gtkhash
-pkgname=(
- gtkhash
- gtkhash-caja
- gtkhash-nautilus
- gtkhash-nemo
- gtkhash-thunar
-)
+pkgname=gtkhash
pkgver=1.4
-pkgrel=4
+pkgrel=5
pkgdesc="A GTK+ utility for computing message digests or checksums"
arch=('x86_64')
url="https://github.com/tristanheaven/gtkhash"
@@ -26,17 +19,20 @@ depends=(
)
makedepends=(
- 'caja'
'dconf'
'gtk3'
- 'intltool'
- 'libnautilus-extension'
+ 'intltool'
'librsvg'
- 'nemo'
'nettle'
- 'thunar'
'xdg-utils'
)
+provides=(${pkgname})
+conflicts=(
+ gtkhash-caja
+ gtkhash-nautilus
+ gtkhash-nemo
+ gtkhash-thunar
+)
source=("${url}/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz")
sha256sums=('20b57dbb8f6c6d7323f573c111a11640603a422c5f9da7b302a4981e4adc37c4')
@@ -49,64 +45,10 @@ build() {
--enable-linux-crypto \
--enable-nettle \
--disable-blake2 \
- --with-gtk=3.0 \
- --enable-nemo \
- --enable-nautilus \
- --enable-thunar \
- --enable-caja
+ --with-gtk=3.0
make
}
-package_gtkhash() {
+package() {
make -C gtkhash-$pkgver DESTDIR="$pkgdir/" install
- # remove filemanager plugins
- rm -rf "$pkgdir"/usr/lib
-}
-
-package_gtkhash-caja() {
- pkgdesc+=' (Caja filemanager plugin)'
- depends=(
- 'gtkhash'
- 'caja'
-)
-
- make -C gtkhash-$pkgver/src/nautilus DESTDIR="$pkgdir/" install
- # remove other filemanager plugins
- rm -rf "$pkgdir"/usr/lib/{thunarx-{2,3},nautilus,nemo}
-}
-
-package_gtkhash-nautilus() {
- pkgdesc+=' (Nautilus filemanager plugin)'
- depends=(
- 'gtkhash'
- 'nautilus'
-)
-
- make -C gtkhash-$pkgver/src/nautilus DESTDIR="$pkgdir/" install
- # remove other filemanager plugins
- rm -rf "$pkgdir"/usr/lib/{thunarx-{2,3},caja,nemo}
-}
-
-package_gtkhash-nemo() {
- pkgdesc+=' (Nemo filemanager plugin)'
- depends=(
- 'gtkhash'
- 'nemo'
- )
-
- make -C gtkhash-$pkgver/src/nautilus DESTDIR="$pkgdir/" install
- # remove other filemanager plugins
- rm -rf "$pkgdir"/usr/lib/{thunarx-{2,3},nautilus,caja}
-}
-
-package_gtkhash-thunar() {
- pkgdesc+=' (Thunar filemanager plugin)'
- depends=(
- 'gtkhash'
- 'thunar'
-)
-
- make -C gtkhash-$pkgver/src/nautilus DESTDIR="$pkgdir/" install
- # remove other filemanager plugins
- rm -rf "$pkgdir"/usr/lib/{nautilus,caja,nemo}
}