summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyrozap2021-12-15 03:46:42 -0600
committercyrozap2021-12-15 03:46:42 -0600
commit0aac3c51b10c012ff1e77190cfd26562922368d6 (patch)
tree64e51b204c0339bbd7838065293a4a10d76c131f
parent46532f66f25cb0d336a9dbe2eff8b390ce4714e4 (diff)
downloadaur-0aac3c51b10c012ff1e77190cfd26562922368d6.tar.gz
Add support for aarch64
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 6 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1d80d00500f..3cde90670e22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = digilent.adept.runtime
arch = x86_64
arch = armv6h
arch = armv7h
+ arch = aarch64
license = custom
depends = libusb
options = !strip
@@ -21,5 +22,7 @@ pkgbase = digilent.adept.runtime
sha256sums_armv6h = 0be9b03500f0e746829a54fceac3b10cca0d0d3c24563c7debcadd15e2d8a73b
source_armv7h = https://digilent.s3.amazonaws.com/Software/Adept2+Runtime/2.21.3/digilent.adept.runtime_2.21.3-armhf.deb
sha256sums_armv7h = 0be9b03500f0e746829a54fceac3b10cca0d0d3c24563c7debcadd15e2d8a73b
+ source_aarch64 = https://digilent.s3.amazonaws.com/Software/Adept2+Runtime/2.21.3/digilent.adept.runtime_2.21.3-arm64.deb
+ sha256sums_aarch64 = 94b2c6dcb7f55700af28c86968105cdafd64d96fe47d7304b02d460345f64d44
pkgname = digilent.adept.runtime
diff --git a/PKGBUILD b/PKGBUILD
index 9435dce2d1e6..47388a0f7f2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,18 @@ pkgname=digilent.adept.runtime
pkgver=2.21.3
pkgrel=1
pkgdesc="The Adept Runtime consists of the shared libraries, firmware images, and configuration files necessary to communicate with Digilent's devices."
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://reference.digilentinc.com/reference/software/adept/start"
license=('custom')
depends=('libusb')
options=('!strip')
backup=('etc/digilent-adept.conf' 'etc/ld.so.conf.d/digilent-adept-libraries.conf' 'etc/udev/rules.d/52-digilent-usb.rules')
+source_aarch64=("https://digilent.s3.amazonaws.com/Software/Adept2+Runtime/${pkgver}/${pkgname}_${pkgver}-arm64.deb")
source_armv6h=("https://digilent.s3.amazonaws.com/Software/Adept2+Runtime/${pkgver}/${pkgname}_${pkgver}-armhf.deb")
source_armv7h=($source_armv6h)
source_i686=("https://digilent.s3.amazonaws.com/Software/Adept2+Runtime/${pkgver}/${pkgname}_${pkgver}-i386.deb")
source_x86_64=("https://digilent.s3.amazonaws.com/Software/Adept2+Runtime/${pkgver}/${pkgname}_${pkgver}-amd64.deb")
+sha256sums_aarch64=('94b2c6dcb7f55700af28c86968105cdafd64d96fe47d7304b02d460345f64d44')
sha256sums_armv6h=('0be9b03500f0e746829a54fceac3b10cca0d0d3c24563c7debcadd15e2d8a73b')
sha256sums_armv7h=($sha256sums_armv6h)
sha256sums_i686=('220a12dda8df2946b2831245d84d3f75037ea92c55a37d6de19b97a73f697b74')