summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmish2022-12-06 22:29:03 +0530
committerAmish2022-12-06 22:29:03 +0530
commit0c74ffb79dfc2aa341a3e074ee958bc60d92a13b (patch)
treefc4c1275af179cb7b37425c73b42147d8f1fd957
parentbda7433442614a55e9617b3d8f74d7b81731565d (diff)
downloadaur-0c74ffb79dfc2aa341a3e074ee958bc60d92a13b.tar.gz
Move -Q option from snort.service to local.lua
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--local.lua4
-rw-r--r--snort.service4
4 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 358970eb54fd..77d6a5305a6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = snort-nfqueue
pkgdesc = A lightweight network IDS / IPS with NFQUEUE and OpenAppID support.
pkgver = 3.1.48.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.snort.org
install = snort.install
arch = i686
@@ -45,10 +45,10 @@ pkgbase = snort-nfqueue
source = snort.service
sha256sums = 65df088a8cac11e59f0b71a7f98fc9d21eeb0e31d35280c470c985172947ebfe
sha256sums = 8513877ce2264bb22119d911c2cf11f73735c866e2ca0d061c35eef6740d51f9
- sha256sums = 518dc2b531baffda9ee87494a6eebc3ebaa12ee7725a8570d0eb18a78c64cf15
+ sha256sums = bf49316d7c287240ee2efc1f6bddaf7833ec6fa57f9be452820a2dea99fe914f
sha256sums = a8a7684a676da5cd55c2b5ab012dac3d14c5a6c62f6e37c4913ba1dbe506088e
sha256sums = ae3245c5de527fb487c459f2f4a9c78803ae6341e9c81b9a404277679cdee051
sha256sums = bc4a02d184601faba5cd0f6cb454097a3b04a0c8fe56f5f8b36d24513484faa2
- sha256sums = 7f624e050265896fde5617305e9a28239bd41c6320427ecb8c2ecf4e4b86ed29
+ sha256sums = cb1108ab0a6ad38981a6f308b0ae2b276b68d08bfa0e38c036eae277b38b28d8
pkgname = snort-nfqueue
diff --git a/PKGBUILD b/PKGBUILD
index cba3490ac97d..af5e06d5cbc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=snort-nfqueue
_pkgname=snort3
_openappid=26425
pkgver=3.1.48.0
-pkgrel=1
+pkgrel=2
pkgdesc='A lightweight network IDS / IPS with NFQUEUE and OpenAppID support.'
arch=('i686' 'x86_64')
url='https://www.snort.org'
@@ -32,11 +32,11 @@ source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/snort3/snort3/archive/
'snort.service')
sha256sums=('65df088a8cac11e59f0b71a7f98fc9d21eeb0e31d35280c470c985172947ebfe'
'8513877ce2264bb22119d911c2cf11f73735c866e2ca0d061c35eef6740d51f9'
- '518dc2b531baffda9ee87494a6eebc3ebaa12ee7725a8570d0eb18a78c64cf15'
+ 'bf49316d7c287240ee2efc1f6bddaf7833ec6fa57f9be452820a2dea99fe914f'
'a8a7684a676da5cd55c2b5ab012dac3d14c5a6c62f6e37c4913ba1dbe506088e'
'ae3245c5de527fb487c459f2f4a9c78803ae6341e9c81b9a404277679cdee051'
'bc4a02d184601faba5cd0f6cb454097a3b04a0c8fe56f5f8b36d24513484faa2'
- '7f624e050265896fde5617305e9a28239bd41c6320427ecb8c2ecf4e4b86ed29')
+ 'cb1108ab0a6ad38981a6f308b0ae2b276b68d08bfa0e38c036eae277b38b28d8')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
diff --git a/local.lua b/local.lua
index 03b3a5f6fbfb..6c7841b1d1e7 100644
--- a/local.lua
+++ b/local.lua
@@ -1,3 +1,7 @@
+-- use this file for local configuration
+snort = {}
+snort['-Q'] = true -- inline mode
+
daq =
{
modules =
diff --git a/snort.service b/snort.service
index 00ac3d365be9..2d21f3a49f3a 100644
--- a/snort.service
+++ b/snort.service
@@ -1,8 +1,8 @@
[Unit]
-Description=Snort IDS daemon in NFQUEUE mode
+Description=Snort IDS / IPS daemon
[Service]
-ExecStart=/usr/bin/snort -Q -M -c /etc/snort/snort.lua -l /var/log/snort --tweaks local
+ExecStart=/usr/bin/snort -M -c /etc/snort/snort.lua -l /var/log/snort --tweaks local
ExecReload=kill -HUP $MAINPID
[Install]