summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVekhir2023-11-15 20:24:22 +0100
committerbartoszek2024-01-16 17:58:55 +0100
commit0c75973b8ca4ca1bec232b850348409fc47ce8ce (patch)
tree4a511a717d7a381c9f2dfddbecb6942a2e74d94e
parent784fa0b49da1dca03c5d48b6d272895c53e03217 (diff)
downloadaur-0c75973b8ca4ca1bec232b850348409fc47ce8ce.tar.gz
Fix build issues
Upstream has merged the fixes for c++17 and gcc11, so remove those patches. The quazip logic upstream has changed to automatically search for quazip 5 or 6 depending on Qt version. Updated quazip.patch to account for that. OpenBoard now starts with startup hints. An additional directory, OpenBoard/resources/startupHints, contains the relevant files and must be installed too. Qt Script isn't used anymore and Qt WebKit has been replaced by Qt WebEngine. Qt tools is only used during building for lrelease.
-rw-r--r--PKGBUILD18
-rw-r--r--c++17.patch16
-rw-r--r--quazip.patch21
3 files changed, 19 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b257f34efcb6..61567a99aa28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,30 +4,28 @@
pkgname=openboard-git
_fragment="#branch=master"
-pkgver=1.6.1.r6.gdd19e752
-pkgrel=3
+pkgver=1.6.4.r502.g1420d5f3
+pkgrel=1
pkgdesc="Interactive whiteboard software for schools and universities (development version current master)"
arch=('x86_64' 'i686')
url="http://openboard.ch/index.en.html"
license=('GPL3')
provides=("${pkgname%-git}=${pkgver%%.r*}")
conflicts=("${pkgname%-git}")
-depends=('qt5-base' 'qt5-multimedia' 'qt5-svg' 'qt5-script' 'qt5-webkit' 'qt5-tools' 'qt5-xmlpatterns' 'libpaper' 'bzip2' 'openssl' 'libfdk-aac' 'sdl' 'ffmpeg')
+depends=('qt5-base' 'qt5-multimedia' 'qt5-svg' 'qt5-webengine' 'qt5-xmlpatterns' 'libpaper' 'bzip2' 'openssl' 'libfdk-aac' 'sdl' 'ffmpeg')
depends+=(quazip) #drop internal quazip and use system one.
depends+=(poppler) #replace internal xpdf with poppler and drop freetype/xpdf from deps
-makedepends=(git)
+makedepends=(git qt5-tools)
source=("git+https://github.com/OpenBoard-org/OpenBoard.git${_fragment}"
openboard.desktop)
source+=(qchar.patch)
source+=(quazip.patch)
-source+=(c++17.patch)
source+=(drop_ThirdParty_repo.patch)
source+=(30fps.patch)
sha256sums=('SKIP'
'e518455b149ced284f515219d752a579f82c67fd143c6f489ea00ff0741a0c79'
'b40fdab85f5921d0404c07db64628a2428a87d39193d2797bbef2e69b1d51549'
- '0a9d037336dab3dbd99652b71934a94cd1e9801650fe5e72f4dd1de1718dd4c1'
- '7b3ca090cee096f47b27f29f2a1a956b4afcaa08338a084fcb20cd7f01d71e26'
+ 'c0a7404eb46c07ccbf28d0496727d95a168bbdfe8aa3466a986d44ba34396841'
'a6a9bc1f9c9bee0345b735fcf422245ae7946f96f6c34520dd63530a98978c14'
'205062adbbd48d6622341e316e14a5496f73696385a3ed5cda7a89d3e7d2861d')
@@ -44,10 +42,6 @@ prepare() {
patch -p1 < "$srcdir"/qchar.patch
msg2 "quazip"
patch -p1 < "$srcdir"/quazip.patch
- msg2 "cpp17"
- patch -p1 < "$srcdir"/c++17.patch
- msg2 "gcc11"
- sed 's/_serialize/serialize/g' -i src/pdf-merger/Object.{h,cpp}
}
build() {
@@ -63,7 +57,7 @@ package() {
cd "$srcdir"/OpenBoard
install -Dm755 build/linux/release/product/OpenBoard -t "$pkgdir"/opt/openboard/
- cp -rp "$srcdir"/OpenBoard/resources/{customizations,etc,i18n,library} -t "$pkgdir"/opt/openboard/
+ cp -rp "$srcdir"/OpenBoard/resources/{customizations,etc,i18n,library,startupHints} -t "$pkgdir"/opt/openboard/
install -Dm644 "$srcdir"/OpenBoard/resources/images/OpenBoard.png -t "$pkgdir"/usr/share/icons/hicolor/64x64/apps/
install -Dm644 "$srcdir"/openboard.desktop -t "$pkgdir"/usr/share/applications/
install -dm755 "$pkgdir"/usr/bin/
diff --git a/c++17.patch b/c++17.patch
deleted file mode 100644
index c919284db87e..000000000000
--- a/c++17.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- orig/OpenBoard.pro 2022-01-17 19:21:33.000000000 +0100
-+++ OpenBoard-1.6.1/OpenBoard.pro 2022-01-13 20:52:35.000000000 +0100
-@@ -1,11 +1,12 @@
- TARGET = "OpenBoard"
- TEMPLATE = app
-
--CONFIG += c++14
-+CONFIG += c++1z
- CONFIG -= flat
- CONFIG += debug_and_release \
- no_include_pwd
-
-+QMAKE_CXXFLAGS += -std=c++17
-
- VERSION_MAJ = 1
- VERSION_MIN = 6
diff --git a/quazip.patch b/quazip.patch
index 7793bf5a20bb..0d2eb68d9d10 100644
--- a/quazip.patch
+++ b/quazip.patch
@@ -1,17 +1,22 @@
diff -Naur OpenBoard-1.6.0a3.orig/OpenBoard.pro OpenBoard-1.6.0a3/OpenBoard.pro
--- OpenBoard-1.6.0a3.orig/OpenBoard.pro 2020-05-22 18:40:49.000000000 +0200
+++ OpenBoard-1.6.0a3/OpenBoard.pro 2020-10-12 07:26:16.628748656 +0200
-@@ -433,8 +431,8 @@
- LIBS += -lcrypto
- #LIBS += -lprofiler
+@@ -466,11 +466,11 @@
LIBS += -lX11
-- LIBS += -lquazip5
-- INCLUDEPATH += "/usr/include/quazip"
-+ LIBS += "-lquazip1-qt5"
-+ INCLUDEPATH += /usr/include/QuaZip-Qt5-1.2/quazip
+
+ greaterThan(QT_MAJOR_VERSION, 5) {
+- LIBS += -lquazip6
+- INCLUDEPATH += "/usr/include/quazip6"
++ LIBS += -lquazip1-qt6
++ INCLUDEPATH += "/usr/include/QuaZip-Qt6-1.4/quazip"
+ } else {
+- LIBS += -lquazip5
+- INCLUDEPATH += "/usr/include/quazip5"
++ LIBS += "-lquazip1-qt5"
++ INCLUDEPATH += /usr/include/QuaZip-Qt5-1.4/quazip
+ }
LIBS += -lpoppler
- INCLUDEPATH += "/usr/include/poppler"
diff -Naur OpenBoard-1.6.0a3.orig/plugins/cffadaptor/UBCFFAdaptor.pro OpenBoard-1.6.0a3/plugins/cffadaptor/UBCFFAdaptor.pro
--- OpenBoard-1.6.0a3.orig/plugins/cffadaptor/UBCFFAdaptor.pro 2020-05-22 18:40:49.000000000 +0200
+++ OpenBoard-1.6.0a3/plugins/cffadaptor/UBCFFAdaptor.pro 2020-10-12 07:20:08.496096917 +0200