summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Shapovalov2024-04-30 16:55:14 +0300
committerIvan Shapovalov2024-04-30 16:55:14 +0300
commit0ecafb7fb375d506f6035bfa05ffebcff53fb0e7 (patch)
tree03c0d54d004399327275c2ec80516b84bc919696
parentd115b0b722e7f494ff6014b167916d188a5d2cb7 (diff)
downloadaur-0ecafb7fb375d506f6035bfa05ffebcff53fb0e7.tar.gz
Bump, add python-setuptools makedep, resync against extra/libimobiledevice
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee345ac59847..6dbcd360d49d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
pkgbase = libimobiledevice-git
pkgdesc = Library that talks the protocols to support iPhone and iPod Touch devices on Linux
- pkgver = 1.3.0.r219.g3969bc9
+ pkgver = 1.3.0.r224.g77c727b
pkgrel = 1
epoch = 1
url = http://www.libimobiledevice.org/
arch = x86_64
- license = GPL2
- license = LGPL2.1
+ license = LGPL-2.1-or-later
makedepends = git
makedepends = cython
makedepends = python
+ makedepends = python-setuptools
depends = glibc
depends = libplist-git
depends = libusbmuxd-git
depends = libimobiledevice-glue-git
depends = openssl
- optdepends = python: for the Python bindings
+ optdepends = python: Python bindings
provides = libimobiledevice-1.0.so
- provides = libimobiledevice=1.3.0.r219.g3969bc9
+ provides = libimobiledevice=1.3.0.r224.g77c727b
conflicts = libimobiledevice
source = git+https://github.com/libimobiledevice/libimobiledevice
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 54241a7c472b..d5d8d509bd98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,15 @@
pkgname=libimobiledevice-git
epoch=1
-pkgver=1.3.0.r219.g3969bc9
+pkgver=1.3.0.r224.g77c727b
pkgrel=1
pkgdesc="Library that talks the protocols to support iPhone and iPod Touch devices on Linux"
url="http://www.libimobiledevice.org/"
arch=(x86_64)
-license=(GPL2 LGPL2.1)
+license=('LGPL-2.1-or-later')
depends=('glibc' 'libplist-git' 'libusbmuxd-git' 'libimobiledevice-glue-git' 'openssl')
-makedepends=('git' 'cython' 'python')
-optdepends=('python: for the Python bindings')
+makedepends=('git' 'cython' 'python' 'python-setuptools')
+optdepends=('python: Python bindings')
provides=(libimobiledevice-1.0.so "libimobiledevice=$pkgver")
conflicts=(libimobiledevice)
source=("git+https://github.com/libimobiledevice/libimobiledevice")
@@ -33,6 +33,7 @@ prepare() {
build() {
cd libimobiledevice
./configure --prefix=/usr
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}