summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Krivopalov2018-07-17 18:06:25 -0700
committerVladimir Krivopalov2018-07-17 18:06:25 -0700
commit1201f50fa1ef65c0de220a8b4eb639bf25021890 (patch)
treee23e0f8e4393a7f56d294a3821d6b03fa1220939
parent21b76fb33a9a55a4163d745cf5875af0e1c54eb5 (diff)
downloadaur-1201f50fa1ef65c0de220a8b4eb639bf25021890.tar.gz
2.1.3 -> 2.2.0
Signed-off-by: Vladimir Krivopalov <vladimir.krivopalov@gmail.com>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5adea4e12b9a..5c75a8fa229c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = scylla
pkgdesc = Scylla is an open source NoSQL drop-in replacement for Apache Cassandra with fast throughput and low latency
- pkgver = 2.1.3
- pkgrel = 2
+ pkgver = 2.2.0
+ pkgrel = 1
url = http://www.scylladb.com/
install = .install
arch = x86_64
license = AGPL
makedepends = git
- makedepends = gcc7
- makedepends = gcc7-libs
makedepends = antlr3-cpp-headers-git
makedepends = libyaml
makedepends = yaml-cpp
@@ -61,7 +59,7 @@ pkgbase = scylla
backup = etc/scylla.d/cpuset.conf
backup = etc/scylla.d/dev-mode.conf
backup = etc/scylla.d/io.conf
- source = git+https://github.com/scylladb/scylla.git#tag=scylla-2.1.3
+ source = git+https://github.com/scylladb/scylla.git#tag=scylla-2.2.0
source = git+https://github.com/scylladb/scylla-ami.git
source = git+https://github.com/scylladb/scylla-swagger-ui.git
source = git+https://github.com/scylladb/scylla-seastar.git
diff --git a/PKGBUILD b/PKGBUILD
index 54c25f34c04c..dd5a9151ff85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Main package information
pkgname=scylla
-pkgver=2.1.3
-pkgrel=2
+pkgver=2.2.0
+pkgrel=1
pkgdesc="Scylla is an open source NoSQL drop-in replacement for Apache Cassandra with fast throughput and low latency"
arch=('x86_64')
url="http://www.scylladb.com/"
@@ -17,7 +17,7 @@ depends=('hwloc' 'systemd' 'collectd' 'python-yaml' 'python2-yaml' 'python-urwid
optdepends=('scylla-jmx: JMX interface for compatibility with tooling such as nodetool'
'scylla-tools: Tools to be used with ScyllaDB, such as cqlsh, nodetool and others')
-makedepends=('git' 'gcc7' 'gcc7-libs' 'antlr3-cpp-headers-git' 'libyaml' 'yaml-cpp'
+makedepends=('git' 'antlr3-cpp-headers-git' 'libyaml' 'yaml-cpp'
'lz4' 'zlib' 'snappy' 'jsoncpp' 'gnutls' 'ninja'
'ragel' 'libaio' 'crypto++' 'xfsprogs' 'jre8-openjdk-headless'
'numactl' 'libpciaccess' 'libxml2' 'thrift-0.10.0' 'lksctp-tools'
@@ -57,7 +57,7 @@ build() {
cd "$srcdir/${pkgname}"
sed -i -e 's@sizeof(byte)@sizeof(CryptoPP::byte)@g' md5_hasher.hh repair/repair.cc
sed -i -e 's@reinterpret_cast<const byte@reinterpret_cast<const CryptoPP::byte@g' md5_hasher.hh repair/repair.cc
- ./configure.py --mode=release --c-compiler=gcc-7 --compiler=g++-7
+ ./configure.py --mode=release
JOBS=`nproc --all`
# It turns out that on maximum jobs compiler often runs out of memory and crashes
# Let's be conservative and assign only half of the available CPU threads