summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Legner2018-01-16 21:34:57 +0100
committerSimon Legner2018-01-16 21:40:19 +0100
commit13c35e3a7f65a20a8af36690107aa9716e134331 (patch)
treea3467f6f2d689fc6bbe9c01c50331ae876466eed
parent6aa8510440fe3918fccc677796e0486b873e2061 (diff)
downloadaur-13c35e3a7f65a20a8af36690107aa9716e134331.tar.gz
Update to camlidl-1.06-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
-rw-r--r--arch-build-system-fix.patch56
-rw-r--r--rename-array-module-for-ocaml-4.03.patch134
4 files changed, 19 insertions, 225 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eebbaba5b0ec..0a520a77b0e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,20 @@
# Generated by mksrcinfo v8
-# Tue Oct 31 08:07:11 UTC 2017
+# Tue Jan 16 20:34:05 UTC 2018
pkgbase = camlidl
pkgdesc = A stub code generator and COM binding for Objective Caml (OCaml)
- pkgver = 1.05
- pkgrel = 7
+ pkgver = 1.06
+ pkgrel = 1
url = https://github.com/xavierleroy/camlidl
arch = i686
arch = x86_64
license = custom
depends = ocaml
options = staticlibs
- source = http://caml.inria.fr/pub/old_caml_site/distrib/bazar-ocaml/camlidl-1.05.tar.gz
- source = arch-build-system-fix.patch
- source = rename-array-module-for-ocaml-4.03.patch
+ source = https://github.com/xavierleroy/camlidl/archive/camlidl106.tar.gz
source = META.camlidl
- sha1sums = 2a0d5ba70fea8c1de1c5387f8b2058357b2177df
- sha1sums = b5cf6873bda3fe48f9946f09ccea39cd60fda59c
- sha1sums = 19e42c60e2e7448951fc87bb70a3e8fb26244e08
+ sha1sums = 674c75608faa841caea5a3d3c75dc8ff58d5c5a4
sha1sums = 2e26acb071e62574ced84ff7aa3a7164e27daef0
- sha256sums = 857ed5bd3b2f99c62813070e1a5b4b6375e837c6815f4ad956baeb6f8c660311
- sha256sums = 4b5a3495db307970fef1e408e1e5caa92c3d3fde5c5fafe81b6d679662ab688c
- sha256sums = 78646a2022617e484b48aa7a5f7aa322696639b8b1eb195f07e88eb143dd735d
+ sha256sums = abf490f1b07f23ed8c9f050475832436c56db22c40083c87f89cb5d4250cf12a
sha256sums = 1a060499f884670ad3ad5f9dbd8421ea3754947b0ee955424490848acb39ce42
pkgname = camlidl
diff --git a/PKGBUILD b/PKGBUILD
index a8f8d6e0f7d7..b54ff14480e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,48 +3,38 @@
# Contributor: Bertram Felgenhauer <int-e@gmx.de>
# Maintainer: Simon Legner <Simon.Legner@gmail.com>
pkgname=camlidl
-pkgver=1.05
-pkgrel=7
+pkgver=1.06
+_pkgver=${pkgver/\./}
+pkgrel=1
pkgdesc="A stub code generator and COM binding for Objective Caml (OCaml)"
arch=('i686' 'x86_64')
url="https://github.com/xavierleroy/camlidl"
license=('custom')
depends=('ocaml')
options=(staticlibs)
-source=(http://caml.inria.fr/pub/old_caml_site/distrib/bazar-ocaml/$pkgname-$pkgver.tar.gz
- arch-build-system-fix.patch
- rename-array-module-for-ocaml-4.03.patch
+source=(https://github.com/xavierleroy/$pkgname/archive/$pkgname$_pkgver.tar.gz
META.camlidl)
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -Np1 -i ${srcdir}/arch-build-system-fix.patch
- patch -Np1 -i ${srcdir}/rename-array-module-for-ocaml-4.03.patch
- cp config/Makefile.unix config/Makefile
-}
-
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgname$_pkgver"
+ cp config/Makefile.unix config/Makefile
make all
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgname$_pkgver"
- local _ocamldir=$(ocamlc -where)
- mkdir -p ${pkgdir}/usr/bin ${pkgdir}/${_ocamldir}/{caml,${pkgname}}
+ local _bindir=$pkgdir/usr/bin
+ local _ocamldir=$pkgdir/$(ocamlc -where)
+ mkdir -p $_bindir $_ocamldir/{caml,stublibs,$pkgname}
- make DESTDIR=${pkgdir} install
+ make BINDIR=$_bindir OCAMLLIB=$_ocamldir install
install -Dm644 ${srcdir}/META.camlidl ${pkgdir}/${_ocamldir}/${pkgname}/META
install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}
-sha1sums=('2a0d5ba70fea8c1de1c5387f8b2058357b2177df'
- 'b5cf6873bda3fe48f9946f09ccea39cd60fda59c'
- '19e42c60e2e7448951fc87bb70a3e8fb26244e08'
+sha1sums=('674c75608faa841caea5a3d3c75dc8ff58d5c5a4'
'2e26acb071e62574ced84ff7aa3a7164e27daef0')
-sha256sums=('857ed5bd3b2f99c62813070e1a5b4b6375e837c6815f4ad956baeb6f8c660311'
- '4b5a3495db307970fef1e408e1e5caa92c3d3fde5c5fafe81b6d679662ab688c'
- '78646a2022617e484b48aa7a5f7aa322696639b8b1eb195f07e88eb143dd735d'
+sha256sums=('abf490f1b07f23ed8c9f050475832436c56db22c40083c87f89cb5d4250cf12a'
'1a060499f884670ad3ad5f9dbd8421ea3754947b0ee955424490848acb39ce42')
diff --git a/arch-build-system-fix.patch b/arch-build-system-fix.patch
index 8a65a3a3c0c1..711504ecdd16 100644
--- a/arch-build-system-fix.patch
+++ b/arch-build-system-fix.patch
@@ -1,42 +1,3 @@
-From a29e6b96b4574be8eaeb8c9c7514583734108cae Mon Sep 17 00:00:00 2001
-From: Bertram Felgenhauer <int-e@gmx.de>
-Date: Thu, 27 Oct 2016 10:45:13 +0200
-Subject: [PATCH 1/2] arch build system fix
-
----
- config/Makefile.unix | 8 +++++---
- lib/Makefile | 10 ++++++++--
- runtime/Makefile.unix | 2 +-
- 3 files changed, 14 insertions(+), 6 deletions(-)
-
-diff --git a/config/Makefile.unix b/config/Makefile.unix
-index cf4549c..fc8c063 100644
---- a/config/Makefile.unix
-+++ b/config/Makefile.unix
-@@ -19,7 +19,7 @@ OSTYPE=unix
-
- # How to invoke the C preprocessor
- # Works on most Unix systems:
--CPP=/lib/cpp
-+CPP=$(shell which cpp)
- # Alternatives:
- # CPP=cpp
- # CPP=/usr/ccs/lib/cpp
-@@ -31,10 +31,12 @@ RANLIB=ranlib
- #RANLIB=:
-
- # Location of the Objective Caml library in your installation
--OCAMLLIB=/usr/local/lib/ocaml
-+OCAMLBASEDIR=$(shell ocamlc -where)
-+OCAMLLIB=$(DESTDIR)$(OCAMLBASEDIR)
-+OCAMLINCDIR=$(DESTDIR)$(OCAMLBASEDIR)/caml
-
- # Where to install the binaries
--BINDIR=/usr/local/bin
-+BINDIR=$(DESTDIR)/usr/bin
-
- # The Objective Caml compilers (the defaults below should be OK)
- OCAMLC=ocamlc -g
diff --git a/lib/Makefile b/lib/Makefile
index 7ce04da..c347d6f 100644
--- a/lib/Makefile
@@ -57,20 +18,3 @@ index 7ce04da..c347d6f 100644
+ fi
.SUFFIXES: .mli .ml .cmi .cmo .cmx
-
-diff --git a/runtime/Makefile.unix b/runtime/Makefile.unix
-index 5617349..737b048 100644
---- a/runtime/Makefile.unix
-+++ b/runtime/Makefile.unix
-@@ -22,7 +22,7 @@ libcamlidl.a: $(OBJS)
- $(RANLIB) $@
-
- install:
-- cp camlidlruntime.h $(OCAMLLIB)/caml/camlidlruntime.h
-+ cp camlidlruntime.h $(OCAMLINCDIR)/camlidlruntime.h
- cp libcamlidl.a $(OCAMLLIB)/libcamlidl.a
- cd $(OCAMLLIB); $(RANLIB) libcamlidl.a
-
---
-2.10.1
-
diff --git a/rename-array-module-for-ocaml-4.03.patch b/rename-array-module-for-ocaml-4.03.patch
deleted file mode 100644
index 46f4f02ec864..000000000000
--- a/rename-array-module-for-ocaml-4.03.patch
+++ /dev/null
@@ -1,134 +0,0 @@
-From fd8f7aa5b1b29912bf794ae0df71a9b2207027f1 Mon Sep 17 00:00:00 2001
-From: Bertram Felgenhauer <int-e@gmx.de>
-Date: Thu, 27 Oct 2016 10:45:43 +0200
-Subject: [PATCH] rename array module for ocaml 4.03
-
----
- compiler/.depend | 14 +++++++-------
- compiler/Makefile | 2 +-
- compiler/{array.ml => array_camlidl.ml} | 0
- compiler/{array.mli => array_camlidl.mli} | 0
- compiler/cvtval.ml | 20 ++++++++++----------
- 5 files changed, 18 insertions(+), 18 deletions(-)
- rename compiler/{array.ml => array_camlidl.ml} (100%)
- rename compiler/{array.mli => array_camlidl.mli} (100%)
-
-diff --git a/compiler/.depend b/compiler/.depend
-index d014910..e58c23c 100644
---- a/compiler/.depend
-+++ b/compiler/.depend
-@@ -1,4 +1,4 @@
--array.cmi: idltypes.cmi prefix.cmi
-+array_camlidl.cmi: idltypes.cmi prefix.cmi
- constdecl.cmi: idltypes.cmi
- cvttyp.cmi: idltypes.cmi
- cvtval.cmi: idltypes.cmi prefix.cmi
-@@ -22,10 +22,10 @@ typedef.cmi: idltypes.cmi
- uniondecl.cmi: idltypes.cmi
- union.cmi: idltypes.cmi prefix.cmi
- variables.cmi: idltypes.cmi
--array.cmo: cvttyp.cmi idltypes.cmi lexpr.cmi utils.cmi variables.cmi \
-- array.cmi
--array.cmx: cvttyp.cmx idltypes.cmi lexpr.cmx utils.cmx variables.cmx \
-- array.cmi
-+array_camlidl.cmo: cvttyp.cmi idltypes.cmi lexpr.cmi utils.cmi variables.cmi \
-+ array_camlidl.cmi
-+array_camlidl.cmx: cvttyp.cmx idltypes.cmi lexpr.cmx utils.cmx variables.cmx \
-+ array_camlidl.cmi
- clflags.cmo: config.cmi
- clflags.cmx: config.cmx
- config.cmo: config.cmi
-@@ -34,9 +34,9 @@ constdecl.cmo: cvttyp.cmi idltypes.cmi lexpr.cmi utils.cmi constdecl.cmi
- constdecl.cmx: cvttyp.cmx idltypes.cmi lexpr.cmx utils.cmx constdecl.cmi
- cvttyp.cmo: config.cmi idltypes.cmi lexpr.cmi utils.cmi cvttyp.cmi
- cvttyp.cmx: config.cmx idltypes.cmi lexpr.cmx utils.cmx cvttyp.cmi
--cvtval.cmo: array.cmi cvttyp.cmi enum.cmi idltypes.cmi lexpr.cmi struct.cmi \
-+cvtval.cmo: array_camlidl.cmi cvttyp.cmi enum.cmi idltypes.cmi lexpr.cmi struct.cmi \
- union.cmi utils.cmi variables.cmi cvtval.cmi
--cvtval.cmx: array.cmx cvttyp.cmx enum.cmx idltypes.cmi lexpr.cmx struct.cmx \
-+cvtval.cmx: array_camlidl.cmx cvttyp.cmx enum.cmx idltypes.cmi lexpr.cmx struct.cmx \
- union.cmx utils.cmx variables.cmx cvtval.cmi
- enumdecl.cmo: cvttyp.cmi cvtval.cmi enum.cmi idltypes.cmi utils.cmi \
- variables.cmi enumdecl.cmi
-diff --git a/compiler/Makefile b/compiler/Makefile
-index 688d14a..5740330 100644
---- a/compiler/Makefile
-+++ b/compiler/Makefile
-@@ -16,7 +16,7 @@ include ../config/Makefile
-
- OBJS=config.cmo utils.cmo clflags.cmo \
- prefix.cmo lexpr.cmo cvttyp.cmo variables.cmo \
-- array.cmo struct.cmo enum.cmo union.cmo cvtval.cmo \
-+ array_camlidl.cmo struct.cmo enum.cmo union.cmo cvtval.cmo \
- structdecl.cmo enumdecl.cmo uniondecl.cmo \
- typedef.cmo funct.cmo constdecl.cmo intf.cmo \
- file.cmo predef.cmo \
-diff --git a/compiler/array.ml b/compiler/array_camlidl.ml
-similarity index 100%
-rename from compiler/array.ml
-rename to compiler/array_camlidl.ml
-diff --git a/compiler/array.mli b/compiler/array_camlidl.mli
-similarity index 100%
-rename from compiler/array.mli
-rename to compiler/array_camlidl.mli
-diff --git a/compiler/cvtval.ml b/compiler/cvtval.ml
-index c71e622..3a9c921 100644
---- a/compiler/cvtval.ml
-+++ b/compiler/cvtval.ml
-@@ -135,17 +135,17 @@ let rec ml_to_c oc onstack pref ty v c =
- | Type_pointer(Ignore, ty_elt) ->
- iprintf oc "%s = NULL;\n" c
- | Type_array({maybe_null=false} as attr, ty_elt) ->
-- Array.array_ml_to_c ml_to_c oc onstack pref attr ty_elt v c
-+ Array_camlidl.array_ml_to_c ml_to_c oc onstack pref attr ty_elt v c
- | Type_array({maybe_null=true} as attr, ty_elt) ->
- option_ml_to_c oc v c
- (fun v' ->
-- Array.array_ml_to_c ml_to_c oc onstack pref attr ty_elt v' c)
-+ Array_camlidl.array_ml_to_c ml_to_c oc onstack pref attr ty_elt v' c)
- | Type_bigarray({bigarray_maybe_null=false} as attr, ty_elt) ->
-- Array.bigarray_ml_to_c oc pref attr ty_elt v c
-+ Array_camlidl.bigarray_ml_to_c oc pref attr ty_elt v c
- | Type_bigarray({bigarray_maybe_null=true} as attr, ty_elt) ->
- option_ml_to_c oc v c
- (fun v' ->
-- Array.bigarray_ml_to_c oc pref attr ty_elt v' c)
-+ Array_camlidl.bigarray_ml_to_c oc pref attr ty_elt v' c)
- | Type_interface(modl, name) ->
- error (sprintf "Reference to interface %s that is not a pointer" name)
- | Type_const ty' ->
-@@ -212,15 +212,15 @@ let rec c_to_ml oc pref ty c v =
- | Type_pointer(Ignore, ty_elt) ->
- ()
- | Type_array({maybe_null=false} as attr, ty_elt) ->
-- Array.array_c_to_ml c_to_ml oc pref attr ty_elt c v
-+ Array_camlidl.array_c_to_ml c_to_ml oc pref attr ty_elt c v
- | Type_array({maybe_null=true} as attr, ty_elt) ->
- option_c_to_ml oc c v
-- (Array.array_c_to_ml c_to_ml oc pref attr ty_elt c)
-+ (Array_camlidl.array_c_to_ml c_to_ml oc pref attr ty_elt c)
- | Type_bigarray({bigarray_maybe_null=false} as attr, ty_elt) ->
-- Array.bigarray_c_to_ml oc pref attr ty_elt c v
-+ Array_camlidl.bigarray_c_to_ml oc pref attr ty_elt c v
- | Type_bigarray({bigarray_maybe_null=true} as attr, ty_elt) ->
- option_c_to_ml oc c v
-- (Array.bigarray_c_to_ml oc pref attr ty_elt c)
-+ (Array_camlidl.bigarray_c_to_ml oc pref attr ty_elt c)
- | Type_interface(modl, name) ->
- error (sprintf "Reference to interface %s that is not a pointer" name)
- | Type_const ty' ->
-@@ -234,9 +234,9 @@ let rec allocate_output_space oc pref c ty =
- let c' = new_c_variable ty_arg in
- iprintf oc "%s = &%s;\n" c c'
- | Type_array(attr, ty_arg) ->
-- Array.array_allocate_output_space oc pref attr ty_arg c
-+ Array_camlidl.array_allocate_output_space oc pref attr ty_arg c
- | Type_bigarray(attr, ty_arg) ->
-- Array.bigarray_allocate_output_space oc pref attr ty_arg c
-+ Array_camlidl.bigarray_allocate_output_space oc pref attr ty_arg c
- | Type_const ty' -> (* does this make sense? *)
- allocate_output_space oc pref c ty'
- | _ -> ()
---
-2.10.1
-