summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2020-05-21 13:44:30 -0400
committerChris Severance2020-05-21 13:44:30 -0400
commit14aa017515cea3f1e1804e7a0e7dd355929e182c (patch)
tree716e6fb3afae8718b574c941472ec8b31ac8d7d4
parent52889ab4f4ff11967a3584c32634ed7be00271c6 (diff)
downloadaur-14aa017515cea3f1e1804e7a0e7dd355929e182c.tar.gz
autu: Update to 7.38-2
-rw-r--r--.SRCINFO8
-rw-r--r--0002-kernel-5.6-proc_dir_entry-proc_ops.patch160
-rw-r--r--PKGBUILD14
3 files changed, 179 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19146b6259e3..b06e76fa8292 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nslink
pkgdesc = tty driver and firmware update for Comtrol DeviceMaster, RTS, LT, PRO, 500, UP, RPSH-SI, RPSH, and Serial port Hub console terminal device server
pkgver = 7.38
- pkgrel = 1
+ pkgrel = 2
url = http://www.comtrol.com/
install = nslink-install.sh
arch = i686
@@ -25,9 +25,15 @@ pkgbase = nslink
source = http://downloads.comtrol.com/beta/dev_mstr/rts/drivers/linux/devicemaster-linux-7.38.tar.gz
source = http://downloads.comtrol.com/dev_mstr/rts/utility/linux_firmware_uploader/DM-Firmware-Updater-1.06.tar.gz
source = dmupdate.py.usage.patch
+ source = 0002-kernel-5.6-proc_dir_entry-proc_ops.patch
+ md5sums = 4aa312f2cc13268d96b0faac3350d77b
+ md5sums = e3ffb36acfdd321c919e44d477f0774a
+ md5sums = 581cd5f582ed20c7cf85a4df23a9f78a
+ md5sums = 36fcfa504772df4aabbde9f23d5459d5
sha256sums = 20297434127cc323e5511e1003e950931140277d45339e1c6b71321fab6665fa
sha256sums = d21c5eeefdbf08a202a230454f0bf702221686ba3e663eb41852719bb20b75fb
sha256sums = 5a4e2713a8d1fe0eebd94fc843839ce5daa647f9fa7d88f62507e660ae111073
+ sha256sums = cbaa55f16357688b992a7d7c0f2fb56225edda286d97595918c50e05005d1318
pkgname = nslink
diff --git a/0002-kernel-5.6-proc_dir_entry-proc_ops.patch b/0002-kernel-5.6-proc_dir_entry-proc_ops.patch
new file mode 100644
index 000000000000..0ac56c97f979
--- /dev/null
+++ b/0002-kernel-5.6-proc_dir_entry-proc_ops.patch
@@ -0,0 +1,160 @@
+--- nslink.c.orig 2020-05-21 00:58:54.304970216 -0400
++++ nslink.c 2020-05-21 01:04:05.147271869 -0400
+@@ -5031,17 +5031,26 @@ static int queue_proc_show(struct seq_fi
+ }
+ static int queue_proc_open(struct inode *inode, struct file *file)
+ {
+ return single_open(file, queue_proc_show, NULL);
+ }
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,6,0)
++static const struct proc_ops queue_proc_fops = {
++ .proc_open = queue_proc_open,
++ .proc_read = seq_read,
++ .proc_lseek = seq_lseek,
++ .proc_release = seq_release,
++};
++#else
+ static const struct file_operations queue_proc_fops = {
+ .open = queue_proc_open,
+ .read = seq_read,
+ .llseek = seq_lseek,
+ .release = seq_release,
+ };
+ #endif
++#endif
+
+
+ #if NSLINK_DEBUG_TRACE_HDLC
+
+ static char *stopString[] = {
+@@ -5089,17 +5098,26 @@ static int ack_proc_show(struct seq_file
+ }
+ static int ack_proc_open(struct inode *inode, struct file *file)
+ {
+ return single_open(file, ack_proc_show, NULL);
+ }
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,6,0)
++static const struct proc_ops ack_proc_fops = {
++ .proc_open = ack_proc_open,
++ .proc_read = seq_read,
++ .proc_lseek = seq_lseek,
++ .proc_release = seq_release,
++};
++#else
+ static const struct file_operations ack_proc_fops = {
+ .open = ack_proc_open,
+ .read = seq_read,
+ .llseek = seq_lseek,
+ .release = seq_release,
+ };
+ #endif
++#endif
+
+ #define NumElements(a) (sizeof (a)/(sizeof (a)[0]))
+
+ // Implements the /proc/driver/nslink/port method.
+ static int port_proc_show(struct seq_file *m, void *v)
+@@ -5162,16 +5180,25 @@ static int port_proc_show(struct seq_fil
+ }
+ static int port_proc_open(struct inode *inode, struct file *file)
+ {
+ return single_open(file, port_proc_show, NULL);
+ }
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,6,0)
++static const struct proc_ops port_proc_fops = {
++ .proc_open = port_proc_open,
++ .proc_read = seq_read,
++ .proc_lseek = seq_lseek,
++ .proc_release = seq_release,
++};
++#else
+ static const struct file_operations port_proc_fops = {
+ .open = port_proc_open,
+ .read = seq_read,
+ .llseek = seq_lseek,
+ .release = seq_release,
+ };
++#endif
+
+
+ // Implements the /proc/driver/nslink/hdlc method.
+ static int hdlc_proc_show(struct seq_file *m, void *v)
+ {
+@@ -5203,16 +5230,25 @@ static int hdlc_proc_show(struct seq_fil
+ }
+ static int hdlc_proc_open(struct inode *inode, struct file *file)
+ {
+ return single_open(file, hdlc_proc_show, NULL);
+ }
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,6,0)
++static const struct proc_ops hdlc_proc_fops = {
++ .proc_open = hdlc_proc_open,
++ .proc_read = seq_read,
++ .proc_lseek = seq_lseek,
++ .proc_release = seq_release,
++};
++#else
+ static const struct file_operations hdlc_proc_fops = {
+ .open = hdlc_proc_open,
+ .read = seq_read,
+ .llseek = seq_lseek,
+ .release = seq_release,
+ };
++#endif
+
+
+ // Implements the /proc/driver/nslink/hdlc-queue method.
+ static int hdlc_queue_proc_show(struct seq_file *m, void *v)
+ {
+@@ -5258,16 +5294,25 @@ static int hdlc_queue_proc_show(struct s
+ }
+ static int hdlc_queue_proc_open(struct inode *inode, struct file *file)
+ {
+ return single_open(file, hdlc_queue_proc_show, NULL);
+ }
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,6,0)
++static const struct proc_ops hdlc_queue_proc_fops = {
++ .proc_open = hdlc_queue_proc_open,
++ .proc_read = seq_read,
++ .proc_lseek = seq_lseek,
++ .proc_release = seq_release,
++};
++#else
+ static const struct file_operations hdlc_queue_proc_fops = {
+ .open = hdlc_queue_proc_open,
+ .read = seq_read,
+ .llseek = seq_lseek,
+ .release = seq_release,
+ };
++#endif
+
+
+ const char *inet_addr_string(struct sockaddr_storage *ss)
+ {
+ static char buf[256];
+@@ -5324,16 +5369,25 @@ static int status_proc_show(struct seq_f
+ }
+ static int status_proc_open(struct inode *inode, struct file *file)
+ {
+ return single_open(file, status_proc_show, NULL);
+ }
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,6,0)
++static const struct proc_ops status_proc_fops = {
++ .proc_open = status_proc_open,
++ .proc_read = seq_read,
++ .proc_lseek = seq_lseek,
++ .proc_release = seq_release,
++};
++#else
+ static const struct file_operations status_proc_fops = {
+ .open = status_proc_open,
+ .read = seq_read,
+ .llseek = seq_lseek,
+ .release = seq_release,
+ };
++#endif
+
+ /********************************************************************************/
+ /* */
+ /* MODULE INIT/CLEANUP FUNCTIONS */
+ /* */
diff --git a/PKGBUILD b/PKGBUILD
index c7a45086d21d..b194a8ee088a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,7 +25,7 @@ _opt_defaultmode='660' # default: 620
set -u
pkgname='nslink'
pkgver='7.38'
-pkgrel='1'
+pkgrel='2'
pkgdesc='tty driver and firmware update for Comtrol DeviceMaster, RTS, LT, PRO, 500, UP, RPSH-SI, RPSH, and Serial port Hub console terminal device server'
# UP is not explicitly supported by NS-Link, only by the firmware updater.
_pkgdescshort="Comtrol DeviceMaster ${pkgname} TTY driver"
@@ -49,10 +49,16 @@ source=(
#'ftp://ftp.comtrol.com/dev_mstr/rts/utility/linux_firmware_uploader/DM-Firmware-Updater-1.06.tar.gz'
'http://downloads.comtrol.com/dev_mstr/rts/utility/linux_firmware_uploader/DM-Firmware-Updater-1.06.tar.gz'
'dmupdate.py.usage.patch'
+ '0002-kernel-5.6-proc_dir_entry-proc_ops.patch'
)
+md5sums=('4aa312f2cc13268d96b0faac3350d77b'
+ 'e3ffb36acfdd321c919e44d477f0774a'
+ '581cd5f582ed20c7cf85a4df23a9f78a'
+ '36fcfa504772df4aabbde9f23d5459d5')
sha256sums=('20297434127cc323e5511e1003e950931140277d45339e1c6b71321fab6665fa'
'd21c5eeefdbf08a202a230454f0bf702221686ba3e663eb41852719bb20b75fb'
- '5a4e2713a8d1fe0eebd94fc843839ce5daa647f9fa7d88f62507e660ae111073')
+ '5a4e2713a8d1fe0eebd94fc843839ce5daa647f9fa7d88f62507e660ae111073'
+ 'cbaa55f16357688b992a7d7c0f2fb56225edda286d97595918c50e05005d1318')
if [ "${_opt_DKMS}" -ne 0 ]; then
depends+=('linux' 'dkms' 'linux-headers')
@@ -78,6 +84,10 @@ prepare() {
fi
unset _ver
+ #cp nslink.c{,.orig}; false
+ #diff -pNau5 nslink.c{.orig,} > '0002-kernel-5.6-proc_dir_entry-proc_ops.patch'
+ patch -Nbup0 -i "${srcdir}/0002-kernel-5.6-proc_dir_entry-proc_ops.patch"
+
# Make package compatible
#cp -p 'install.sh' 'install.sh.Arch' # testmode for diff comparison
sed -e '# Fix some paths' \