summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2024-02-15 14:50:08 -0800
committerDonald Webster2024-02-15 14:50:08 -0800
commit151e5fa5508dc6d768b729732850f7ba075710dd (patch)
tree170d57845cb12e381224b66afdfbb1cd2232c768
parent6caa7ad1dee8f7148222fca12d3db3e00712ff9a (diff)
downloadaur-151e5fa5508dc6d768b729732850f7ba075710dd.tar.gz
Fix the patch.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--xdg.patch6
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45bcf250ac5f..913cf68551fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,6 +15,6 @@ pkgbase = tmuxinator
source = tmuxinator-3.1.1.tar.gz::https://github.com/aziz/tmuxinator/archive/v3.1.1.tar.gz
source = xdg.patch
sha256sums = e9be8001042c735d49ec94398a69e65308d9d0ca6bacc0e9fd947c37d53e250c
- sha256sums = 4a120cc210af73190561d2788f2d47c19b11d6f0f129f18fb2614748d5bd9470
+ sha256sums = 75d32aa7e9e7061a21ecb72bd4d3a76ea8610ec391a6dad1797d511cc8544ffb
pkgname = tmuxinator
diff --git a/PKGBUILD b/PKGBUILD
index fc3da75d2558..f2ffd81d205f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ source=(
"xdg.patch"
)
sha256sums=('e9be8001042c735d49ec94398a69e65308d9d0ca6bacc0e9fd947c37d53e250c'
- '4a120cc210af73190561d2788f2d47c19b11d6f0f129f18fb2614748d5bd9470')
+ '75d32aa7e9e7061a21ecb72bd4d3a76ea8610ec391a6dad1797d511cc8544ffb')
prepare() {
cd ${pkgname}-${pkgver}
diff --git a/xdg.patch b/xdg.patch
index c2bf27299540..274f39a4d3ab 100644
--- a/xdg.patch
+++ b/xdg.patch
@@ -1,5 +1,5 @@
diff --git a/lib/tmuxinator/config.rb b/lib/tmuxinator/config.rb
-index 9b64b75..d89e835 100644
+index d14eb9a..d4eccaa 100644
--- a/lib/tmuxinator/config.rb
+++ b/lib/tmuxinator/config.rb
@@ -29,7 +29,7 @@ module Tmuxinator
@@ -12,13 +12,13 @@ index 9b64b75..d89e835 100644
def xdg?
diff --git a/spec/lib/tmuxinator/config_spec.rb b/spec/lib/tmuxinator/config_spec.rb
-index 877cac4..9be2aa3 100644
+index 09ab25f..9d6d7e2 100644
--- a/spec/lib/tmuxinator/config_spec.rb
+++ b/spec/lib/tmuxinator/config_spec.rb
@@ -53,7 +53,8 @@ describe Tmuxinator::Config do
Dir.mktmpdir do |dir|
- config_parent = "#{dir}/non_existant_parent/s"
+ config_parent = "#{dir}/non_existent_parent/s"
- allow(XDG).to receive(:[]).with("CONFIG").and_return config_parent
+ allow(XDG::Config).to receive_message_chain(:new, :home, :to_s).
+ and_return config_parent