summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Kluger2024-04-23 06:00:00 +0000
committerAndy Kluger2024-04-23 06:00:00 +0000
commit15e35b35dded059825321d8d9906dd533a463306 (patch)
tree8ad3d83ffdc46ac6e1d9fffe53d3050de81e39a9
parent5390d23439c97c6ca8bb154a823bad6623641265 (diff)
downloadaur-15e35b35dded059825321d8d9906dd533a463306.tar.gz
Merge upstream changes and patch
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD7
-rw-r--r--a07f2422.patch37
3 files changed, 50 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4c58efb69e9..c2f8ae54a69e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dolphin-meld
pkgdesc = KDE File Manager, using Meld rather than Kompare
- pkgver = 24.02.1
+ pkgver = 24.02.2
pkgrel = 1
url = https://apps.kde.org/dolphin/
arch = x86_64
@@ -48,16 +48,18 @@ pkgbase = dolphin-meld
optdepends = konsole: terminal panel
optdepends = kio-admin: for managing files as administrator
optdepends = purpose: share context menu
- provides = dolphin=24.02.1
- conflicts = dolphin=24.02.1
- source = https://download.kde.org/stable/release-service/24.02.1/src/dolphin-24.02.1.tar.xz
- source = https://download.kde.org/stable/release-service/24.02.1/src/dolphin-24.02.1.tar.xz.sig
+ provides = dolphin=24.02.2
+ conflicts = dolphin=24.02.2
+ source = https://download.kde.org/stable/release-service/24.02.2/src/dolphin-24.02.2.tar.xz
+ source = https://download.kde.org/stable/release-service/24.02.2/src/dolphin-24.02.2.tar.xz.sig
+ source = https://invent.kde.org/system/dolphin/-/commit/a07f2422.patch
source = dolphin-meld.patch
validpgpkeys = CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7
validpgpkeys = F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87
validpgpkeys = D81C0CB38EB725EF6691C385BB463350D6EF31EF
- sha256sums = 597bb12c53984bae7310cda5e06dbed831fdae1a6e731f55bbc660b4a583da0e
+ sha256sums = 50844490d45159ca16c1d8d9f5f0701f118772e4b09adad270835b67bb26a701
sha256sums = SKIP
+ sha256sums = 9a0d799832323ca78be78189fcd569b6911f0d024dda6b9429312ebcea4bc22e
sha256sums = a69abda1bd78cbaf3eb92ed645637fce1ea04a3528c90e22ab2abbdd809a0b15
pkgname = dolphin-meld
diff --git a/PKGBUILD b/PKGBUILD
index 976302d03020..cb940f04ac80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=dolphin-meld
_pkgname=dolphin
-pkgver=24.02.1
+pkgver=24.02.2
pkgrel=1
pkgdesc='KDE File Manager, using Meld rather than Kompare'
arch=(x86_64)
@@ -59,15 +59,18 @@ optdepends=('ffmpegthumbs: video thumbnails'
groups=(kde-applications
kde-system)
source=(https://download.kde.org/stable/release-service/$pkgver/src/$_pkgname-$pkgver.tar.xz{,.sig}
+ https://invent.kde.org/system/dolphin/-/commit/a07f2422.patch
dolphin-meld.patch)
-sha256sums=('597bb12c53984bae7310cda5e06dbed831fdae1a6e731f55bbc660b4a583da0e'
+sha256sums=('50844490d45159ca16c1d8d9f5f0701f118772e4b09adad270835b67bb26a701'
'SKIP'
+ '9a0d799832323ca78be78189fcd569b6911f0d024dda6b9429312ebcea4bc22e'
'a69abda1bd78cbaf3eb92ed645637fce1ea04a3528c90e22ab2abbdd809a0b15')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87 # Christoph Feck <cfeck@kde.org>
D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
prepare() {
+ patch -d $_pkgname-$pkgver -p1 < a07f2422.patch # Fix crash when entering selection mode
patch -d $_pkgname-$pkgver -p1 < $pkgname.patch
}
diff --git a/a07f2422.patch b/a07f2422.patch
new file mode 100644
index 000000000000..ff8171c82e43
--- /dev/null
+++ b/a07f2422.patch
@@ -0,0 +1,37 @@
+From a07f24228a94aab2bdeb3caaf7a4d694c0180ed7 Mon Sep 17 00:00:00 2001
+From: Felix Ernst <felixernst@kde.org>
+Date: Wed, 17 Apr 2024 07:32:27 +0000
+Subject: [PATCH] Fix crash while entering selection mode with Qt6.7
+
+`deleteLater()` on a non-existing object seems to cause a crash with
+Qt6.7. This makes some sense but wasn't the case previously.
+
+I didn't test this yet but it is a harmless change so if anyone can confirm we can IMO merge directly.
+
+This was brought up in https://invent.kde.org/system/dolphin/-/merge_requests/764#note_920935, reported in the bug linked below, and the sentry crash reporting page also has a few dozen reports (https://crash-reports.kde.org/organizations/kde/issues/13589/?project=4&query=is%3Aunresolved&referrer=issue-stream&stream_index=1).
+
+Dolphin 24.02 is also affected but we are already past the last bug fix release for it.
+
+BUG: 485599
+---
+ src/selectionmode/bottombarcontentscontainer.cpp | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/src/selectionmode/bottombarcontentscontainer.cpp b/src/selectionmode/bottombarcontentscontainer.cpp
+index d571b0302a..0e3087a9c5 100644
+--- a/src/selectionmode/bottombarcontentscontainer.cpp
++++ b/src/selectionmode/bottombarcontentscontainer.cpp
+@@ -483,7 +483,9 @@ std::vector<QAction *> BottomBarContentsContainer::contextActionsFor(const KFile
+ if (selectedItems.isEmpty()) {
+ // There are no contextual actions to show for these items.
+ // We might even want to hide this bar in this case. To make this clear, we reset m_internalContextMenu.
+- m_internalContextMenu.release()->deleteLater();
++ if (m_internalContextMenu) {
++ m_internalContextMenu.release()->deleteLater();
++ }
+ return std::vector<QAction *>{};
+ }
+
+--
+GitLab
+