summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2022-11-05 01:06:35 +0100
committerAngelo Theodorou2022-11-05 01:06:35 +0100
commit1670824a6159d2f06ee85b7e7fb976bdd6c41a64 (patch)
treec1406793ab2485807a2dbce3ecb1ca51115a93b0
parentb3206dabc07c393d3523fb9c8e406e405e2575c8 (diff)
downloadaur-1670824a6159d2f06ee85b7e7fb976bdd6c41a64.tar.gz
Update to v0.9
- Build and install csvexport, import-chrome, and libtracy - Install public include headers
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 21 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ff50440efe3..baefe3f601b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tracy
pkgdesc = Real-time, nanosecond resolution frame profiler
- pkgver = 0.8.2
- pkgrel = 3
+ pkgver = 0.9
+ pkgrel = 1
url = https://github.com/wolfpld/tracy
arch = i686
arch = x86_64
@@ -15,7 +15,7 @@ pkgbase = tracy
optdepends = xdg-desktop-portal: file dialogs
provides = tracy
conflicts = tracy
- source = git+https://github.com/wolfpld/tracy#tag=v0.8.2
+ source = git+https://github.com/wolfpld/tracy#tag=v0.9
sha256sums = SKIP
pkgname = tracy
diff --git a/PKGBUILD b/PKGBUILD
index e4dd9baab48b..4dbd995e2f82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Angelo Theodorou <encelo at gmail dot com>
pkgname=tracy
-pkgver=0.8.2
-pkgrel=3
+pkgver=0.9
+pkgrel=1
pkgdesc="Real-time, nanosecond resolution frame profiler"
arch=('i686' 'x86_64')
url="https://github.com/wolfpld/tracy"
@@ -18,16 +18,30 @@ sha256sums=('SKIP')
build() {
cd tracy
+ make -C capture/build/unix release
+ make -C csvexport/build/unix release
+ make -C import-chrome/build/unix release
+ make -C library/unix release
make -C profiler/build/unix release
make -C update/build/unix release
- make -C capture/build/unix release
}
package() {
cd tracy
+ install -Dm755 capture/build/unix/capture-release $pkgdir/usr/bin/tracy-capture
+ install -Dm755 csvexport/build/unix/csvexport-release $pkgdir/usr/bin/tracy-csvexport
+ install -Dm755 import-chrome/build/unix/import-chrome-release $pkgdir/usr/bin/tracy-import-chrome
+ install -Dm755 library/unix/libtracy-release.so $pkgdir/usr/lib/libtracy.so
install -Dm755 profiler/build/unix/Tracy-release $pkgdir/usr/bin/tracy
install -Dm755 update/build/unix/update-release $pkgdir/usr/bin/tracy-update
- install -Dm755 capture/build/unix/capture-release $pkgdir/usr/bin/tracy-capture
+
+ mkdir -p $pkgdir/usr/include/Tracy/client
+ mkdir -p $pkgdir/usr/include/Tracy/common
+ mkdir -p $pkgdir/usr/include/Tracy/tracy
+
+ cp -p public/client/*.{h,hpp} $pkgdir/usr/include/Tracy/client/
+ cp -p public/common/*.{h,hpp} $pkgdir/usr/include/Tracy/common/
+ cp -p public/tracy/*.{h,hpp} $pkgdir/usr/include/Tracy/tracy/
install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
install -Dm644 extra/desktop/tracy.desktop $pkgdir/usr/share/applications/tracy.desktop