summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Hansen2016-11-19 23:03:07 -0800
committerMichael Hansen2016-11-19 23:03:07 -0800
commit173de6d0fd30b1dcd02edfb78b945e286f2b16b2 (patch)
treef9b65d0f3b2347f59dc7364a5a4bb7041d81f260
parent9d31a47ca6af27b7e61209eb064e90535c04b582 (diff)
downloadaur-173de6d0fd30b1dcd02edfb78b945e286f2b16b2.tar.gz
Update to RC3, and split packages to match clion stable
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD151
-rw-r--r--jetbrains-clion-eap.desktop12
3 files changed, 107 insertions, 95 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49f892bc5dd5..2a5028ed6f2e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,42 @@
# Generated by mksrcinfo v8
-# Tue Nov 15 20:49:59 UTC 2016
+# Sun Nov 20 07:02:40 UTC 2016
pkgbase = clion-eap
pkgdesc = C/C++ IDE. 30-day evaluation.
- pkgver = 163.7743.32
+ pkgver = 163.7743.47
pkgrel = 1
url = http://www.jetbrains.com/clion
- arch = i686
arch = x86_64
license = custom
- optdepends = java-runtime: native JRE
- optdepends = cmake: native build system (Set BUNDLED_CMAKE=0 to remove the bundled one)
- optdepends = gdb: native debugger (Set BUNDLED_GDB=0 to remove the bundled one)
- optdepends = lldb: native debugger (Set BUNDLED_LLDB=0 to remove the bundled one)
+ noextract = CLion-2016.3-RC3.tar.gz
+ options = !strip
+ source = https://download.jetbrains.com/cpp/CLion-2016.3-RC3.tar.gz
+ source = jetbrains-clion-eap.desktop
+ sha256sums = 61b81e6906ffc675253d2565f8e54425a4bbfae7e4650f9f42af2f90abfada9a
+ sha256sums = deb1e9f90e99f2ac00b5c31581fe6148712ecfa25f7290a39ae71443978cd539
+
+pkgname = clion-eap
+ optdepends = clion-eap-jre: JetBrains custom Java Runtime (Recommended)
+ optdepends = clion-eap-cmake: JetBrains packaged CMake tools
+ optdepends = clion-eap-gdb: JetBrains packaged GNU debugger
+ optdepends = clion-eap-lldb: JetBrains packaged LLVM debugger
+ optdepends = java-runtime: JRE - Required if clion-eap-jre is not installed
+ optdepends = cmake: Build system - Required if clion-eap-cmake is not installed
+ optdepends = gdb: native GNU debugger
+ optdepends = lldb: native LLVM debugger
optdepends = gcc: GNU compiler
optdepends = clang: LLVM compiler
optdepends = biicode: C/C++ dependency manager
optdepends = gtest: C++ testing
optdepends = swift: Swift programming language support (Also requires the plugin)
- optdepends = python: Python programming language support
+ optdepends = python: Python 3 programming language support
optdepends = python2: Python 2 programming language support
optdepends = doxygen: Code documentation generation
- noextract = CLion-2016.3-RC2.tar.gz
- options = !strip
- source = https://download.jetbrains.com/cpp/CLion-2016.3-RC2.tar.gz
- sha256sums = 9b9629c0d46bc3f23c5660a3e92d245e24a9982f8a9dc22e0b73cc32545b4de6
-pkgname = clion-eap
+pkgname = clion-eap-jre
+
+pkgname = clion-eap-cmake
+
+pkgname = clion-eap-gdb
+
+pkgname = clion-eap-lldb
diff --git a/PKGBUILD b/PKGBUILD
index 078d14be61cd..ee7b433e0d9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,104 +5,91 @@
# Uncomment if you want to disable compressing the package to save some time.
#PKGEXT=.pkg.tar
-# These can be overridden on the makepkg command line
-# Note that AUR helpers may not support overriding these, so they can also
-# be modified here for convenience
-[[ -z "$USE_SYSTEM_JRE" ]] && USE_SYSTEM_JRE=0
-[[ -z "$BUNDLED_CMAKE" ]] && BUNDLED_CMAKE=1
-[[ -z "$BUNDLED_GDB" ]] && BUNDLED_GDB=1
-[[ -z "$BUNDLED_LLDB" ]] && BUNDLED_LLDB=1
-
-pkgname=clion-eap
+pkgbase=clion-eap
+pkgname=(clion-eap clion-eap-jre clion-eap-cmake clion-eap-gdb clion-eap-lldb)
_pkgname=clion
_dlname=CLion
-pkgver=163.7743.32
-_dlver=2016.3-RC2
+pkgver=163.7743.47
+_dlver=2016.3-RC3
pkgrel=1
pkgdesc="C/C++ IDE. 30-day evaluation."
-arch=('i686' 'x86_64')
+arch=('x86_64')
options=(!strip)
url="http://www.jetbrains.com/${_pkgname}"
license=('custom')
-source=("https://download.jetbrains.com/cpp/${_dlname}-${_dlver}.tar.gz")
-sha256sums=('9b9629c0d46bc3f23c5660a3e92d245e24a9982f8a9dc22e0b73cc32545b4de6')
+source=("https://download.jetbrains.com/cpp/${_dlname}-${_dlver}.tar.gz"
+ "jetbrains-${pkgbase}.desktop")
+sha256sums=('61b81e6906ffc675253d2565f8e54425a4bbfae7e4650f9f42af2f90abfada9a'
+ 'deb1e9f90e99f2ac00b5c31581fe6148712ecfa25f7290a39ae71443978cd539')
noextract=("${_dlname}-${_dlver}.tar.gz")
-depends=()
-optdepends=()
-if (( USE_SYSTEM_JRE )); then
- depends+=('java-runtime')
-else
- optdepends+=('java-runtime: native JRE')
-fi
+build() {
+ mkdir -p "${srcdir}/opt/${pkgbase}"
+ bsdtar --strip-components 1 -xf "${_dlname}-${_dlver}.tar.gz" \
+ -C "${srcdir}/opt/${pkgbase}"
-if (( ! BUNDLED_CMAKE )); then
- depends+=('cmake')
-else
- optdepends+=('cmake: native build system (Set BUNDLED_CMAKE=0 to remove the bundled one)')
-fi
+ rm -f "${srcdir}/opt/${pkgbase}/bin/libyjpagent-linux.so"
+ rm -f "${srcdir}/opt/${pkgbase}/bin/fsnotifier"
+}
-optdepends+=(
- 'gdb: native debugger (Set BUNDLED_GDB=0 to remove the bundled one)'
- 'lldb: native debugger (Set BUNDLED_LLDB=0 to remove the bundled one)'
- 'gcc: GNU compiler'
- 'clang: LLVM compiler'
- 'biicode: C/C++ dependency manager'
- 'gtest: C++ testing'
- 'swift: Swift programming language support (Also requires the plugin)'
- 'python: Python programming language support'
- 'python2: Python 2 programming language support'
- 'doxygen: Code documentation generation'
-)
+package_clion-eap() {
+ optdepends=(
+ 'clion-eap-jre: JetBrains custom Java Runtime (Recommended)'
+ 'clion-eap-cmake: JetBrains packaged CMake tools'
+ 'clion-eap-gdb: JetBrains packaged GNU debugger'
+ 'clion-eap-lldb: JetBrains packaged LLVM debugger'
+ 'java-runtime: JRE - Required if clion-eap-jre is not installed'
+ 'cmake: Build system - Required if clion-eap-cmake is not installed'
+ 'gdb: native GNU debugger'
+ 'lldb: native LLVM debugger'
+ 'gcc: GNU compiler'
+ 'clang: LLVM compiler'
+ 'biicode: C/C++ dependency manager'
+ 'gtest: C++ testing'
+ 'swift: Swift programming language support (Also requires the plugin)'
+ 'python: Python 3 programming language support'
+ 'python2: Python 2 programming language support'
+ 'doxygen: Code documentation generation'
+ )
-package() {
- mkdir -p "${pkgdir}/opt/${pkgname}"
- bsdtar --strip-components 1 -xf "${_dlname}-${_dlver}.tar.gz" \
- -C "${pkgdir}/opt/${pkgname}"
+ rsync -rtl "${srcdir}/opt" "${pkgdir}" \
+ --exclude=/opt/${pkgbase}/jre \
+ --exclude=/opt/${pkgbase}/bin/cmake \
+ --exclude=/opt/${pkgbase}/bin/gdb \
+ --exclude=/opt/${pkgbase}/bin/lldb
- (( USE_SYSTEM_JRE )) && rm -r "${pkgdir}/opt/${pkgname}/jre"
- (( ! BUNDLED_CMAKE )) && rm -r "${pkgdir}/opt/${pkgname}/bin/cmake"
- (( ! BUNDLED_GDB )) && rm -r "${pkgdir}/opt/${pkgname}/bin/gdb"
- (( ! BUNDLED_LLDB )) && rm -r "${pkgdir}/opt/${pkgname}/bin/lldb"
+ mkdir -p "${pkgdir}/usr/bin/"
+ mkdir -p "${pkgdir}/usr/share/applications/"
+ mkdir -p "${pkgdir}/usr/share/pixmaps/"
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgbase}"
- if [[ $CARCH = 'i686' ]]; then
- rm -f "${pkgdir}/opt/${pkgname}/bin/libyjpagent-linux64.so"
- rm -f "${pkgdir}/opt/${pkgname}/bin/fsnotifier64"
- fi
- if [[ $CARCH = 'x86_64' ]]; then
- rm -f "${pkgdir}/opt/${pkgname}/bin/libyjpagent-linux.so"
- rm -f "${pkgdir}/opt/${pkgname}/bin/fsnotifier"
- fi
+ install -m 644 "${srcdir}/jetbrains-${pkgbase}.desktop" \
+ "${pkgdir}/usr/share/applications/"
-(
-cat <<EOF
-[Desktop Entry]
-Type=Application
-Version=1.0
-Name=CLion EAP
-GenericName=${_pkgname}
-Comment=${pkgdesc}
-Icon=${pkgname}
-Exec="/usr/bin/${pkgname}" %f
-Terminal=false
-Categories=Development;IDE;
-StartupNotify=true
-StartupWMClass=jetbrains-${_pkgname}
-EOF
-) > ${srcdir}/jetbrains-${pkgname}.desktop
+ ln -s "/opt/${pkgbase}/bin/${_pkgname}.svg" \
+ "${pkgdir}/usr/share/pixmaps/${pkgbase}.svg"
+ ln -s "/opt/${pkgbase}/license/CLion_Preview_License.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgbase}"
+ ln -s "/opt/${pkgbase}/bin/${_pkgname}.sh" \
+ "${pkgdir}/usr/bin/${pkgbase}"
+}
- mkdir -p "${pkgdir}/usr/bin/"
- mkdir -p "${pkgdir}/usr/share/applications/"
- mkdir -p "${pkgdir}/usr/share/pixmaps/"
- mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+package_clion-eap-jre() {
+ install -d -m755 "${pkgdir}/opt/${pkgbase}"
+ rsync -rtl "${srcdir}/opt/${pkgbase}/jre" "${pkgdir}/opt/${pkgbase}"
+}
- install -m 644 "${srcdir}/jetbrains-${pkgname}.desktop" \
- "${pkgdir}/usr/share/applications/"
+package_clion-eap-cmake() {
+ install -d -m755 "${pkgdir}/opt/${pkgbase}/bin"
+ rsync -rtl "${srcdir}/opt/${pkgbase}/bin/cmake" "${pkgdir}/opt/${pkgbase}/bin"
+}
+
+package_clion-eap-gdb() {
+ install -d -m755 "${pkgdir}/opt/${pkgbase}/bin"
+ rsync -rtl "${srcdir}/opt/${pkgbase}/bin/gdb" "${pkgdir}/opt/${pkgbase}/bin"
+}
- ln -s "/opt/${pkgname}/bin/${_pkgname}.svg" \
- "${pkgdir}/usr/share/pixmaps/${pkgname}.svg"
- ln -s "/opt/${pkgname}/license/CLion_Preview_License.txt" \
- "${pkgdir}/usr/share/licenses/${pkgname}"
- ln -s "/opt/${pkgname}/bin/${_pkgname}.sh" \
- "${pkgdir}/usr/bin/${pkgname}"
+package_clion-eap-lldb() {
+ install -d -m755 "${pkgdir}/opt/${pkgbase}/bin"
+ rsync -rtl "${srcdir}/opt/${pkgbase}/bin/lldb" "${pkgdir}/opt/${pkgbase}/bin"
}
diff --git a/jetbrains-clion-eap.desktop b/jetbrains-clion-eap.desktop
new file mode 100644
index 000000000000..ab441fb05923
--- /dev/null
+++ b/jetbrains-clion-eap.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=CLion EAP
+GenericName=clion
+Comment=C/C++ IDE. 30-day evaluation.
+Icon=clion-eap
+Exec="/usr/bin/clion-eap" %f
+Terminal=false
+Categories=Development;IDE;
+StartupNotify=true
+StartupWMClass=jetbrains-clion