summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSilvio Fricke2022-09-21 08:34:20 +0200
committerSilvio Fricke2022-09-21 08:36:54 +0200
commit18318c7514474e9e955b658e76117fefcfc0a732 (patch)
tree7d3b5a64873e5405b6e8bb4de5d95dba01c461a3
parent16c604f22ab7088c64bddea4fddd878b94ee29b2 (diff)
downloadaur-18318c7514474e9e955b658e76117fefcfc0a732.tar.gz
PKGBUILD: add libsoup3 and disable weather plugin
libsoup3 is needed as dependency for evolution. Currently disabled because libgweather needs compiled with libsoup3 support. Thats not on my desk currently. This commit fixes this build problem. -- Checking for module 'gweather4>=3.91' -- Found gweather4, version 4.0.0 CMake Error at CMakeLists.txt:784 (message): Requires libgweather compiled with libsoup 3.0 API, but found version '2.4' instead. If you want to disable weather calendar backend, please use -DENABLE_WEATHER=OFF argument to cmake command. Signed-off-by: Silvio Fricke <silvio.fricke@gmail.com>
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68edd0a015d3..cd9441e81d87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,10 @@ pkgrel=1
pkgdesc="Centralized access to appointments and contacts"
arch=(i686 x86_64)
depends=(libgdata
- libgweather
libical
libphonenumber
libsignon-glib
+ libsoup3
)
makedepends=(git
gnome-common
@@ -50,6 +50,7 @@ build() {
-DENABLE_UOA=OFF \
-DENABLE_VALA_BINDINGS=ON \
-DWITH_PHONENUMBER=ON \
+ -DENABLE_WEATHER=OFF \
ninja
}