summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard Landauer2017-06-01 09:50:19 +0200
committerBernhard Landauer2017-06-01 09:50:19 +0200
commit18c07857db495cc92049930fe952c2dcbd4604bf (patch)
treecab9d20686d832bbd2f7c412db9c19160f919760
parent15fcca4daaee024731b01b981f9d3368aa586fea (diff)
downloadaur-18c07857db495cc92049930fe952c2dcbd4604bf.tar.gz
fix gcc7 build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--include_functional.patch10
3 files changed, 24 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 227d8cf532b0..28e85b5b0ea5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue May 23 00:25:02 UTC 2017
+# Thu Jun 1 07:49:08 UTC 2017
pkgbase = conky-lua
pkgdesc = Lightweight system monitor for X, with Lua support enabled
pkgver = 1.10.6
@@ -16,7 +16,7 @@ pkgbase = conky-lua
makedepends = librsvg
makedepends = libxinerama
makedepends = libxml2
- makedepends = perl-xml-libxml
+ makedepends = man-db
makedepends = perl-xml-libxml
depends = alsa-lib
depends = cairo
@@ -35,7 +35,9 @@ pkgbase = conky-lua
backup = etc/conky/conky.conf
backup = etc/conky/conky_no_x11.conf
source = https://github.com/brndnmtthws/conky/archive/v1.10.6.tar.gz
+ source = include_functional.patch
sha1sums = 54cb3322dc3a969f1fda03383012c61d57261345
+ sha1sums = 5111076229ddfa778d60af15a8a13d3f703567ba
pkgname = conky-lua
diff --git a/PKGBUILD b/PKGBUILD
index 436a2bda0771..df225eed962e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,9 +33,16 @@ depends=('alsa-lib'
provides=("conky=$pkgver")
conflicts=('conky')
backup=('etc/conky/conky.conf' 'etc/conky/conky_no_x11.conf')
-source=("https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz")
-sha1sums=('54cb3322dc3a969f1fda03383012c61d57261345')
-
+source=("https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz"
+ 'include_functional.patch')
+sha1sums=('54cb3322dc3a969f1fda03383012c61d57261345'
+ '5111076229ddfa778d60af15a8a13d3f703567ba')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ patch -p1 -i $srcdir/include_functional.patch
+}
+
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
diff --git a/include_functional.patch b/include_functional.patch
new file mode 100644
index 000000000000..5010b3cb35fd
--- /dev/null
+++ b/include_functional.patch
@@ -0,0 +1,10 @@
+diff -bur conky-1.10.6-orig/src/luamm.hh conky-1.10.6/src/luamm.hh
+--- conky-1.10.6-orig/src/luamm.hh 2016-12-04 17:13:57.000000000 +0200
++++ conky-1.10.6/src/luamm.hh 2017-05-31 20:05:59.000000000 +0300
+@@ -28,6 +28,7 @@
+ #include <exception>
+ #include <stdexcept>
+ #include <string>
++#include <functional>
+
+ #include <lua.hpp>