summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAyush Agarwal2023-02-20 07:12:03 +0530
committerAyush Agarwal2023-02-20 07:12:03 +0530
commit18c090643566c098e56860aaf2a7e6abf9f813ff (patch)
tree683126b614c2dd8f55939d0754e87a10a5418ba4
parent8f7b632dc760d929177148a71add80d60eb0957c (diff)
downloadaur-18c090643566c098e56860aaf2a7e6abf9f813ff.tar.gz
refactor: improve PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 5 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25068ba57e1d..8f7ac00cf544 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = buku
pkgdesc = Bookmark manager like a text-based mini-web
pkgver = 4.8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jarun/buku
arch = any
- license = GPL
+ license = GPL3
makedepends = python-setuptools
depends = ca-certificates
depends = python-beautifulsoup4
@@ -12,10 +12,8 @@ pkgbase = buku
depends = python-html5lib
depends = python-urllib3
optdepends = wl-clipboard: to copy text in wayland
- optdepends = wl-clipboard-rs: to copy text in wayland
optdepends = xsel: to copy text in xorg
optdepends = xclip: to copy text in xorg
- conflicts = buku-git
source = buku-4.8.tar.gz::https://github.com/jarun/buku/archive/refs/tags/v4.8.tar.gz
sha256sums = a0b94210e80e9f9f359e5308323837d41781cf8dba497341099d5c59e27fa52c
diff --git a/PKGBUILD b/PKGBUILD
index 6effcf2de241..035915dd0e2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,11 +6,11 @@
pkgname=buku
pkgver=4.8
-pkgrel=1
+pkgrel=2
pkgdesc="Bookmark manager like a text-based mini-web"
arch=('any')
url="https://github.com/jarun/buku"
-license=('GPL')
+license=('GPL3')
depends=('ca-certificates'
'python-beautifulsoup4'
'python-cryptography'
@@ -18,18 +18,13 @@ depends=('ca-certificates'
'python-urllib3')
makedepends=('python-setuptools')
optdepends=('wl-clipboard: to copy text in wayland'
- 'wl-clipboard-rs: to copy text in wayland'
'xsel: to copy text in xorg'
'xclip: to copy text in xorg')
-conflicts=('buku-git')
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
sha256sums=('a0b94210e80e9f9f359e5308323837d41781cf8dba497341099d5c59e27fa52c')
package() {
- cd "$pkgname-$pkgver" 2> /dev/null || {
- printf "%s\n" "unable to cd to $pkgname-$pkgver"
- exit 1
- }
+ cd "$pkgname-$pkgver"
export PYTHONHASHSEED=0
python setup.py install --root="$pkgdir" --prefix=/usr --optimize=1