summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew McGinn2019-02-23 22:13:49 -0300
committerMatthew McGinn2019-02-23 22:13:49 -0300
commit19a0b78bfc83e89d3e439258b14f55482ac1c5d2 (patch)
tree82717a45c99f303406a2c5540b2f73a4772222f7
parentea1f870b0b1c98b439d630a9de3b1847ed243a1c (diff)
downloadaur-19a0b78bfc83e89d3e439258b14f55482ac1c5d2.tar.gz
Update to python 3.7
Signed-off-by: Matthew McGinn <mamcgi@gmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD11
-rw-r--r--bitbake.install5
4 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1862eadfd1a4..c5cb0096a9e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,13 @@
# Generated by mksrcinfo v8
-# Fri Feb 22 20:35:06 UTC 2019
+# Sun Feb 24 01:13:27 UTC 2019
pkgbase = bitbake
pkgdesc = Build tool executing tasks and managing metadata.
pkgver = 1.40.0
- pkgrel = 2
+ pkgrel = 3
url = https://www.openembedded.org/wiki/Main_Page
arch = any
license = GPL2
makedepends = git
- makedepends = python
- makedepends = python-django18
- makedepends = python-beautifulsoup4
- makedepends = python-codegen
- makedepends = python-pyinotify
- makedepends = python-progressbar
source = https://github.com/openembedded/bitbake/archive/1.40.0.tar.gz
md5sums = 902bb4b71bb85fe55cdcf24bf21a7214
diff --git a/.gitignore b/.gitignore
index 884c73c7ff46..e3a9ab4146fb 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,5 @@ src
bitbake/*
*.tar.xz
*.tar.gz
+__pycache__
+pyshtables.py
diff --git a/PKGBUILD b/PKGBUILD
index e605faca31e7..361b5bd2c743 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,13 @@
pkgbase=bitbake
pkgname=('bitbake' 'bitbake-vim')
pkgver=1.40.0
-pkgrel=2
+pkgrel=3
+_pythonver=3.7
pkgdesc='Build tool executing tasks and managing metadata.'
arch=('any')
url='https://www.openembedded.org/wiki/Main_Page'
license=('GPL2')
-makedepends=('git' 'python' 'python-django18' 'python-beautifulsoup4' 'python-codegen' 'python-pyinotify' 'python-progressbar')
+makedepends=('git')
source=("https://github.com/openembedded/bitbake/archive/${pkgver}.tar.gz")
md5sums=('902bb4b71bb85fe55cdcf24bf21a7214')
@@ -29,9 +30,9 @@ package_bitbake() {
install -d "${pkgdir}/usr/bin"
install bin/bitbake* "${pkgdir}/usr/bin"
- install -d "${pkgdir}/usr/lib/python3.6/site-packages"
- cp -Ra lib/bb "${pkgdir}/usr/lib/python3.6/site-packages"
- cp -Ra lib/prserv "${pkgdir}/usr/lib/python3.6/site-packages"
+ install -d "${pkgdir}/usr/lib/python${_pythonver}/site-packages"
+ cp -Ra lib/bb "${pkgdir}/usr/lib/python${_pythonver}/site-packages"
+ cp -Ra lib/prserv "${pkgdir}/usr/lib/python${_pythonver}/site-packages"
install -d "${pkgdir}/usr/share/man/man1"
install doc/bitbake.1 "${pkgdir}/usr/share/man/man1"
diff --git a/bitbake.install b/bitbake.install
index b46142ee9182..a769dc814aba 100644
--- a/bitbake.install
+++ b/bitbake.install
@@ -1,4 +1,5 @@
post_install() {
- echo "Please add to '/usr/lib/python3.6/site-packages/bb' to PYTHONPATH shell variable in order for bitbake to work."
- echo "example: echo export PYTHONPATH=/usr/lib/python3.6/site-packages/bb >> ~/.bash_profile"
+ _pythonver=3.7
+ echo "Please add to '/usr/lib/python${_pythonver}/site-packages/bb' to PYTHONPATH shell variable in order for bitbake to work."
+ echo "example: echo export PYTHONPATH=/usr/lib/python${_pythonver}/site-packages/bb >> ~/.bash_profile"
}