summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuben Van Boxem2020-09-24 10:25:48 +0200
committerRuben Van Boxem2020-09-24 10:25:48 +0200
commit1a9b34d2b090a695c08ce4682d59cafde93f0d6c (patch)
treed2fd82b4a2710cf9c952447ce6f9f14b55104bdc
parentafb94c9a880cfc78b4621bce75907caa6759a650 (diff)
downloadaur-1a9b34d2b090a695c08ce4682d59cafde93f0d6c.tar.gz
Update to 2.6.5 version.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
-rw-r--r--qt5.15_missing_qpainterpath_include.patch11
3 files changed, 17 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6aca382812c4..997a540355de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = stack-client
pkgdesc = The STACK Client provides file sync to desktop clients.
- pkgver = 2.6.4
- pkgrel = 2
+ pkgver = 2.6.5
+ pkgrel = 1
url = https://www.transip.nl/stack/
arch = x86_64
license = GPL2
@@ -17,14 +17,12 @@ pkgbase = stack-client
optdepends = python-nautilus: integration with Nautilus
optdepends = nemo-python: integration with Nemo
conflicts = stack-client-bin
- source = client-v2.6.4.tar.gz::https://github.com/nextcloud/client/archive/v2.6.4.tar.gz
- source = http://mirror.transip.net/stack/software/source/stack-client-source-2.6.4.20200506.tar.gz
+ source = client-v2.6.5.tar.gz::https://github.com/nextcloud/client/archive/v2.6.5.tar.gz
+ source = http://mirror.transip.net/stack/software/source/stack-client-source-2.6.5.20200909.tar.gz
source = APPLICATION_NAME.patch
- source = qt5.15_missing_qpainterpath_include.patch
- sha256sums = aea4dff6bf2a6bd2b783a6175ac2393ffcae2949536b15def7aae4372f0c24ef
- sha256sums = b6dc38ad1830b3b1b99863c853117bd03198bf0c15ecbe06da30b644c5c8f14d
+ sha256sums = 935385ff07174a4d85c2d4eda4d069aeb4aa8d0e68865b2cf8a24ca8cc883288
+ sha256sums = b3b5e7fe98df6c8cb8e7020115e58007c902604b5928616c8fd2134dcd127e3a
sha256sums = 65a37003112bbc07bb372693793ff5a2dba86199d0da845e7203096ecc33c559
- sha256sums = 449c798e17b9e6bea8ab0021383a9c97422e28bebae1db0166fab3f8971e4fc0
pkgname = stack-client
diff --git a/PKGBUILD b/PKGBUILD
index b89e3ed5806a..6cf5de9ca065 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=stack-client
-pkgver=2.6.4
-pkgrel=2
+pkgver=2.6.5
+pkgrel=1
pkgdesc="The STACK Client provides file sync to desktop clients."
arch=('x86_64')
url='https://www.transip.nl/stack/'
@@ -10,23 +10,18 @@ optdepends=('python-nautilus: integration with Nautilus' 'nemo-python: integrati
makedepends=('cmake' 'qt5-tools' 'extra-cmake-modules' 'frameworkintegration')
conflicts=('stack-client-bin')
source=("client-v${pkgver}.tar.gz::https://github.com/nextcloud/client/archive/v${pkgver}.tar.gz"
- "http://mirror.transip.net/stack/software/source/stack-client-source-${pkgver}.20200506.tar.gz"
- "APPLICATION_NAME.patch"
- "qt5.15_missing_qpainterpath_include.patch")
-sha256sums=('aea4dff6bf2a6bd2b783a6175ac2393ffcae2949536b15def7aae4372f0c24ef'
- 'b6dc38ad1830b3b1b99863c853117bd03198bf0c15ecbe06da30b644c5c8f14d'
- '65a37003112bbc07bb372693793ff5a2dba86199d0da845e7203096ecc33c559'
- '449c798e17b9e6bea8ab0021383a9c97422e28bebae1db0166fab3f8971e4fc0')
+ "http://mirror.transip.net/stack/software/source/stack-client-source-${pkgver}.20200909.tar.gz"
+ "APPLICATION_NAME.patch")
+sha256sums=('935385ff07174a4d85c2d4eda4d069aeb4aa8d0e68865b2cf8a24ca8cc883288'
+ 'b3b5e7fe98df6c8cb8e7020115e58007c902604b5928616c8fd2134dcd127e3a'
+ '65a37003112bbc07bb372693793ff5a2dba86199d0da845e7203096ecc33c559')
prepare() {
patch -p1 < ${srcdir}/APPLICATION_NAME.patch
- patch -p1 < ${srcdir}/qt5.15_missing_qpainterpath_include.patch
- cd desktop-${pkgver}
- for file in ${srcdir}/patches/*
- do
- patch -p1 < ${file}
- done
+ cd ${srcdir}
+ # these seem to be already applied this time...
+ #. patch.sh
}
build() {
@@ -45,8 +40,7 @@ build() {
-DQTKEYCHAIN_LIBRARY=/usr/lib/libqt5keychain.so \
-DQTKEYCHAIN_INCLUDE_DIR=/usr/include/qt5keychain/ \
-DAPPLICATION_EXECUTABLE=stack-client \
- -DMIRALL_VERSION_SUFFIX= \
- -DMIRALL_VERSION_BUILD=20200508
+ -DMIRALL_VERSION_SUFFIX=
make
}
diff --git a/qt5.15_missing_qpainterpath_include.patch b/qt5.15_missing_qpainterpath_include.patch
deleted file mode 100644
index 5846f6241e16..000000000000
--- a/qt5.15_missing_qpainterpath_include.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -upr desktop-2.6.4-orig/src/libsync/networkjobs.cpp desktop-2.6.4/src/libsync/networkjobs.cpp
---- a/desktop-2.6.4/src/libsync/networkjobs.cpp 2020-06-20 21:00:43.636264023 +0200
-+++ b/desktop-2.6.4/src/libsync/networkjobs.cpp 2020-06-20 21:01:01.126316908 +0200
-@@ -31,6 +31,7 @@
- #include <QJsonDocument>
- #include <QJsonObject>
- #include <QPainter>
-+#include <QPainterPath>
-
- #include "networkjobs.h"
- #include "account.h"