summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof AS (3ED)2021-01-10 10:37:36 +0100
committerKrzysztof AS (3ED)2021-01-10 10:37:36 +0100
commit1b57b9764b03a778a67a5e0e0147fe6268456acc (patch)
tree11fea9a385623b4a15f31bbad6976166a5acb2ba
parent2799faf8a8d43e73ff1f72edcf434487be94ca68 (diff)
downloadaur-1b57b9764b03a778a67a5e0e0147fe6268456acc.tar.gz
add missing glic (detected by namcap); add condition for autoconf older than 2.70 (suggested by jbbr)
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb17b3f1e75e..27a4d4481899 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,6 +14,7 @@ pkgbase = ddccontrol
depends = perl-xml-parser
depends = libxml2
depends = icu
+ depends = glibc
options = !libtool
source = ddccontrol-0.5.0.tar.gz::https://github.com/ddccontrol/ddccontrol/archive/0.5.0.tar.gz
sha256sums = 41d7c4fbcd1c2fa33bc6993c44527e98a1af7233903f6b362f41b99f977224df
diff --git a/PKGBUILD b/PKGBUILD
index 1595a06116e3..67c0f2906834 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ pkgdesc="Control your monitor by software using the DDC/CI protocol"
arch=('i686' 'x86_64')
url="https://github.com/ddccontrol/ddccontrol"
license=('GPL')
-depends=('pciutils' 'ddccontrol-db-git' 'perl-xml-parser' 'libxml2' 'icu')
+depends=('pciutils' 'ddccontrol-db-git' 'perl-xml-parser' 'libxml2' 'icu' 'glibc')
makedepends=('gtk2' 'autoconf' 'intltool')
source=("$pkgbase-$pkgver.tar.gz::https://github.com/ddccontrol/ddccontrol/archive/${pkgver}.tar.gz")
options=('!libtool')
@@ -19,7 +19,17 @@ sha256sums=('41d7c4fbcd1c2fa33bc6993c44527e98a1af7233903f6b362f41b99f977224df')
prepare() {
cd "${srcdir}"/${pkgbase}-${pkgver}
- test -f configure || INTLTOOLIZE='intltoolize --force' autoreconf --install
+
+ # fix for autoconf older than 2.70 (suggested by jbbr)
+ local _is_older="$(vercmp "2.70-1" "$(pacman -Q autoconf|cut -d\ -f2)")"
+
+ if [ "$_is_older" = "1" ]; then
+ msg2 "Running autogen (for autoconf<2.70)"
+ ./autogen.sh
+ else
+ msg2 "Running autogen (for autoconf>=2.70)"
+ test -f configure || INTLTOOLIZE='intltoolize --force' autoreconf --install
+ fi
}
build() {