summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Wells2022-02-28 18:44:39 -0500
committerDavid Wells2022-02-28 18:44:39 -0500
commit1b716491813ca0e0c0b86aef7bb52f5c33f6177b (patch)
tree03022a8625c36fc9afb7f4c07e7cd62be0ed95b2
parent658826e6dea6bdd60e7319e3dd235e5d6ab7f801 (diff)
downloadaur-1b716491813ca0e0c0b86aef7bb52f5c33f6177b.tar.gz
Fix a quick test that wasn't ported to oneAPI
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6819faf8a888..b60eb4c2f2a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = deal-ii
pkgdesc = An Open Source Finite Element Differential Equations Analysis Library
pkgver = 9.3.3
- pkgrel = 1
+ pkgrel = 2
url = http://www.dealii.org/
install = deal-ii.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 018337e538c7..b83b0f937c92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=deal-ii
_realname=dealii
pkgver=9.3.3
-pkgrel=1
+pkgrel=2
pkgdesc="An Open Source Finite Element Differential Equations Analysis Library"
arch=("i686" "x86_64")
url="http://www.dealii.org/"
@@ -112,6 +112,13 @@ build() {
sed -i '122ifedisableexcept(FE_INVALID);\n' \
${srcdir}/${_realname}-$pkgver/tests/quick_tests/scalapack.cc
+ # Fix a test to work with TBB's oneAPI:
+ sed -i '/include .tbb.task_scheduler.init.h./d' \
+ ${srcdir}/${_realname}-$pkgver/tests/quick_tests/tbb.cc
+
+ sed -i 's/tbb::task_scheduler_init::default_num_threads/MultithreadInfo::n_threads/' \
+ ${srcdir}/${_realname}-$pkgver/tests/quick_tests/tbb.cc
+
# Also remove from LDFLAGS if necessary
LDFLAGS=$(echo $LDFLAGS | sed 's/--as-needed,//')