summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblubbblubb2023-03-16 16:42:58 +0100
committerblubbblubb2023-03-16 16:42:58 +0100
commit1c03e5c5e9b8ae1bb7d5b5b69c86f2024391ebea (patch)
treead18d7d159229f732bcc2da2b3dd30aae6f9609a
parent1fec453d067b919954bbddce30813ded546075c4 (diff)
downloadaur-1c03e5c5e9b8ae1bb7d5b5b69c86f2024391ebea.tar.gz
add patch for mp4/asf
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--fix_mp4-asf.patch21
3 files changed, 30 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5259c7add364..af791168921e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = loudgain
pkgdesc = A loudness normalizer that scans music files and calculates loudness-normalized gain and loudness peak values according to the EBU R128 standard, and can optionally write ReplayGain-compatible metadata.
pkgver = v0.6.8
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/Moonbase59/loudgain
arch = i686
arch = x86_64
@@ -14,7 +14,9 @@ pkgbase = loudgain
provides = rgbpm
source = loudgain-0.6.8.tar.gz::https://github.com/Moonbase59/loudgain/archive/v0.6.8.tar.gz
source = fix_ffmpeg5.patch
+ source = fix_mp4-asf.patch
sha256sums = 1137c193ad941b366e87c5d84ccc95a7aa8571affc060db0bd1cf72c489aeaee
sha256sums = 73c1cc5d416e2b5b73a4deac1ef2b563d289976c296c24b39c1e8d740333d2ff
+ sha256sums = 5c23a8cbee1e919f7dfe36c16652d8dfdd7e44dae0aa5dfd453fad4ba8c2a0b9
pkgname = loudgain
diff --git a/PKGBUILD b/PKGBUILD
index cd925e778e93..20b613e54481 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=loudgain
pkgver=v0.6.8
_pkgver=0.6.8
-pkgrel=3
+pkgrel=4
pkgdesc="A loudness normalizer that scans music files and calculates loudness-normalized gain and loudness peak values according to the EBU R128 standard, and can optionally write ReplayGain-compatible metadata."
url="https://github.com/Moonbase59/loudgain"
arch=('i686' 'x86_64')
@@ -12,13 +12,16 @@ depends=("taglib" "libebur128" "ffmpeg")
makedepends=('cmake')
provides=('loudgain' 'rgbpm')
source=("loudgain-${_pkgver}.tar.gz::https://github.com/Moonbase59/loudgain/archive/${pkgver}.tar.gz"
- "fix_ffmpeg5.patch")
+ "fix_ffmpeg5.patch"
+ "fix_mp4-asf.patch")
sha256sums=('1137c193ad941b366e87c5d84ccc95a7aa8571affc060db0bd1cf72c489aeaee'
- '73c1cc5d416e2b5b73a4deac1ef2b563d289976c296c24b39c1e8d740333d2ff')
+ '73c1cc5d416e2b5b73a4deac1ef2b563d289976c296c24b39c1e8d740333d2ff'
+ '5c23a8cbee1e919f7dfe36c16652d8dfdd7e44dae0aa5dfd453fad4ba8c2a0b9')
prepare() {
cd "${srcdir}/${pkgname}-${_pkgver}"
patch --forward --strip=1 --input="${srcdir}/fix_ffmpeg5.patch"
+ patch --forward --strip=1 --input="${srcdir}/fix_mp4-asf.patch"
}
build() {
diff --git a/fix_mp4-asf.patch b/fix_mp4-asf.patch
new file mode 100644
index 000000000000..9fc1a09e9f1c
--- /dev/null
+++ b/fix_mp4-asf.patch
@@ -0,0 +1,21 @@
+diff -ur a/src/tag.cc b/src/tag.cc
+--- a/src/tag.cc 2019-09-06 17:31:19.000000000 +0200
++++ b/src/tag.cc 2023-03-09 22:42:56.363890247 +0100
+@@ -490,7 +490,7 @@
+
+ void tag_remove_mp4(TagLib::MP4::Tag *tag) {
+ TagLib::String desc;
+- TagLib::MP4::ItemListMap &items = tag->itemListMap();
++ TagLib::MP4::ItemListMap items = tag->itemListMap();
+
+ for(TagLib::MP4::ItemListMap::Iterator item = items.begin();
+ item != items.end(); ++item)
+@@ -568,7 +568,7 @@
+
+ void tag_remove_asf(TagLib::ASF::Tag *tag) {
+ TagLib::String desc;
+- TagLib::ASF::AttributeListMap &items = tag->attributeListMap();
++ TagLib::ASF::AttributeListMap items = tag->attributeListMap();
+
+ for(TagLib::ASF::AttributeListMap::Iterator item = items.begin();
+ item != items.end(); ++item)