summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSameer Puri2023-02-24 09:51:20 -0800
committerSameer Puri2023-02-24 09:51:20 -0800
commit1c31a014aec8b9e1680837a3be3d597fa9e79f00 (patch)
tree95b5b024cb03809cc3c761f99b92294923e90f06
parent5186de679567b39d62bb95c5741c0555614033b8 (diff)
downloadaur-1c31a014aec8b9e1680837a3be3d597fa9e79f00.tar.gz
update to v9.5 and fix cplex query
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d0aa95f325e..51063185c590 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-or-tools
pkgdesc = Google's Operations Research tools
- pkgver = 9.4
+ pkgver = 9.5
pkgrel = 1
url = https://github.com/google/or-tools
arch = x86_64
@@ -25,7 +25,7 @@ pkgbase = python-or-tools
optdepends = python-pandas: used by some examples
optdepends = python-matplotlib: used by some examples
options = !emptydirs
- source = https://github.com/google/or-tools/archive/v9.4.tar.gz
- b2sums = 9fe09798071f8ed2aa9634ad566ef00a68fd64892cf7169762108c2dc86a4fd144cfa70d78b69d73f645802318b1a20f2f8fc0ded32638260a122cdc857e6a7f
+ source = https://github.com/google/or-tools/archive/v9.5.tar.gz
+ b2sums = 4052f36286258b6715b75dc577193f3d930febb56df5eeed02bf5f3a69f0d4bf73342b17c70ea44c93f4c955109bc5de31e2533d272bda98ea1f7d63987fe165
pkgname = python-or-tools
diff --git a/PKGBUILD b/PKGBUILD
index 435759c7373e..c6df0c032a3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Sameer Puri <aur@purisa.me>
pkgname=python-or-tools
-pkgver=9.4
+pkgver=9.5
pkgrel=1
pkgdesc="Google's Operations Research tools"
arch=('x86_64' 'i686' 'aarch64' 'armv7h')
@@ -11,11 +11,11 @@ makedepends=('cmake' 'wget' 'lsb-release' 'automake' 'python-wheel' 'python-pip'
optdepends=('cplex: CPLEX solver support' 'python-pandas: used by some examples' 'python-matplotlib: used by some examples')
options=(!emptydirs)
source=("https://github.com/google/or-tools/archive/v${pkgver}.tar.gz")
-b2sums=('9fe09798071f8ed2aa9634ad566ef00a68fd64892cf7169762108c2dc86a4fd144cfa70d78b69d73f645802318b1a20f2f8fc0ded32638260a122cdc857e6a7f')
+b2sums=('4052f36286258b6715b75dc577193f3d930febb56df5eeed02bf5f3a69f0d4bf73342b17c70ea44c93f4c955109bc5de31e2533d272bda98ea1f7d63987fe165')
build() {
cd "${srcdir}/or-tools-${pkgver}"
- if [ `pacman -Qi cpelx &>/dev/null` ]; then
+ if [ `pacman -Qi cplex &>/dev/null` ]; then
cmake -S. -Bbuild -DBUILD_PYTHON:BOOL=ON -DUSE_CPLEX:BOOL=ON -DCPLEX_ROOT=/usr/lib/cplex
else
cmake -S. -Bbuild -DBUILD_PYTHON:BOOL=ON