summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSameer Puri2023-08-18 10:59:06 -0700
committerSameer Puri2023-08-18 10:59:06 -0700
commit1c70b660283cd6aec4f55ceb733b5f1e629549fc (patch)
treec4a4c6bd70b306143c937b4a1a41346dc02ea466
parent6d9b0044b566c400123e81b2f4f648ee21540644 (diff)
downloadaur-1c70b660283cd6aec4f55ceb733b5f1e629549fc.tar.gz
update to 9.7
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9bc2de986034..ee633aac2f82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-or-tools
pkgdesc = Google's Operations Research tools
- pkgver = 9.6
+ pkgver = 9.7
pkgrel = 1
url = https://github.com/google/or-tools
arch = x86_64
@@ -16,6 +16,7 @@ pkgbase = python-or-tools
makedepends = python-pip
makedepends = git
makedepends = python-mypy-protobuf
+ makedepends = python-virtualenv
depends = python>=3.6
depends = swig
depends = python-protobuf>=3.19.4
@@ -25,7 +26,7 @@ pkgbase = python-or-tools
optdepends = python-pandas: used by some examples
optdepends = python-matplotlib: used by some examples
options = !emptydirs
- source = https://github.com/google/or-tools/archive/v9.6.tar.gz
- b2sums = 1c4a523db01d4d2675b4078b4c20557428ca1bd3aaad543026141ebbdb34a12ba9d38a6d2a483c6c384ea302f9760a13cad46c93960572ad12f94e6b2cf860a0
+ source = https://github.com/google/or-tools/archive/v9.7.tar.gz
+ b2sums = ae4fa89665639894ae6feab9cb711fc493bbccecc4aa3f3cca290e28e1e77d043dbb7270567738ea6655c0daf2e8104ad08a96d2ef03959eb16eee71551eb987
pkgname = python-or-tools
diff --git a/PKGBUILD b/PKGBUILD
index 8c5472047b79..69262db3e33b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Sameer Puri <aur@purisa.me>
pkgname=python-or-tools
-pkgver=9.6
+pkgver=9.7
pkgrel=1
pkgdesc="Google's Operations Research tools"
arch=('x86_64' 'i686' 'aarch64' 'armv7h')
url="https://github.com/google/or-tools"
license=('Apache2')
depends=('python>=3.6' 'swig' 'python-protobuf>=3.19.4' 'absl-py' 'python-numpy>=1.13.3')
-makedepends=('cmake' 'wget' 'lsb-release' 'automake' 'python-wheel' 'python-pip' 'git' 'python-mypy-protobuf')
+makedepends=('cmake' 'wget' 'lsb-release' 'automake' 'python-wheel' 'python-pip' 'git' 'python-mypy-protobuf' 'python-virtualenv')
optdepends=('cplex: CPLEX solver support' 'python-pandas: used by some examples' 'python-matplotlib: used by some examples')
options=(!emptydirs)
source=("https://github.com/google/or-tools/archive/v${pkgver}.tar.gz")
-b2sums=('1c4a523db01d4d2675b4078b4c20557428ca1bd3aaad543026141ebbdb34a12ba9d38a6d2a483c6c384ea302f9760a13cad46c93960572ad12f94e6b2cf860a0')
+b2sums=('ae4fa89665639894ae6feab9cb711fc493bbccecc4aa3f3cca290e28e1e77d043dbb7270567738ea6655c0daf2e8104ad08a96d2ef03959eb16eee71551eb987')
build() {
cd "${srcdir}/or-tools-${pkgver}"