summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreg Erwin2018-04-29 12:36:08 -0700
committerGreg Erwin2018-04-29 12:36:08 -0700
commit1d6f119a9010aa24c028386ac7c42e47d7f5e5ea (patch)
treecfb5faf851f93f38521e5a583e32910bcbe061b1
parent4ea54d408e0b4ca0331dbbe4129f7c8d7430bcbb (diff)
downloadaur-1d6f119a9010aa24c028386ac7c42e47d7f5e5ea.tar.gz
Enable support for c++ and python bindings
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e840dc00ad42..c5f2a2ff6944 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libgpiod-git
pkgdesc = C library and tools for interacting with the linux GPIO character device
- pkgver = r530.a029549
- pkgrel = 2
+ pkgver = r602.039b301
+ pkgrel = 1
url = https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git
arch = x86_64
arch = i686
@@ -11,7 +11,9 @@ pkgbase = libgpiod-git
arch = aarch64
license = LGPL2.1
makedepends = git
+ makedepends = autoconf-archive
depends = linux>=4.8
+ depends = python
source = git://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4efcb7bd2007..a6e58f663823 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Greg Erwin <first name last name 256 at gmail dot com>
pkgname=libgpiod-git
-pkgver=r530.a029549
-pkgrel=2
+pkgver=r602.039b301
+pkgrel=1
pkgdesc="C library and tools for interacting with the linux GPIO character device"
url="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
license=('LGPL2.1')
-depends=('linux>=4.8')
-makedepends=('git')
+depends=('linux>=4.8' 'python')
+makedepends=('git' 'autoconf-archive')
source=('git://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git')
sha1sums=('SKIP')
@@ -19,8 +19,11 @@ pkgver() {
build() {
cd "$srcdir/${pkgname%-git}"
- ./autogen.sh
- ./configure --enable-tools=yes --prefix=/usr
+ ./autogen.sh \
+ --enable-tools=yes \
+ --enable-bindings-cxx \
+ --enable-bindings \
+ --prefix=/usr
make
}