summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Shapovalov2023-05-05 18:19:11 +0300
committerIvan Shapovalov2023-05-05 18:19:11 +0300
commit1f080ce6a234fcc99728943c3b728bc49aff3e8b (patch)
treec7c0022b068bdb6f132c0d5b209b39b3cd0367d8
parent36044adc39f3af2d489be8b3092701867c87df62 (diff)
downloadaur-1f080ce6a234fcc99728943c3b728bc49aff3e8b.tar.gz
Resync against extra/libimobiledevice
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD39
2 files changed, 41 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cdfb244518f..9ce911de9f46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,26 @@
pkgbase = libimobiledevice-git
pkgdesc = Library that talks the protocols to support iPhone and iPod Touch devices on Linux
- pkgver = 1.3.0.r71.g3a10a31
+ pkgver = 1.3.0.r179.g860ffb7
pkgrel = 1
epoch = 1
url = http://www.libimobiledevice.org/
- arch = i686
arch = x86_64
license = GPL2
license = LGPL2.1
- makedepends = python
- makedepends = cython
- makedepends = libplist-git
makedepends = autoconf-archive
+ makedepends = cython
makedepends = git
+ makedepends = python
makedepends = python-setuptools
- depends = libusbmuxd
- depends = usbmuxd
- depends = openssl
+ depends = gnutls
+ depends = libgcrypt
+ depends = libplist-git
+ depends = libtasn1
+ depends = libusbmuxd-git
depends = libimobiledevice-glue-git
- provides = libiphone-git
- provides = libiphone
- provides = libimobiledevice
- conflicts = libiphone-git
- conflicts = libiphone
+ optdepends = python: for the Python bindings
+ provides = libimobiledevice-1.0.so
+ provides = libimobiledevice=1.3.0.r179.g860ffb7
conflicts = libimobiledevice
source = git+https://github.com/libimobiledevice/libimobiledevice
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 50f48b64d638..2112ebdbb898 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,17 +6,30 @@
pkgname=libimobiledevice-git
epoch=1
-pkgver=1.3.0.r71.g3a10a31
+pkgver=1.3.0.r179.g860ffb7
pkgrel=1
pkgdesc="Library that talks the protocols to support iPhone and iPod Touch devices on Linux"
url="http://www.libimobiledevice.org/"
-arch=('i686' 'x86_64')
-license=('GPL2' 'LGPL2.1')
-depends=('libusbmuxd' 'usbmuxd' 'openssl' 'libimobiledevice-glue-git')
-makedepends=('python' 'cython' 'libplist-git' 'autoconf-archive'
- 'git' 'python-setuptools')
-provides=('libiphone-git' 'libiphone' 'libimobiledevice')
-conflicts=('libiphone-git' 'libiphone' 'libimobiledevice')
+arch=(x86_64)
+license=(GPL2 LGPL2.1)
+depends=(
+ gnutls
+ libgcrypt
+ libplist-git
+ libtasn1
+ libusbmuxd-git
+ libimobiledevice-glue-git
+)
+makedepends=(
+ autoconf-archive
+ cython
+ git
+ python
+ python-setuptools
+)
+optdepends=('python: for the Python bindings')
+provides=(libimobiledevice-1.0.so "libimobiledevice=$pkgver")
+conflicts=(libimobiledevice)
source=("git+https://github.com/libimobiledevice/libimobiledevice")
sha256sums=('SKIP')
@@ -32,10 +45,18 @@ prepare() {
build() {
cd libimobiledevice
- ./configure --prefix=/usr
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --without-openssl \
+ --with-gnutls
+ #sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool # not needed anymore (libtool honors $LDFLAGS now)
make
}
+check() {
+ cd libimobiledevice
+ make check
+}
+
package() {
cd libimobiledevice
make DESTDIR="$pkgdir" install