summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian 'gonX' Jensen2023-08-16 19:50:14 +0200
committerSebastian 'gonX' Jensen2023-08-16 19:50:14 +0200
commit1f9381b538a4187b1e1fed5e446a62c86301f6dd (patch)
tree2ce66b36671dbd46805487f15e90bf8a26c47fbc
parentdb9a64606b88e8b4f3312074c27affd03009cf6e (diff)
downloadaur-1f9381b538a4187b1e1fed5e446a62c86301f6dd.tar.gz
Update to the new repo packaging scripts
-rw-r--r--.SRCINFO15
-rw-r--r--OpenTabletDriver.desktop10
-rw-r--r--PKGBUILD49
-rw-r--r--notes.install12
-rw-r--r--opentabletdriver.service12
-rwxr-xr-xotd13
-rwxr-xr-xotd-gui3
7 files changed, 21 insertions, 93 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f9ccd6edcc1..3c3be79df106 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = opentabletdriver-git
pkgdesc = A cross-platform open source tablet driver
- pkgver = v0.7.0.0pre.r255.g1eee9d76
+ pkgver = v0.7.0.0pre.r554.gdbb0a1a5
pkgrel = 2
- url = https://github.com/OpenTabletDriver/OpenTabletDriver
+ url = https://opentabletdriver.net
install = notes.install
arch = x86_64
license = LGPL3
makedepends = git
makedepends = dotnet-sdk>=7.0
depends = dotnet-runtime>=7.0
- depends = dotnet-host>=7.0
depends = gtk3
depends = libevdev
optdepends = libxrandr: x11 display querying support
@@ -18,16 +17,8 @@ pkgbase = opentabletdriver-git
conflicts = opentabletdriver
options = !strip
source = git+https://github.com/OpenTabletDriver/OpenTabletDriver
- source = otd
- source = otd-gui
- source = opentabletdriver.service
- source = OpenTabletDriver.desktop
source = notes.install
sha256sums = SKIP
- sha256sums = 05b7792f0ee8ffcee40225dd750fe453800c511d228eff5bafe3dd6189390caf
- sha256sums = cdd143d2a18d0eb226585d796f39258a2c1575b31475c50d794ecbfab12d64d3
- sha256sums = 88f7d9ae1e9402cfbf9266ddf0de642195b64de13a3d5ce6f93460ba035cf7f2
- sha256sums = 4399359bf6107b612d10aaa06abb197db540b00a973cfec64c2b40d1fbbb2834
- sha256sums = cddf5b0928bc6e1d8d87ac503b4dd31536d956b1f37e7e3fa1c1b47a0ad23880
+ sha256sums = 5b9db850e29b66a218a165f2d109375e15416069d2c759cac79cc6af6b04688a
pkgname = opentabletdriver-git
diff --git a/OpenTabletDriver.desktop b/OpenTabletDriver.desktop
deleted file mode 100644
index 7eaa6bc46710..000000000000
--- a/OpenTabletDriver.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Version=OTD_VERSION
-Name=OpenTabletDriver
-Exec=/usr/bin/otd-gui
-Icon=otd
-Terminal=false
-Type=Application
-StartupNotify=true
-Categories=Accessories;
-X-Desktop-File-Install-Version=0.15
diff --git a/PKGBUILD b/PKGBUILD
index bd7c3ab19571..4b1760af1426 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,33 +5,26 @@ pkgname=opentabletdriver-git
_pkgname=OpenTabletDriver
_lpkgname=opentabletdriver
_spkgname=otd
-pkgver=v0.7.0.0pre.r255.g1eee9d76
+pkgver=v0.7.0.0pre.r554.gdbb0a1a5
pkgrel=2
pkgdesc="A cross-platform open source tablet driver"
arch=('x86_64')
-url="https://github.com/OpenTabletDriver/OpenTabletDriver"
+url="https://opentabletdriver.net"
license=('LGPL3')
-depends=('dotnet-runtime>=7.0' 'dotnet-host>=7.0' 'gtk3' 'libevdev')
+depends=('dotnet-runtime>=7.0' 'gtk3' 'libevdev')
optdepends=('libxrandr: x11 display querying support' 'libx11')
makedepends=('git' 'dotnet-sdk>=7.0')
provides=("opentabletdriver")
conflicts=("opentabletdriver")
install="notes.install"
+# unified binary dotnet releases break when stripped see https://github.com/dotnet/runtime/issues/54947
+options=('!strip')
source=('git+https://github.com/OpenTabletDriver/OpenTabletDriver'
- "$_spkgname"
- "$_spkgname-gui"
- "$_lpkgname.service"
- "$_pkgname.desktop"
"notes.install"
)
-options=(!strip) # sorry, seems like dotnet bug
sha256sums=('SKIP'
- '05b7792f0ee8ffcee40225dd750fe453800c511d228eff5bafe3dd6189390caf'
- 'cdd143d2a18d0eb226585d796f39258a2c1575b31475c50d794ecbfab12d64d3'
- '88f7d9ae1e9402cfbf9266ddf0de642195b64de13a3d5ce6f93460ba035cf7f2'
- '4399359bf6107b612d10aaa06abb197db540b00a973cfec64c2b40d1fbbb2834'
- 'cddf5b0928bc6e1d8d87ac503b4dd31536d956b1f37e7e3fa1c1b47a0ad23880')
+ '5b9db850e29b66a218a165f2d109375e15416069d2c759cac79cc6af6b04688a')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -58,32 +51,14 @@ build() {
PREFIX=$(git describe --long --tags | sed 's/-.*//;s/v//')
fi
- ./build.sh linux-x64 \
- /p:VersionPrefix="$PREFIX" \
- $EXTRA_OPTIONS
+ if check_option "strip" y; then
+ EXTRA_OPTIONS="/p:DebugType=None /p:DebugSymbols=false"
+ fi
- ./generate-rules.sh
+ ./eng/linux/package.sh --dog-food "false" --package Generic -- /p:VersionPrefix="$PREFIX" $EXTRA_OPTIONS
}
package() {
- cd "$srcdir"
-
- install -do root "$pkgdir/usr/share/$_pkgname"
-
- shopt -s nullglob
- cd "$srcdir/$_pkgname/bin"
- for binary in OpenTabletDriver.* *.pdb; do
- install -Dm 755 -o root "$binary" -t "$pkgdir/usr/share/$_pkgname"
- done
- cd "$srcdir"
-
- sed -i "s/OTD_VERSION/$pkgver/" "$_pkgname.desktop"
-
- install -Dm 644 -o root "$_pkgname/bin/99-$_lpkgname.rules" -t "$pkgdir/usr/lib/udev/rules.d"
- install -Dm 644 -o root "$_pkgname/$_pkgname.UX/Assets/$_spkgname.png" -t "$pkgdir/usr/share/pixmaps"
-
- install -Dm 755 -o root "$_spkgname" -t "$pkgdir/usr/bin"
- install -Dm 755 -o root "$_spkgname-gui" -t "$pkgdir/usr/bin"
- install -Dm 644 -o root "$_lpkgname.service" -t "$pkgdir/usr/lib/systemd/user"
- install -Dm 644 -o root "$_pkgname.desktop" -t "$pkgdir/usr/share/applications"
+ cd "${srcdir}/${_pkgname}"
+ cp -r ./dist/files/* "${pkgdir}/"
}
diff --git a/notes.install b/notes.install
index 19e4246c7173..c68a0ae63768 100644
--- a/notes.install
+++ b/notes.install
@@ -11,23 +11,22 @@ msg_starting() {
echo "The daemon can be started with:"
echo -e " $ ${GREEN}otd${RESET}"
echo "You can fork it to the background and use output redirection to a log file if desired."
- echo "A systemd user service is also provided and can be used instead:"
+ echo "A systemd user service is also provided and can be used instead, assuming you have a correct systemd user graphical-session.target set up:"
echo -e " $ ${GREEN}systemctl --user enable --now opentabletdriver.service${RESET}"
echo
}
msg_modules() {
- echo "You will have to manually disable built-in kernel modules in order for this driver to work properly."
- echo -e "This can be done by blacklisting the kernel module by creating a file in ${GREEN}/etc/modprobe.d/blacklist.conf${RESET} with a single line:"
- echo -e " ${GREEN}blacklist <module>${RESET}"
- echo "Where <module> is 'wacom' if you own a wacom tablet, and 'hid_uclogic' otherwise."
+ echo "You will have to manually unload built-in kernel modules (or reboot) in order for this driver to work properly."
echo "To unload the module immediately, run:"
echo -e " # ${GREEN}rmmod <module>${RESET}"
+ echo "Where <module> is 'wacom' if you own a wacom tablet, and 'hid_uclogic' otherwise."
echo
}
msg_faq() {
- echo -e "In case that you still have issues after following these instructions, the FAQ at ${GREEN}https://opentabletdriver.net/Wiki/FAQ/Linux${RESET} may help."
+ echo -e "As of version 0.6.2.0, having the package installed will ${BOLD}block${RESET} any modules related to drawing tablets"
+ echo -e "In the case that you still have issues after following these instructions, the FAQ at ${GREEN}https://opentabletdriver.net/Wiki/FAQ/Linux${RESET} may help."
echo
}
@@ -56,4 +55,5 @@ post_upgrade() {
echo -e "You may want to clear the contents of the ${GREEN}Plugins/${RESET} and ${GREEN}Configurations/${RESET} folder in ${GREEN}~/.config/OpenTabletDriver/${RESET}"
echo
fi
+ msg_faq
}
diff --git a/opentabletdriver.service b/opentabletdriver.service
deleted file mode 100644
index 96e76e3da8d1..000000000000
--- a/opentabletdriver.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=OpenTabletDriver Daemon
-StartLimitIntervalSec=300
-StartLimitBurst=5
-
-[Service]
-ExecStart=/usr/bin/otd
-Restart=on-failure
-RestartSec=8s
-
-[Install]
-WantedBy=default.target
diff --git a/otd b/otd
deleted file mode 100755
index f35332e14f37..000000000000
--- a/otd
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/bash
-cd /usr/share/OpenTabletDriver
-if [ $# -eq 0 ]
-then
- if [[ ! -v DISPLAY ]] && [[ ! -v WAYLAND_DISPLAY ]]
- then
- echo "DISPLAY and/or WAYLAND_DISPLAY is not set"
- exit 64
- fi
- ./OpenTabletDriver.Daemon
-else
- ./OpenTabletDriver.Console "$@"
-fi
diff --git a/otd-gui b/otd-gui
deleted file mode 100755
index 644ff882b4fe..000000000000
--- a/otd-gui
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/bash
-cd /usr/share/OpenTabletDriver
-./OpenTabletDriver.UX.Gtk "$@"