summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Prager2022-10-30 10:13:28 +0100
committerMichael Prager2022-10-30 10:22:09 +0100
commit20a4869814c993ac1ff95b4e1612e076253949f8 (patch)
tree0dcec9c3c04718ce619ab2e69619be33b1127f17
parent4f7c24cb05ca182053a82efdd1a2305d1e67299b (diff)
downloadaur-20a4869814c993ac1ff95b4e1612e076253949f8.tar.gz
updated gcconfig.pri according to upstream commit 5a771809579c619aefdd52d3ea596f0a2372f315 and enabled QMAKE_MOVE which finally makes 3628.patch for building using bison 3.7 obsolete
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--gcconfig.pri13
3 files changed, 9 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c16b1c7443c2..1e97065854ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -46,11 +46,9 @@ pkgbase = golden-cheetah-git
source = GoldenCheetah.desktop
source = gc.png
source = gcconfig.pri
- source = https://patch-diff.githubusercontent.com/raw/GoldenCheetah/GoldenCheetah/pull/3628.patch
sha256sums = SKIP
sha256sums = 6c4f56ba53f2deadec5b16efdecd1311653c2dca2c0378f951672a9b7186f09d
sha256sums = e12471b7864adc877c34cd4cfb23451cae7648b9c8109f400f1af883d4c8cd4e
- sha256sums = 0cac4a391dc360df375329122a5835fd50b3808ca17451bf56c9221a2710abb4
- sha256sums = 843d4edf5b49e7620f7dcb58de7fcb65b833e22a1a6273afafda821c3f44da3e
+ sha256sums = c018c5d36739a2a369d69f2fb0247b641b9e0da1ef29321058a2fad361fb6e4f
pkgname = golden-cheetah-git
diff --git a/PKGBUILD b/PKGBUILD
index 23be4efc0550..597dce707cc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,25 +14,17 @@ depends=('qt5-base' 'qt5-svg' qt5-location qt5-declarative qt5-webchannel qt5-we
optdepends=('vlc' 'srmio' 'libftd2xx' 'libkml' 'libical' 'libusb-compat' 'libsamplerate' 'r')
options=('!strip' '!buildflags' 'staticlibs')
conflicts=('golden-cheetah-rc' 'golden-cheetah-dev' 'golden-cheetah')
-source=('golden-cheetah::git+https://github.com/GoldenCheetah/GoldenCheetah.git'
-GoldenCheetah.desktop gc.png gcconfig.pri
-'https://patch-diff.githubusercontent.com/raw/GoldenCheetah/GoldenCheetah/pull/3628.patch')
+source=('golden-cheetah::git+https://github.com/GoldenCheetah/GoldenCheetah.git' GoldenCheetah.desktop gc.png gcconfig.pri)
sha256sums=('SKIP'
'6c4f56ba53f2deadec5b16efdecd1311653c2dca2c0378f951672a9b7186f09d'
'e12471b7864adc877c34cd4cfb23451cae7648b9c8109f400f1af883d4c8cd4e'
- '0cac4a391dc360df375329122a5835fd50b3808ca17451bf56c9221a2710abb4'
- '843d4edf5b49e7620f7dcb58de7fcb65b833e22a1a6273afafda821c3f44da3e')
+ 'c018c5d36739a2a369d69f2fb0247b641b9e0da1ef29321058a2fad361fb6e4f')
pkgver() {
cd "${srcdir}/golden-cheetah"
printf "%s" "$(git describe --long --tags --exclude v3.5-RC2 | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
-prepare() {
- cd "${srcdir}/golden-cheetah/"
- patch --forward --strip=1 --input="${srcdir}/3628.patch"
-}
-
build() {
cd "${srcdir}/golden-cheetah/"
diff --git a/gcconfig.pri b/gcconfig.pri
index 50367e27732a..589b71e291ae 100644
--- a/gcconfig.pri
+++ b/gcconfig.pri
@@ -82,16 +82,15 @@ QMAKE_CXXFLAGS += -O3
# You may need to specify the full path if things don't work.
#QMAKE_LEX = flex
#QMAKE_YACC = bison
+# If you are using bison 3.7 or higher, uncomment the line below
+QMAKE_MOVE = cp
# If you're compiling with nmake and VC then you
# will likely also use win_flex and win_bison
# so uncomment below
-#QMAKE_LEX = win_flex
-#QMAKE_YACC = win_bison
-#win32 {
-# QMAKE_YACC = bison --file-prefix=y -t
-# QMAKE_MOVE = cmd /c move
-# QMAKE_DEL_FILE = rm -f
-#}
+#QMAKE_LEX = win_flex --wincompat
+#QMAKE_YACC = win_bison --file-prefix=y -t
+# If you are using bison 3.7 or higher, uncomment the line below
+#QMAKE_MOVE = copy
# If you want SRM download support you must install SRMIO
# http://www.zuto.de/project/srmio/