summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Krivopalov2018-06-08 18:25:33 -0700
committerVladimir Krivopalov2018-06-08 18:25:33 -0700
commit21b76fb33a9a55a4163d745cf5875af0e1c54eb5 (patch)
tree43020859fea1027190b9308be537e778aca0383a
parent257e3ab293a1542e790c7ce8319e294c26f3ea52 (diff)
downloadaur-21b76fb33a9a55a4163d745cf5875af0e1c54eb5.tar.gz
Specify gcc-7 and g++-7 as the compiler to use
Signed-off-by: Vladimir Krivopalov <vladimir.krivopalov@gmail.com>
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8d8283f5171..54c25f34c04c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -57,7 +57,7 @@ build() {
cd "$srcdir/${pkgname}"
sed -i -e 's@sizeof(byte)@sizeof(CryptoPP::byte)@g' md5_hasher.hh repair/repair.cc
sed -i -e 's@reinterpret_cast<const byte@reinterpret_cast<const CryptoPP::byte@g' md5_hasher.hh repair/repair.cc
- ./configure.py --mode=release
+ ./configure.py --mode=release --c-compiler=gcc-7 --compiler=g++-7
JOBS=`nproc --all`
# It turns out that on maximum jobs compiler often runs out of memory and crashes
# Let's be conservative and assign only half of the available CPU threads