summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Hentschel (hpmachining)2023-04-16 19:48:29 -0400
committerPaul Hentschel (hpmachining)2023-04-16 19:56:37 -0400
commit23dc5c244f3022621003bc78801f394ce549b1c1 (patch)
treec9e43333f1b7b4b3a6feec6c0f0a5a5dc66eb118
parent72730d61485f42f213244e6a2231a78638c036ce (diff)
downloadaur-23dc5c244f3022621003bc78801f394ce549b1c1.tar.gz
Updated to 1.8.0
Updated to tag 1.8.0 to support CAMotics 1.3.0
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--0001_python3_fix.patch89
-rw-r--r--0001_v8_sandbox_enable.patch10
-rw-r--r--0002_openssl_test.patch12
-rw-r--r--PKGBUILD33
6 files changed, 34 insertions, 132 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16f151395f8a..6dc08f65bcbd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = cbang
pkgdesc = a library of cross-platform C++ utilities
- pkgver = 1.3.1
- pkgrel = 5
+ pkgver = 1.8.0
+ pkgrel = 1
url = https://github.com/CauldronDevelopmentLLC/cbang
arch = x86_64
license = LGPL2.1
- checkdepends = python2
+ checkdepends = python
+ checkdepends = python-six
makedepends = scons
- depends = v8-3.14
+ depends = v8-r
depends = libevent
depends = sqlite
depends = re2
@@ -16,11 +17,9 @@ pkgbase = cbang
depends = bzip2
depends = expat
optdepends = mariadb-libs: MariaDB database support
- source = cbang-1.3.1.tar.gz::https://github.com/CauldronDevelopmentLLC/cbang/archive/1.3.1.tar.gz
- source = 0001_python3_fix.patch
- source = 0002_openssl_test.patch
- sha256sums = 23bf2997ac8438592545f1cde7cd076ba759f3f4a01e6540cdf45a97616eaaef
- sha256sums = 4047b8dcaeae671d631e4cfbc896833c861ecf1a1e1c3d873095d901515f7e11
- sha256sums = 254d6e33e1a53eb5edc80f0a4a660232562b79b8fec46ffccf12fbdb4b3836e3
+ source = cbang-1.8.0.tar.gz::https://github.com/CauldronDevelopmentLLC/cbang/archive/refs/tags/1.8.0.tar.gz
+ source = 0001_v8_sandbox_enable.patch
+ sha256sums = 4be28b0aa0d024e5c9fd274264bed7f82551219414c12c45e35afd8946f6e7d7
+ sha256sums = 75eff0bcd04293990f8dfb0771562356ccac2a7f40a06df0c0ba515fcdf4126a
pkgname = cbang
diff --git a/.gitignore b/.gitignore
index b8f3bd3a518c..7735b4612827 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,5 +2,4 @@
!PKGBUILD
!.SRCINFO
!.gitignore
-!0001_python3_fix.patch
-!0002_openssl_test.patch
+!*.patch
diff --git a/0001_python3_fix.patch b/0001_python3_fix.patch
deleted file mode 100644
index e1c24c6bb244..000000000000
--- a/0001_python3_fix.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-diff -ruN a/config/__init__.py b/config/__init__.py
---- a/config/__init__.py 2019-02-08 04:16:27.000000000 -0500
-+++ b/config/__init__.py 2019-08-18 16:08:36.326638519 -0400
-@@ -277,7 +277,7 @@
- updated_csig = set()
-
-
--def decider_hack(dep, target, prev_ni):
-+def decider_hack(dep, target, prev_ni, *args, **kwargs):
- from SCons.Util import MD5signature
-
- #print('%s ?= %s %s' % (dep, target, prev_ni.csig))
-diff -ruN a/config/resources/__init__.py b/config/resources/__init__.py
---- a/config/resources/__init__.py 2019-02-08 04:16:27.000000000 -0500
-+++ b/config/resources/__init__.py 2019-08-18 16:13:53.866632487 -0400
-@@ -18,7 +18,7 @@
-
-
- def start_file(ctx, path):
-- f = open(path, 'wb')
-+ f = open(path, 'w')
-
- note = ('WARNING: This file was auto generated. Please do NOT '
- 'edit directly or check in to source control.')
-@@ -108,7 +108,8 @@
- while True:
- count = 0
- for c in f.read(102400):
-- write_string(ctx, out, '%d,' % ord(c))
-+ if not isinstance(c, int): c = ord(c)
-+ write_string(ctx, out, '%d,' % c)
- count += 1
-
- if count == 0: break
-@@ -219,7 +220,7 @@
- name = str(target[0])
- data_dir = os.path.splitext(name)[0] + ".data"
- target += get_targets(exclude, str(source[0]), data_dir, [0])
-- print(map(str, target))
-+ print(tuple(map(str, target)))
- Depends(target, FindFile('cbang/util/Resource.h', env['CPPPATH']))
- return target, source
-
-diff -ruN a/SConstruct b/SConstruct
---- a/SConstruct 2019-02-08 04:16:27.000000000 -0500
-+++ b/SConstruct 2019-08-18 16:08:36.326638519 -0400
-@@ -35,7 +35,7 @@
- lines = os.popen('svn status -v').readlines()
- lines = filter(lambda l: len(l) and l[0] in 'MA ', lines)
- files = map(lambda l: l.split()[-1], lines)
-- files = filter(lambda f: not os.path.isdir(f), files)
-+ files = list(filter(lambda f: not os.path.isdir(f), files))
-
- tar = env.TarBZ2Dist('libcbang' + libversion, files)
- Alias('dist', tar)
-@@ -89,7 +89,7 @@
- # Build in 'build'
- import re
- VariantDir('build', 'src', duplicate = False)
--src = map(lambda path: re.sub(r'^src/', 'build/', str(path)), src)
-+src = list(map(lambda path: re.sub(r'^src/', 'build/', str(path)), src))
-
-
- # Resources
-diff -ruN a/src/libevent/SConscript b/src/libevent/SConscript
---- a/src/libevent/SConscript 2019-02-08 04:16:27.000000000 -0500
-+++ b/src/libevent/SConscript 2019-08-18 16:22:45.103289070 -0400
-@@ -190,7 +190,11 @@
- # TODO Define EVENT__HAVE_WORKING_KQUEUE if kqueue works correctly w/ pipes
-
- # to_def
-- from string import maketrans
-+ try:
-+ from string import maketrans
-+ except ImportError:
-+ def maketrans(_from, _to): return ''.maketrans(_from, _to)
-+
- trans = maketrans('/. *', '___P')
-
- def to_def(name):
-@@ -330,7 +334,7 @@
-
- # OpenSSL
- if not env.CBConfigEnabled('openssl'):
-- src = filter(lambda f: not 'openssl' in f.path, src)
-+ src = list(filter(lambda f: not 'openssl' in f.path, src))
-
- # libkern
- conf.CBCheckLib('kern')
diff --git a/0001_v8_sandbox_enable.patch b/0001_v8_sandbox_enable.patch
new file mode 100644
index 000000000000..86591baf212a
--- /dev/null
+++ b/0001_v8_sandbox_enable.patch
@@ -0,0 +1,10 @@
+diff -ruN a/src/cbang/js/v8/V8.h b/src/cbang/js/v8/V8.h
+--- a/src/cbang/js/v8/V8.h 2023-04-12 13:01:26.846888687 -0400
++++ b/src/cbang/js/v8/V8.h 2023-04-12 13:02:23.030223080 -0400
+@@ -41,5 +41,6 @@
+ #define V8STDINT_H_
+
+ #define V8_ENABLE_CHECKS
++#define V8_ENABLE_SANDBOX
+
+ #include <v8.h>
diff --git a/0002_openssl_test.patch b/0002_openssl_test.patch
deleted file mode 100644
index b353396f57ec..000000000000
--- a/0002_openssl_test.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ruN a/tests/SConstruct b/tests/SConstruct
---- a/tests/SConstruct 2023-04-10 21:09:07.963333339 -0400
-+++ b/tests/SConstruct 2023-04-10 21:29:00.140000015 -0400
-@@ -21,7 +21,7 @@
- tests = []
- for test in Glob('*Tests'):
- if str(test) in ('cryptoTests', 'httpTests', 'iostreamTests', 'serverTests'
-- ) and not env.CBConfigEnabled('openssl'):
-+ ) and env.CBConfigEnabled('openssl'):
-
- for t in Glob('%s/*Test' % test):
- open('%s/disable' % t, 'w').close()
diff --git a/PKGBUILD b/PKGBUILD
index 9ff68199f65d..96426ff18336 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Paul Hentschel (hpmachining)
pkgname=cbang
-pkgver=1.3.1
-pkgrel=5
+pkgver=1.8.0
+pkgrel=1
pkgdesc="a library of cross-platform C++ utilities"
arch=('x86_64')
url="https://github.com/CauldronDevelopmentLLC/cbang"
license=('LGPL2.1')
depends=(
- 'v8-3.14'
+ 'v8-r'
'libevent'
'sqlite'
're2'
@@ -21,47 +21,42 @@ makedepends=(
'scons'
)
checkdepends=(
- 'python2'
+ 'python'
+ 'python-six'
)
optdepends=(
'mariadb-libs: MariaDB database support'
)
source=(
- "$pkgname-$pkgver.tar.gz::https://github.com/CauldronDevelopmentLLC/cbang/archive/$pkgver.tar.gz"
- "0001_python3_fix.patch"
- "0002_openssl_test.patch"
+ "$pkgname-$pkgver.tar.gz::https://github.com/CauldronDevelopmentLLC/cbang/archive/refs/tags/$pkgver.tar.gz"
+ "0001_v8_sandbox_enable.patch"
)
-sha256sums=('23bf2997ac8438592545f1cde7cd076ba759f3f4a01e6540cdf45a97616eaaef'
- '4047b8dcaeae671d631e4cfbc896833c861ecf1a1e1c3d873095d901515f7e11'
- '254d6e33e1a53eb5edc80f0a4a660232562b79b8fec46ffccf12fbdb4b3836e3')
+sha256sums=('4be28b0aa0d024e5c9fd274264bed7f82551219414c12c45e35afd8946f6e7d7'
+ '75eff0bcd04293990f8dfb0771562356ccac2a7f40a06df0c0ba515fcdf4126a')
prepare() {
cd "$pkgname-$pkgver"
- patch -p1 -i "../0001_python3_fix.patch"
- patch -p1 -i "../0002_openssl_test.patch"
+ patch -p1 -i "../0001_v8_sandbox_enable.patch"
}
build() {
cd "$pkgname-$pkgver"
- scons disable_local="libevent sqlite3 re2 libyaml zlib bzip2 expat" \
- cxxflags="-fpermissive" \
- with_openssl=false
+ scons cxxstd="c++17" disable_local="libevent sqlite3 re2 libyaml zlib bzip2 expat"
}
check() {
cd "$pkgname-$pkgver/tests"
scons
- python2 ./testHarness
+ python ./testHarness
}
package() {
cd "$pkgname-$pkgver"
scons install prefix="$pkgdir/opt/$pkgname" \
- disable_local="libevent sqlite3 re2 libyaml zlib bzip2 expat" \
- cxxflags="-fpermissive" \
- with_openssl=false
+ cxxstd="c++17" disable_local="libevent sqlite3 re2 libyaml zlib bzip2 expat"
install -m644 lib/libcbang.a -t "$pkgdir/opt/$pkgname/lib"
install -m644 lib/libcbang-boost.a -t "$pkgdir/opt/$pkgname/lib"
cp -a config/ "$pkgdir/opt/$pkgname/config/"
cp -a src/boost/boost/ "$pkgdir/opt/$pkgname/include/"
+ cp -a include/cbang/ "$pkgdir/opt/$pkgname/include/"
}